IRC channel logs

2025-02-24.log

back to list of logs

<wingo>rlb: didn't see that, i should take a look
<wingo>ah you are on it :) great
<wingo>when i added lto, i think thin objects were the state of the art
<rlb>wingo: ahh, ok. And I *was* on it, but wandered off -- glad you reminded me :)
<lechner>Hi, is there a way to "display" '(values 1 2)'?
<lechner>or otherwise serialize it?
<rlb>I suppose it depends on what you need -- i.e. (values 1 2) is a representation suitable for some purposes.
<sudden>lechner: (display (call-with-values (lambda () (values 1 2)) (lambda a a)))
<daviid>lechner: (receive (. args) (values 1 2 3) args)
<lechner>i would like to serialize a procedure's return value, generally
<dthompson>call-with-values is what you want, then
<dthompson>since procedures are not guaranteed to return a single value in the general case. they can return 0 or more.
<daviid>(receive (. args) (values) args) => ()
<lloda>a lot of data types in Guile don't have literal syntax. You have to write your own reader
<lechner>sudden / rlb / daviid / dthompson / thanks!