IRC channel logs

2025-02-23.log

back to list of logs

<simendsjo>I'm unable to get regexp/newline to work. Whenever I add the flag, the regexp no longer matches anything. E.g. the following doesn't match anything: (list-matches "^\\w+" "foo bar\nbaz qux" regexp/newline)
<lilyp>you are using a flag for make-regexp in regexp-exec (list-matches)
<lilyp>try (list-matches (make-regexp "^\\w+" regexp/newline) "foo bar\nbaz qux")
<simendsjo>lilyp: Thanks! So the flags in list-matches is not the same as flags in make-regexp...?
<lilyp>nope
<lilyp>the only valid flags are notbol and noteol
<simendsjo>Is there more documentation for Guile than the one I fonud at https://www.gnu.org/software/guile//manual/html_node/Regexp-Functions.html?
<lilyp>(which disable "^" and "$" respectively)
<lilyp>read regexp-exec closely
<lilyp>then list-matches
<dsmith>simendsjo, Also remember, the regexp is the system C lib implementation.