IRC channel logs

2025-02-17.log

back to list of logs

<cow_2001>something real strange in this line https://git.savannah.gnu.org/cgit/guile.git/tree/module/ice-9/peg/codegen.scm#n95
<cow_2001>the procedure definition right beneath it is (define (cg-string pat accum) ...) but the example is (cg-string syntax "abc" 'body)
<cow_2001>it is the same in all "e.g." comments
<cow_2001>is this a stale comment?
<old>.
<mwette>rlb: I've been looking through your utf-8 stuff a bit, while thinking of how an editor might work in scheme. First, are stringbufs exposed to scheme? Second, given the sparse lookup, is there something like a stringbuf cursor? That would cache a byte offset and character offset, so one could call `(forward-char cursor)' -> cursor.
<old>would like to have support in fibers for async waiting on PID and pipes (open-pipe)
<ttz>Hi, is there a way to evaluate a symbole in the current (not-top-level) environment? For example such that (let ((x 1)) (eval 'x (?))) returns 1?
<civodul>ttz: hi! yes, see “Local Evaluation” in the manual
<civodul>‘eval’ should be used with care though
<ttz>arg I have been turning around this section for ages without seeng it... thanks!
<ttz>And is there a way to reach the code of a procedure once it is defined?
<ttz>(procedure-source) seems only to return #f