IRC channel logs

2022-11-04.log

back to list of logs

<w0ll3q1uszxabiwo><w0ll3q1uszxabiwo> "https://github.com/libfive/..." <- .
<dsmith>So there are folds and for-each and map. Usually applying a function over some list(s)
<dsmith>I've several times needed to apply a list of function to the same argument/input.
<dsmith>IS there a general thing/concept/funtion for this? I suspect there is in Haskell
<singpolyma>In Haskell it would be map ($arg) listOfFuncs
<singpolyma>So (map (lambda (f) (f arg)) listOfFuncs)
<lloda>yeah that's just map. srfi-26 lets you do (cut <> arg). idk if it has a particular name
<rekado>(shadow-ban strikes again…)
<rekado>(map (lambda (f x) (f x)) (list 1+ 1- number->string) (list 1 2 3))
<rekado>is there a name for (lambda (f x) (f x)) ?
<rekado>it’s not quite “apply”
<civodul>rekado: not that i know of
<rekado>could also do (map apply fs (map list args))
<rekado>not sure if that’s clearer
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>Yeah, it's no trouble to (map (lambda (f) (f arg)) (list of f's)). Just wondering is there is a name for that (lambda (f) (f arg))
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>!uptime
<sneek>I've been running for 3 days
<sneek>This system has been up 1 week, 2 days, 13 hours, 50 minutes
<old>Is there any advantage of using `export-syntax` in a module declaration instead of plain `export`?
<old>I don't see anything in the manual concerning this
<nckx>civodul: Seriously, please consider ‘/mode #guile +R’ && ’/mode #guile -q $~a’ to stop these shocking accusations of the shadowbanz.
<civodul>nckx: is "$~a" to be understood literally?
<civodul>ACTION is clueless
<nckx>Yes.
<nckx>From what I can see, you did it right.
<nckx>rekado can test it if they like.
<nckx>…that ‘Yes’ was… poorly placed.
<rekado>I’ll probably lose identification in a day.
<rekado>I thought znc would authenticate me automatically, but that doesn’t seem to work and I’m too phlegmatic to check if this can be changed in the configuration.
<drakonis>use sasl or config znc to send a message to nickserv
<old>Could someone explain to me what's all that talk about shadow ban lately? I'm kind of out of the loop
<ArneBab>old: in which context?
<rekado>old: up until a few minutes ago only people who were identified with nickserv could send a message to #guile
<rekado>without prior identification you would not get an error when sending a message. It just wouldn’t be relayed.
<rekado>in my atrophied vocabulary the closest noun matching this phenomenon is the effective “shadow ban”
<nckx>To be clear: <only people who were identified with nickserv could send a message> still the case. <would not get an error when sending> not the case.
<nckx>Whether or not to keep the original restriction at all is, fortunately, not my monkey circus.
<nckx>It was presumably there for a reason, and might be a good idea in a channel with low op coverage.
<rekado>seeing an error is a great improvement
<rekado>beats having to compulsively check http://logs.guix.gnu.org/guile/
<old>rekado: Oh I see. That does not seem to impact me then
<old>Sounds terrible to be shadow ban :/
<old>Like you think nobody is answering you for some reason, but really you're just quietly muted
<nckx>It was not deliberate, just a side effect.
<old>Yes I understand
<nckx>Until recently, I don't think there was a better way to do this. +R is new. By IRC standards, it's gooder.
<old>Clearly having a message that says that you should identify yourself to NickServ until then you're muted, is great
<nckx>It's a revolutionary idea whose time has come.
<old>Is this really necessary? I mean, a spammer could just create many account with NickServ no?
<nckx>Yes, but in practice, they don't.
<old>okay
<nckx>Barring some obsessive exceptions, spammer and work ethos seem to sufficiently conflict just enough to make this ‘work’.
<old>I wonder what is the point in spamming a IRC channel of a community though
<old>I mean, where is there to gain from that?
<old>s/where/what/
<nckx>Speaking generally, not about #guile: a significant share of problems aren't actually caused by rational actors, against which your arguments make perfect sense. Making it ‘hard’ for an emotional user to open up a Webchat browser tab in rage is actually really effective, even if we're conditioned to think it's not.
<nckx>As for what's to gain: your guess is as good as mine. Often: attention. It's scarce.
<old>I see. So this restriction for NickServ is more a deterrent against rage and troll
<old>make sens
<nckx>I didn't set it, but that's why I might.
<dsmith-work>So what does "with the flags +v or +o within a channel" meean: https://libera.chat/guides/faq#flood-exemptions-for-bots
<dsmith-work>How are those set and who can set them?
<nckx>/msg chanserv flags #guile
<nckx>civodul & wingo.
<nckx>But since this is working around a bug of sorts, I'd chat with staff first.
<nckx>Not being subject to those limits might accidentally expose sneek to more severe anti-spam measures.
<spk121>civodul: for what it is worth, cannot reproduce your mem problem with the example on debbugs
<spk121>on fedora, tho
<civodul>sneek: later tell spk121 you don't see heap growth on https://issues.guix.gnu.org/59021 ?
<sneek>Got it.
<civodul>i'd be curious to see what others see