IRC channel logs

2022-10-23.log

back to list of logs

<apteryx>sneek: later tell mwette the problem I'm now trying to solve is the "expanding a binary tree as it is traversed" test at https://paste.debian.net/1257994/
<sneek>Will do.
<apteryx>hm, so perhaps foldts is not what I want here; I'm after creating a tree this time around, not simply navigating it.
<lilyp>if you want a tree -> tree mapping, foldts might still be "it"
<lilyp>if you want to generate a tree from nothing then maybe not
<rekado_>apteryx: is this what you want? https://elephly.net/paste/1666511807.html
<dthompson>lilyp: haven't made any announcements yet but guile-sdl2 0.8.0 is available now
<lilyp>0.8.0? Are there any serious changes from 0.7.0?
<dthompson>lilyp: nothing major
<dthompson>some new bindings and bug fixes
<apteryx>rekado_: looks like it! thank you! that's very elegantly expressed; I'll study it
<apteryx>rekado_: perhaps the predicate should test for list? instead of pair?
<civodul>apteryx: note that 'list?' is O(n)
<rekado_>apteryx: “pair?” is quick and usually quite enough if you know that your inputs are either atoms or lists.
<spk121>woohoo (sorta) - I got the 64-bit MinGW Guile build down to just 44 test failures / errors
<apteryx>rekado_: thanks; when I ,trace its execution, I see list? calls; I'm guessing as a map input validation
<lampilelo>indeed, 'map' functions from boot-9.scm, srfi/srfi-1.scm and scheme/base.scm call 'list?', but not the one from rnrs/base.scm, the one from rnrs checks for circular lists as it maps over values in one go
<lampilelo>'list?' is written entirely in c though, i wonder how do they compare in benchmarks