IRC channel logs

2022-10-17.log

back to list of logs

<old>I think there's a race conditon with join-thread and cancel-thread.
<old>Can someone confirm that they also get a deadlock by running this? https://paste.sr.ht/~old/96f3e3151b16008ce922de18afcc302e80969d68
<old>Might takes multiple run. `while guile race-condition.scm; do :; done` should helps reproduce
<old>I think that canceling a thread too early results in undefined behavior
<old>In fact it seems that trying to get an object property of the thread (thread-join-data or %thread-results) deadlock sometime
***Server sets mode: +ntz
<spk121>janneke: in that mingw branch, you put a bunch of effort messing with file name functions so that it would cross build
<spk121>Does cross-building it actually work?
<janneke>spk121: sure
<janneke>i've added a guix recipe
<janneke> https://git.savannah.nongnu.org/cgit/guile.git/commit/?h=wip-mingw&id=c39c56ca70796ae8a87a14b499859f47d4cb5d2b
<janneke>err
<janneke> https://git.savannah.gnu.org/cgit/guile.git/commit/?h=wip-mingw&id=c39c56ca70796ae8a87a14b499859f47d4cb5d2b
<spk121>janneke: cool
<sneek>Welcome back dsmith-work!
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>Monday Greetings, Guilers
<sneek>wb tohoyn :D
<tohoyn>sneek: botsnack
<sneek>:)
<stis>Hey guilers!
<daviid>sneek: later tell tohoyn I finalized and pushed virtual function 'full support' in g-golf, in the devel branch, documented as well, in the source tree and uploaded, here https://www.gnu.org/software/g-golf/manual/html_node/VFunc-Alley.html - a (wip) peg-solitaire.scm example as well, here https://paste.centos.org/view/12131dfe (url valid for another 7h, i'll repaste if 'lost') which mimic the gtk4 peg-solitaire.c example, which I need
<daviid>to complete it with drag and drop and the game rules, but it fully exposes the VFunc part ...
<sneek>Got it.
<a12l>A question to you people that know Clojure, when you start a new project (everything between a one line script, to a self-aware AI): when do you decide to use Guile, and when do you decide to use Clojure?
<dsmith-work>daviid: Pretty sure the bot didn't get "to compltete ..."
<daviid>dsmith-work: ah, tx
<daviid>sneek: later tell tohoyn ... the peg-solitaire example ... which I need to complete it with drag and drop and the game rules, but it fully exposes the VFunc part ...
<sneek>Got it.
<old>Yoo
<old>I've made this if anyone find it interesting. https://git.sr.ht/~old/guile-parallel
<daviid>a12l: see https://git.sr.ht/~rlb/lokke
<old>Feedbacks and requests are welcome :-)
<a12l>daviid: I'm a beginner, so don't know much and don't have experience. Does that "layer" work seamlessly, or is the result that you get another "layer" that work often, but not always? Know that ease of defining new "language constructs" is one of the big things about Lisps, but know how well it actually works.
<a12l>E.g., would Lokke work seamlessly for Guix configurations?
<a12l>It would be amazing if it did, but I'm skeptical.
<daviid>a12l: (not answering yur quiz, completing my 2c comment) - fwiw, unless for a 'real job', meaning i would be forced to, i'd rather use kawa scheme then clojure, if the 'all reason' is to have to run on top of a jre, otherwise, always prefer guile, as i said, my 2c
<daviid>no, lokke would not seamlessly let you configure guix, but you may ask guix quiz in #guix
<rlb>a12l: I also wouldn't recommend lokke right now for anything "serious". It's likely more of interest to anyone who might like to help out.
<rlb>But it does have very direct interop (intentionally) with guile.
<rlb>i.e. it's trivial to call guile functions directly, etc.
<a12l>daviid: Thanks for your opinion! Is the reason why you prefer Guile over Clojure what you prefer Scheme in general over Clojure, or is it because you just prefer GNU projects?
<a12l>rlb: Thanks for the info! What's your opinion on what projects Guile is best for, and what projects Clojure is best for?