IRC channel logs

2022-10-04.log

back to list of logs

<wingo>rekado: fwiw running mt-gcbench as 3 8 8 means with 3x the minimum heap size, 8 mutator threads, and 8 collector threads. whippet currently has a limit of 8 collector threads, could tweak of course. total workload is the same per mutator and heap size scales linearly with # of mutator threads (for that benchmark), so if a gc scaled perfectly, adding mutator threads would result in the same elapsed time
<wingo>but in practice there are limitations; we try to limit serial phases in gc but there are a couple, there are some synchronization costs, and # of mutator threads is capped
<wingo>er
<wingo># collector threads is capped, i mean
<wingo>moo
<tohoyn>I'm trying to build guile 3.0.8-2 debian packages in a virtualbox VM containing debian 11.5.0. Now test case web-server.test fails, see https://paste.debian.net/1255930/. When I do the same build in my host computer (with Debian 11) everything works fine. Can anybody help with this?
<rekado>tohoyn: do you have basic networking in that VM? The test tries to connect to http://localhost:8885. Make sure that “localhost” maps to 127.0.0.1
<tohoyn>rekade: tx
<tohoyn>s/rekade/rekado/
<tohoyn>sneek: botsnack
<sneek>:)
<tohoyn>File /etc/hosts contains line "127.0.0.1 localhost"
<tohoyn>adapter 1 is connected to NAT
<tohoyn>there is some "Port forwarding" button in the VM settings
<tohoyn>ping localhost works
<tohoyn>but it seems that localhost is defined to "::1". same on my host machine.
<sneek>tohoyn: wb!!
<a12l>Someone here that have a basic Emacs config with corfu-terminal and geiser? I'm having some problem getting it working, so I want to look at a working example to see what I'm doing wrong
<lilyp>I don't have corfu-terminal, but corfu+geiser works decently well imho
<lilyp>you might want to use this leaf tho: https://paste.gnome.org/gHF8qHIog
<lilyp>that way, geiser won't bug you when you haven't run M-x run-guile yet
<jao>i don't know what a leaf is, but recent versions of geiser don't bug you either
<lilyp>good to know
<lilyp>leaf is a "declarative" way of managing package configurations easily; basically it's a fancier eval-after-load
<jpoiret>that when clause won't trigger on autoload, won't it?
<jpoiret>it's a use-package clone, if you're familiar with that one
<a12l>lilyp: I'm trying to avoid abstractions now, before I've had the change to read the source code and know what they're doing.
<jpoiret>just use with-eval-after-load then
<a12l>I'm in a bit of "anti-abstraction" phase.
<a12l>From some testing now it seems that Geiser doesn't "connect" to my Scheme buffer :/
<old>Did you change the module in Geiser? `,m (my module)`
<a12l>Even if I've started a Guile repl inside Emacs using `geiser` :/
<a12l>Is all code in Scheme automatically written in a module? (I'm a Guile beginner)
<a12l>I haven't manually switched module in the REPL
<a12l>And the only code I've written inside the .scm file is `(define foo (+ 1 2 3))`. When I'm trying to see what completion suggestion I get after having written `(+ fo` I don't get `foo` as a suggestion.
<lilyp>I'm pretty sure geiser doesn't automatically parse the whole file for you, you need to eval it first
<old>Yes. `C-c C-b` in the buffer I think
<old>You should have some completation like `call-with-input-file` though
<old>s/comlpetation/completion/
<old>I personnaly use company for that and it works okay
<lilyp>As long as it isn't compleation, you're fine.
<a12l>thanks! Now it syncs up
<a12l>So nothing wrong with how I've setup Geiser at least
<a12l>But corfu still doesn't want to show its popup
<old>Usually if you `C-c C-b` in a file, it will evaluate in the defined module of the file. So you don't have to change module in the REPL for evaluating change in another buffer
<old>Try `M-x completion-at-point`? Perhaps it will pop
<a12l>Just suggestions in the minibuffer
<old>Hmm. I don't know how corfus works, but usually you should get a popup from your auto-completion engine
<old>Does it works as expected with other language?
<a12l>My init.el: https://gist.github.com/a12l/2b2ddf792049d2fdfbbe52d9094a4d3d
<a12l>Haven't tested really with other language, I've just configured emacs for guile
<a12l>But it doesn't work with Emacs lisp, but I don't know if it's supposed to do that without more packages installed