IRC channel logs

2022-09-28.log

back to list of logs

***Colere is now known as LoupGris
<jpoiret>yes
<alextee[m]> GEN guile-procedures.texi
<alextee[m]>/home/alex/Documents/git/zrythm-installer/build/gnu-linux/zrythm-deps-finished.p/guile-3.0.8/libguile/.libs/guile: error while loading shared libraries: libffi.so.7: cannot open shared object file: No such file or directory
<alextee[m]>Makefile:4560: recipe for target 'guile-procedures.texi' failed
<alextee[m]>what is it doing there? is it attempting to run the compiled guile binary?
<alextee[m]>libffi is in the --prefix I specified, should i pass LD_LIBRARY_PATH ?
<alextee[m]>also is there no way to disable the docs? i don't see anything in ./configure --help
<alextee[m]>it succeeded after passing LD_LIBRARY_PATH
*KREYREN sent a scheme code block: https://libera.ems.host/_matrix/media/r0/download/libera.chat/13d66b5fe106b70f27fa73ef9e1314911be7a63e
<KREYREN>Is there a nicer way to write this? I don't like that it's calling `format` multiple times as that is compiling that into invidual calls right
<drakonis>have you considered adding new lines?
<chris> https://pastebin.com/raw/BihngXjU
<chris>Keep it simple
*KREYREN is waiting for his system to bypass cloudflare gate on pastebin.com atm
<KREYREN><chris> "https://pastebin.com/raw/..." <- oh right.. thanks
<chris>TMTOWTDI
<KREYREN>ye ideally i want some like cli processing library that i just get to implement arguments for it to parse help in a flexible way 🤔
<drakonis>have you considered writing it?
<drakonis>that said
<drakonis>is getopts-long not good enough?
<drakonis>or perhaps it would help to look up how guix does arg parsing?
<drakonis> https://www.gnu.org/software/guile/manual/guile.html#getopt_002dlong-Example
<unmatched-paren>KREYREN: Try srfi-37
<unmatched-paren>That's what Guix uses for arg parsing
<unmatched-paren>It uses a small wrapper though
<unmatched-paren>non-wrapped example: https://git.sr.ht/~whereiseveryone/website/tree/master/item/website.scm#L120
<chris>hopefully KREYREN will be motivated to read through the entire guile manual at least once. It's not *that* long.
*chris has skipped sxml stuff every time
<KREYREN>chris: I read though that thing like 7 times now, but imma still stupid :c
<KREYREN><drakonis> "or perhaps it would help to look..." <- did, i couldn't find the relevant codeblock
<KREYREN><unmatched-paren> "6piz7wk: Try srfi-37" <- noted will check
<KREYREN><unmatched-paren> "non-wrapped example: https://git..." <- interesting
<KREYREN>it's still hard-coding the help message though https://git.sr.ht/~whereiseveryone/website/tree/master/item/website.scm#L90
<drakonis>KREYREN: it's in the docs i linked
<drakonis>and yet you did not see it
<KREYREN>drakonis: i had that exact page opened before i was asking here >_<
<drakonis>it is quite sufficient tbh
<Zelphir>Hi! I assume many people here are using Geiser : ) Sometimes I have an error in my code and Geiser will log a lot of output. For example I have a list in a record or struct and that list might be hundreds of items long. Then I make a mistake and the whoooole list gets logged. Afterwards any typing in that Geiser buffer becomes very sluggish. Is there a simple solution to shorten the output or configure Geiser differently? Maybe it has to do with the
<Zelphir>way Emacs represents lines of text and that having performance issues for long lines?
<dthompson>it's an emacs issue unfortunately :(
<dthompson>you can try enabling so-long-mode to ease the pain
<rekado>with native comp Emacs I found I can visit minified JS files without any slow-down
<rekado>(maybe I just got lucky)
<dthompson>:o
<rekado>it’s only 17.8kB, but all on one long line and with js2-mode
<rekado>I’m pretty sure that something like that would have been the end of my emacs uptime in the past
<dthompson>yes definitely
<dthompson>I didn't expect native compilation to resolve the issue.
<daviid>Zelphir: those of us who have to work, daily, with (very) large structures, not hundreds, several millions ... had to come with asolution to this terrible guile(not emacs) problem - thanks to lloda, there is a solution, here is how toimplement it - https://www.gnu.org/software/guile-cv/manual/html_node/Configuring-Guile-for-Guile_002dCV.html
<Zelphir>Ah OK thanks for that info : )
<daviid>welcome - i had a previous guile maintainer who's now using guile-cv that also had to go through these steps ... touching (ice-9 boot-9) is not forthe 'faint hearted', but there is currently no other way -
<daviid>*I have a previous guile maintainer who's now using guile-cv, also ad to gothrough these steps ...
<daviid>Zelphir: let us know how it goes ..
***ec_ is now known as ec
<Zelphir>So far I tried to sometimes use (truncated-print ...) for somethings, but this of course does not work for cases, when there is an unhandled exception.
<Zelphir>I also thought, if I rewrote some of the code, I could make use of structs inside the list, so that each list item has its own printer/printing function and the whole thing does not get such a long line. Perhaps the printer would also break lines. But right now, my list items are alists.
<Zelphir>So you are saying, that I would need to change Guile source code for the default printing and repl printing and compile guile, to solve this annoyance?