IRC channel logs

2022-09-24.log

back to list of logs

<alextee[m]>lilyp: oh makes sense, but can 't i bypass it?
<alextee[m]>mwette: thx
<rekado>alextee[m]: I thought you can use an existing Guile in the bootstrap process to speed things up.
<alextee[m]>rekado: how does that work? Dont the go files need to be produced by the version being compiled?
<mwette>some (per-arch) .go are provided in the prebuilt dir in the dist
<lechner>Hi, is it possible to redefine a global variable with define-public later in the same scope?
<antipode>sneek: later tell lechner: Are you sure what you want to do is some kind of _redefinition_ of a module variable (my interpretation of 'global variable), and not just mutating the variable? For mutation, there is 'set!'.
<sneek>Welcome back antipode, you have 1 message!
<sneek>antipode, rekado says: Download speed from within the MDC campus network is 190MB/s. Through my ISP (same city, same district) I get only about 2MB/s.
<sneek>Okay.
<alextee[m]>mwette: are the .go files relocatable across different guile versions or distros as long as they are for the same arch?
<sneek>Welcome back alextee[m], you have 1 message!
<sneek>alextee[m], antipode says: I don't think `tmpnam` warnings or 'undefined reference' have anything to do with out of memory. However, if you are wondering if the OOM killer killed GCC before it could print an error message, you could disable overcommitting and the OOM killer, or alternatively look in dmesg.
<alextee[m]>maybe not different guile versions..
<dirtcastle>I'm using emacs guix. I want to setup geiser. how to make geiser-edit-symbol-at-point or geiser-pop-symbol-stack work. it can't find the documentation when I run geiser-doc-symbol-at-point. but I should be able to view the code using geiser-edit-symbol-at-point right?
<polyex> https://dthompson.us/guix-for-development.html great post ty!!
<flatwhatson>dirtcastle: you need a repl running and at least the relevant modules loaded
<flatwhatson>M-x geiser-guile and M-x geiser-eval-buffer (C-c C-b)
<flatwhatson>civodul: this is the cheeky COLUMNS fix: https://paste.debian.net/1254817/
<flatwhatson>i'm not sure whether we can get away with that though.
<flatwhatson>otherwise it's a matter of adding libguile/terminal.c & implementing the ioctl(TIOCGWINSZ) ourselves, unless there's another approach i've missed?
<slbtty>I think pretty-print have some werid interaction with set-cdr!
<slbtty> https://pastebin.ubuntu.com/p/5g6R928fPN/
<slbtty>It modified my data
<slbtty>Code in the pastebin above have to be execuated as `guile3 < file.scm` to reproduce the problem
<slbtty>this snippet only need copy-n-paste to repl to reproduce https://pastebin.ubuntu.com/p/ydZV5T7RHx/
<flatwhatson>yes can confirm, nasty!
<flatwhatson>slbtty: would you mind making a bug report?
<flatwhatson>the problem seems to be mutating an immutable pair. testing in guile 2.2.7, it errors "expecting mutable pair"
<flatwhatson>replacing '(1 2) with (list 1 2) doesn't error in guile 2.2, and doesn't get corrupted in guile 3
<slbtty>Yes, but wildly i discovered that there is no "immutable pair" in scheme, thus we got set-car! and set-cdr! by default
<slbtty>I am not sure about the internal staff, but does '(1 2) and (list 1 2) creates different things?
<antipode>flatwhatson: The use of 'false-if-exception' seems to wide to me -- e.g., it also catches stack overflows, which can easily happen when using 'call-with-stack-overflow-handler'. Instead, I recommend (resolve-module '(ice-9 readline) #:ensure #false) and checking the return value.
<dirtcastle>if I load the modules, they will work? flatwhatson
<flatwhatson>dirtcastle: should do yeah. geiser needs to "see" the definitions, which means they need to be loaded into the repl
<flatwhatson>eval'ing the whole buffer is generally the easiest way to do that
<dirtcastle>I just ran eval buffer after starting the geiser repl.
<dirtcastle>but I think it reads it thinking it's elisp code.
<dirtcastle>so I ran the file using (load "")
<flatwhatson>er, not eval-buffer... geiser-eval-buffer ;)
<dirtcastle>It is throwing error. I ran 3,4 files. everything throws error when loading modules. I think it is because the file I'm evaluating isn't present in the right location
<flatwhatson>dirtcastle: best to post an error message if you're getting one, that will provide some clues
<flatwhatson>likely you need to add some directory to your load path, this can be done with (add-to-load-path "/some/path") in the repl
<flatwhatson>but there are better ways to configure geiser depending on what you're actually trying to do
<mwette>alextee[m]: I doubt you can use .go from release to release; you can't get away from building the .go files. The provided ones in prebuilt are the ones that take a long time, I think. In fact, the .go files are built several times (into stage0, stage1, stage2).
<alextee[m]>i'll live with building them
***NullPointerErro1 is now known as NullPointerError
<mwette>dirtcastle: you can't set-cdr! on a literal list (i.e., '(1 2)); try with (list 1 2) instead
***rgherdt_ is now known as rgherdt