IRC channel logs

2022-08-10.log

back to list of logs

***amk_ is now known as amk
***attila_lendvai_ is now known as attila_lendvai
<jpoiret>is it possible to inspect some (guile) variables at run time, like %active-exception-handlers?
<dsmith-work>Wednesday Greetings, Guilers
<jpoiret>well, rather (ice-9 boot-9)
<unmatched-paren>is there any way i can build a guile package without autoconf?
<unmatched-paren>Well, it's almost certainly possible, so: how do i build a guile package without autoconf?
<jpoiret>you can use `guild compile`
<unmatched-paren>thanks
<unmatched-paren>Is there anything I should know about GUILE_* env variables, etc, that autoconf sets up?
<jpoiret>they're not env variables
*unmatched-paren hasn't actually looked at a guile autoconf file, but assumed that there were GUILE_* env vars
<jpoiret>rather, they're shell variables or m4 variables or whatnot, i haven't really understood it well
<jpoiret>ie, they only control what the resulting makefile will look like
<jpoiret>as long as you're not compiling C modules, you shouldn't need them iiuc
<unmatched-paren>thanks
<sneek>Welcome back tohoyn!!
<tohoyn>unmatched-paren: you may need to set GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH for loading your own modules
<unmatched-paren>tohoyn: I thought I'd have to do something with them, thanks for the heads-up
<mwette>unmatched-paren: I tried to make nyacc w/o autoconf. I gave up, but I think I managed to minimize the dependencies (e.g., no automake). Check https://git.savannah.nongnu.org/cgit/nyacc.git/tree/etc?h=main
<unmatched-paren>mwette: What was the problem with not using autoconf?
<mwette>Users were expecting a configure w/ all the standard arguments.
<mwette>If you can get away with make, use that. I use guile itself to report where the paths are. Check use of %global-site-dir etc.
<unmatched-paren>mwette: Ah, the configure problem is easily solved.
<unmatched-paren>Just write a configure that takes all the standard arguments and discards the one it doesn't need :)
<unmatched-paren>I've done that already, it works ootb with guix's gnu-build-system (though it's for C, not guile)
<unmatched-paren>I did it mainly so that I could write the makefile with POSIX features only
<unmatched-paren>because without the GNU extensions, I couldn't use $(if ...), $(shell ...) etc
<mwette>I wrote my own Makefile.in's.
<unmatched-paren> https://paste.sr.ht/~unmatched-paren/6fbd48e6090c648ef89066d29ffc6b5a1fcd4ad7
<unmatched-paren>i could just adapt this for guile
<mwette>OK. I see where you are going.
<unmatched-paren>can i directly execute .go files?
<unmatched-paren>guile foo.scm --language=bytecode doesn't work
<ArneBab>unmatched-paren: you can use guile -L . -e '(foo)' to execute the main method in the module foo.
<unmatched-paren>ArneBab: Thanks!
<ArneBab>Then the language does not matter: if it is compiled, guile can run it.
<ArneBab>If you want to compile in the file, you can use something like the header in dryads-wake: https://hg.sr.ht/~arnebab/dryads-wake/browse/dryads-wake.w?rev=tip
<apteryx>is it possible to programatically query the variable name of some object?
<jab>is anyone here using guile-debbugs?
<jab>Just curious