IRC channel logs

2022-08-06.log

back to list of logs

<daviid>apteryx: can you paste the definition of lightdm-gtk-greeter-configuration?, or a url to its def, just curious, not sure i can answer, but i'd like to check something
<apteryx>daviid: it's a work in progress: https://paste.centos.org/view/5e454d3b
<apteryx>line 317 fails because pred is of type <syntax-transformer> rather than <procedure>
<apteryx>it relies on https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/configuration.scm for defining the records and autogenerating predicates such as 'lightdm-gtk-greeter-configuration?'
<daviid>apteryx: ah, unfamiliar with that code, sorry
<daviid>apteryx: though in your paste, (procedure? $18) should 'normally' raise an exception, even simply naming a syntax-transformer would raise an exception
<daviid>(macro? (module-ref (current-module) 'lightdm-gtk-greeter-configuration?)) should return #t
<daviid>but (macro? $18) would/should raise an exception
<daviid>apteryx: in order to 'play with' but eliminate the complexity of the guix/gnu services configuration process, you can play/try all the bove with add-to-load-path
<daviid>*in order to 'play with' a 'simple' syntax-trnsformer
<daviid>(module-ref the-root-module 'add-to-load-path) => $9 = #<syntax-transformer add-to-load-path>
<daviid>(procedure? $9) and (macro? $9) both would raise an exception
<daviid>but (macro? (module-ref the-root-module 'add-to-load-path)) => #t
<daviid>(procedure? (module-ref the-root-module 'add-to-load-path)) => #f
<daviid>fwiw ...
<apteryx>yeah, I can the same result
<apteryx>odd
<apteryx>perhaps I can hack my way with this kludge: (procedure? (lambda (x) ((module-ref (current-module) 'lightdm-gtk-greeter-configuration?))))
<apteryx>works!
<vbramselaar>Hi all, I'm trying out the (ice-9 peg) module. I try to use the "peg-string-compile" procedure, but it keeps calling it an "Unbound variable". I don't know what I'm doing wrong.
<vbramselaar>My goal is to be able to use a PEG pattern read from a file. So I guess first read in file as string and turn it into a PEG pattern.
<Zelphir>@vbramselaar Do you have a link to any code?
<vbramselaar> https://pastebin.com/Q5R2brD5
<Zelphir>Hm. (import (only (ice-9 peg) peg-string-compile)) fails for me on GNU Guile 3.0.8.
<vbramselaar>Zelphir: Im using Guile 3.0.5 myself and having the same problem
<Zelphir>However, (import (only (ice-9 peg) compile-peg-pattern)) works and it is in the same section in the manual at https://www.gnu.org/software/guile/manual/html_node/PEG-API-Reference.html. I do not see a workaround though, because compile-peg-pattern wants an s-expression and I don't know how one could get one from a grammar string.
<Zelphir>Do you want to read from a file, so that you can define the grammar outside of the actual program? Or perhaps offer a user to define their own grammar for something?
<vbramselaar>Yhea I want to define it outside the program. But it would not be a huge dealbreaker if it has to be in hte program, but I kinda like to have it seperate.
<Zelphir>I personally like the syntax for defining it inside the program, not as a string, more, and I guess it might catch a few more errors at compile time, but I can understand the aspect of wanting it outside of the program.
<vbramselaar>Kinda like the thing of being able to change the grammar without touching the code
<vbramselaar>but on the other hand compile time is probably more safe
<vbramselaar>Thanks anyway for the help. Is this something that should be bug reported?
<Zelphir>I would try asking on the mailing list first, but I think it is a bug. At the very least it is unexpected behavior. I am not an expert though.
<tohoyn>I have a large guile program, which gives segmentation fault/out of memory when only 4 GiB out of 15.4 GiB is used.
<tohoyn>which environment variable shall I set in order to get the error message in English? I have already tried LANG=C.
<tohoyn>I obtained the memory figures from Gnome Monitor
<Cairn>Hey #guile
<Cairn>two: Testing
<Cairn>Ok, so I see Matrix-bridged messages in IRC, but I don't see IRC messages in Matrix
<Cairn>Sorry yuu, I actually thought that the bridge was working to send messages. I just don't see messages from libera.chat users on my matrix client
<Cairn>Yeah, like I saw that in my irc client
<Cairn>Yep, I'm not able to see the irc message I just sent on this client
<Cairn>Huh.. So I guess two's messages didn't go through. And neither did yours?
<Cairn>Is your libera.chat account registered? Maybe that's the issue. I went to send messages using a temp name and they didn't come through either, so it probably just requires registration
<Cairn>This whole time, I thought the IRC hadn't been updated yet, but I just realized it's the 6th and not the 7th
<Cairn>Haha
<Cairn>Ah yeah. Why don't you register yuu[m]?
<Cairn>Then you can nick yourself that on libera.chat and rooms that require registration will let your messages through
<Cairn>Did you /nick somewhere?
<Cairn>That'll do it
<Cairn>Strange. I thought Matrix automatically uses [m] as your nick suffix. I remember having to update my bridged nick to remove the [m]
<Cairn>I just reidentified and it works for me
<Cairn>yuu[m]: Are you having trouble registering or something?
<Cairn>I guess it would just be REGISTER [password] [email]
<Cairn> * I guess it would just be `REGISTER \[password\] \[email\]`
<Cairn>Sorry for chatspam everyone. We probably should have direct messaged