IRC channel logs

2022-07-05.log

back to list of logs

***X-Scale` is now known as X-Scale
***civodul` is now known as civodul
***X-Scale` is now known as X-Scale
<rekado_>I’m using this to capture stderr and stdout: https://elephly.net/paste/1657017498.scm.html
<rekado_>is there a better way?
<rekado_>I have tried many *worse* ways (not using sockets but polling a file)
<rekado_>my biggest concern with the above approach is that reading from the socket is blocking, so maybe I cannot use it with fibers.
<jpoiret>sneek, later tell isamert: in guix we have https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/installer/utils.scm#n87
<sneek>Got it.
<jpoiret>sneek, later isamert: you've gotta be careful though as the Guile primitives don't handle having current-{input,output,error}-port file ports for the same fd, that's bug https://debbugs.gnu.org/cgi/bugreport.cgi?bug=52835
<jpoiret>oops
<jpoiret>sneek, later tell isamert: you've gotta be careful though as the Guile primitives don't handle having current-{input,output,error}-port file ports for the same fd, that's bug https://debbugs.gnu.org/cgi/bugreport.cgi?bug=52835
<sneek>Will do.
<civodul`>rekado_: you could use primitive-fork instead of call-with-new-thread + system*
<civodul`>that's fine as long as your program is single-threaded
***civodul` is now known as civodul
<dsmith-work>{appropriate time} Greetings, Guilers
<dsmith-work>nerthus: What you want is for-each
<dsmith-work>nerthus: map applies a fn to each item in a list (or lists) and returns a list.
<dsmith-work>nerthus: for-each applies the fn in-order. Is for side effects, like display
<dsmith-work>Just saw this: https://codeberg.org/rgherdt/emacs-lsp-scheme
<dsmith-work>Anyone here using it?
<drakonis>this one's for chicken, no?
<drakonis>oh, guile and chicken, neat.
<unmatched-paren>how do i treat a syntax-rules variable as a symbol?
<unmatched-paren>e.g. (foo bar -> baz) for (define-syntax foo ((_ bar direction baz) (case direction ('-> ...) ('<- ...))))))
<unmatched-paren>sorry, forgot (syntax-rules ...) around ((_ bar direction baz) ...)
<unmatched-paren>I know I should be doing (syntax-rules (-> <-) ((_ bar -> baz) ...) ((_ bar <- baz) ...)) instead but that gets tedious quickly
<unmatched-paren>as you add more symbols, at least
<rekado_>is using syntax-case an option?
<unmatched-paren>Oh, huh, I didn't know that was a thing. Thanks!
<rekado_>it’s a little verbose and confusing, but very powerful
<rekado_>and you get to work with syntax quotes: #` #' #,