IRC channel logs

2022-06-11.log

back to list of logs

<GNUtoo>I'll do that
<GNUtoo>exec guile --no-auto-compile -s "$0" "$@" results in ';; note: source file [...]'
<daviid>GNUtoo: https://paste.centos.org/view/427a7183 - drop this somewhere, call it cflags, chmod a+x, then ./cflafs
<daviid>at the end of the paste, you can see it's not compiling the script
<daviid>which is expected :)
<GNUtoo>bash: ./cflags: /bin/sh^M: bad interpreter: No such file or directory
<GNUtoo>I'll try to fix
<GNUtoo>It works it seems
<GNUtoo>Hello World
<GNUtoo>no extra prints
<daviid>you don't have /bin/sh
<GNUtoo>It's more likely that the pastebin converted the file to CRLF, so I did dos2unix
<GNUtoo>(file cflags => cflags: POSIX shell script, ASCII text executable, with CRLF line terminators => dos2unix cflags + ./cflags == Hello World)
<daviid>GNUtoo: great, i wanted to convince you something was wrong 'on your side', done :)
<GNUtoo>Renaming my script make it work it seems
<GNUtoo>Something looks strange on my side indeed
<GNUtoo>Since it printed "note: source file [...] newer than compiled [...]/cflags.go.scm" I did rm [...]/cflags.go.scm and it now seems to work fine
<GNUtoo>Maybe it was a permission issue in the cache
<GNUtoo>Like if I ran it as root at some point it might have explained the issue
<GNUtoo>Thanks a lot for the help
<GNUtoo>Having it not working upstream was indeed strange as some people typically need stderr
<daviid>welcome!
<redacted>When calling a scheme proc through scm_call_0 et al, what sort of concurrency happens? Does guile have some kind of event loop? is it a new thread?
<sneek>Welcome back chrislck!!
<daviid>tohoyn (and other g-golf interested/users): i just pushed a fix (to the g-golf devel branch) that allows (unregistered) derived class instances to be used anywhere GObject (sub)class instances are expected - as an example, here is an updated/reviewed bind-model example (which isn't stupid at all any more :)) - https://paste.centos.org/view/6d53db09
***chris is now known as Guest6583
<stis>Hello guilers!
***avp_ is now known as avp
<maximed>redacted: scm_call_0 does not create a new thread -- for threading, see scm_spawn_thread.
<maximed>redacted: scm_call_0 does not do any event loopery -- for event loops, see the separate guile-fibers library
<maximed>redacted: all scm_call_0 does, is calling the scheme procedure -- no concurrency going on here!
<redacted>maximed: thanks!
<redacted>maximed: I'd *just* realized that it couldn't have done any concurrency because it returns a value when your message came in.