IRC channel logs

2022-05-20.log

back to list of logs

<ArneBab>leth: you need to make the fiber asynchronous, otherwise put-message waits for get-message to retrieve the message.
<ArneBab>scrap my previous message. You need a lambda () in the fiber.
<ArneBab>leth: ^ (spawn-fiber (lambda() (put-message message-channel "Hello")))
<stis>going from O2 -> O3 the speedup of my examples when from 35s to 1.5s for 1G writes, a 20X increase and the result was correct, wow, just wow.
<stis>the questions was to represent 1234567890123456 as characters in a car buffer
<stis>ahh inlining and smarties made it cheat. It actualyy is 27s, ok that's better it is what I would exoect
<stis>Looks like I increased the upper limit of writing a double to file to between 30-40M doubles a second
<stis>snprintf() is about 10X slower
<leth>ArneBab: Thanks! That wasn't very clear form the documentation for me, is there a concise way to explain it?
<leth>ArneBab: oh, it does say thunk. My bad.
<dsmith-work>Happy Friday, Guilers!!
<mwette>wingo: If you are working on GC, please consider now non-memory objects fit in. In the past I was leaving (file read) ports to the GC and guile crashed ungracefully due to "no more ports". The manual does recommend explicitly calling close, and no I do that. But seems like one might like to trigger a GC sweep on "no more ports".
<civodul>sneek: later tell mwette a stop-the-world GC is indeed triggered when libguile makes an open(2) call that returns EMFILE
<sneek>Welcome back civodul, you have 1 message!
<sneek>civodul, zimoun says: Give a look at https://users.ugent.be/~kehoste/eum18/easybuild_nix_cvmfs_compute_canada_bart_oldeman.pdf «EasyBuild wrapping nix» and «Nix wrapping EasyBuild».
<sneek>Okay.
<ArneBab>leth: happy to help — thunk is one of the words that aren’t really clear…
***karlosz_ is now known as karlosz
<leth>another question, why doesn't this work http://paste.debian.net/1241533/ (the fiber-proc definition seems to be the problem and commenting it out, and it's replacing it's call with the commented line over it works)
<ArneBab>leth: fiber-proc is not a function, it is an in-line call.
<ArneBab>leth: (define (fiber-proc) (put-message (message-channel) "Hello"))
<ArneBab>with your define, you put the result of (put-message …) into the variable fiber-proc and then try to execute that result.
<leth>Ah, yes...
<leth>thank you again.
<leth>Been rewriting my init.el, So been getting used to the emacs lisp syntax i guess. Couldn't see it untill you pointed it out.
<ArneBab>no prob :-)
<leth>Also I seem to be getting depreated warnings when i use srfi-9 records, are they deprecated and replaced by something else or are thy in turn just using some code that needs update?
<leth>mayhaps it isn't srfi-9
<ArneBab>I’m not sure about that
<leth>anyway a fixed version of the code i posted last, gives depracated warnings.
<leth>made a bad assumption about it being srfi-9 but something does give the warning.
<ArneBab>I don’t get deprecated warnings from that
<ArneBab>(version)$1 = "3.0.8
<leth>it's in fibers.
<leth>same version.
<ArneBab>Fibers 1.0, 1.1.0 or 1.1.1?
<ArneBab>There were updates lately
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>!uptime
<sneek>I've been running for one day and 21 hours
<sneek>This system has been up 5 weeks, 4 days, 22 hours, 2 minutes
<dsmith-work>goodbot
<leth>ArneBab: 1.1.0, I'll update and see what happens.
<ArneBab>Good luck!
<leth>no, in the latest git comit fibers.scm also uses bit-count on line 95, which my guile tells me is deprecated.
<leth>I'd make a patch but it's getting late, need too sleep.