IRC channel logs

2022-05-08.log

back to list of logs

***chris is now known as Guest1495
<tohoyn_>sneek: botsnack
<sneek>:)
<cassepipe>Hi ! I am making the tortoise turorial to learn and I my compiler cannot find libguile.h
<cassepipe> https://www.gnu.org/software/guile/docs/guile-tut/tutorial.html#Guiling
<cassepipe>I have also tried #include <guile/gh.h> but it can't find it either
<cassepipe>I am running Linux Mint and I do have the guile virtual package installed, which should have installed the libs and headers
<lampilelo>what build system are you using?
<cassepipe>Make
<jpoiret>cassepipe: from what i remember, guile/gh.h doesn't exist in guile 3
<cassepipe>Gnu make, as in the tutorial
<cassepipe>Which is not up to date then ?
<lampilelo>no
<cassepipe>The weird thing is although the libs seem to be installed, I can't find no guile headers in /usr/include
<cassepipe>Oh the headers are in the dev package, I didn't know
<jpoiret>it's possible that you'd need to use pkg-config
<jpoiret>ah no, right, guile-config takes care of that anyways
<lampilelo>you need to alter your CFLAGS and LIBS variables: CFLAGS=$(shell pkg-config --libs guile-3.0) and LIBS=(shell $pkg-config --cflags guile-3.0)
<lampilelo>sorry, there's a typo in LIBS, $ should be outside the parens
<lampilelo>ah lol
<lampilelo>i guess i didn't notice the guile-config lines
<lampilelo>so disregard
<cassepipe>My bad it was indicated in the tutorial I should have read on.
<cassepipe>I was to eager to appease the linter
<lampilelo>so you left CFLAGS and LIBS empty after all?
<lampilelo>because regardless of where it's installed guile-config should know where to find the compile and link flags
<cassepipe>lampilelo: Sorry, I did not see your message. No I added :
<cassepipe>CFLAGS = `guile-config compile`
<cassepipe>LIBS = `guile-config link`
<stis>Hello guilers!
<nckx>Hullo stis.
<stis>sad days with this stupid war and tough economical times, hard to focus on free coding atm.
<stis>all energy goes into minimizing the cost of living. Last thing I did was to cancel vacationi plans.
<stis>nothing terrible, but if many are doing this economy will tank
<stis>lowred also the speed by more than 20% when going "interstate" to visit paranets to keep fuile costs low.
<stis>Good for the environment though.
<stis>air resistance has a v^2 component
<stis>But boy things can get extreamly nasty in poorer countries so I do not complain.
<stis>Sorry to spread some angst here. Have anybody digested any of my hashtable ideas?
<stis> http://itampe.com/hash-tables.html
<stis> http://itampe.com/association-performans-test.html
<mwette>stis: Would you be willing to proofread hash-tables.html? For example, the doc says BV16 is 128 bits but only takes on values from 0 to 255. I'm puzzled by that.
<stis>8bit times 16 = 128
<stis>0-255 is 8 bits
<stis>mwette: ^^
<stis>it's a vector of 16 bytes each taking values in 0-255 (actually due to the algorithm we must assume 1-255
<stis>mwette: ^^
<stis>there is also a scm file that could need discussions of the higher level stuff
<stis>unfourtunately guiles generilized hash implementation is leking into the abstraction so it is impossible to completely replace it. (hash,assoc) in stead of the much better in my bview (hash,equal?)
<mwette>But the doc doesn't say that (i.e., there are 16 hash keys).
<stis>Yes I will fix that. Anyhow ecch slot can hold up to 15 elements in an vector, the 16th slot is teh rest assoc and there is a cache that is maintained in a move to fron manner
<stis>you keep the potential 15 hash slots in the first 128 bits and use various bitwise operatoin and SIMD instructions to find out if there is a potential match or if there is a free slot anywhere
<stis>at access if you have a match at the first hash element you use the cache, else you look into the vector and swap it to the cache, there is a rest assoc for hash clashes and when there is more than 15 elemnts in the vector slot
<stis>I will rework it to make it better now.
<stis>rsynch is fantastic
<stis>mwette: I tried to make things a bit clearer, do you agree?
<stis>mwette I've seen som 5x faster hash lookup in some cases compared to guiles eq? hash lookup
<stis>blog updated