IRC channel logs

2022-05-07.log

back to list of logs

<ArneBab>soft ports are currently continuation barriers — for dryads wake I had to use actual unix sockets to avoid that. See https://hg.sr.ht/~arnebab/dryads-wake/browse/game-helpers.w?rev=6c8b0d189e18c5a66e1954a7fd384e2f4a68768d#L321
<unmatched-paren>is there some kind of path-append procedure in the standard guile libraries?
<unmatched-paren>like (path-append "foo" "bar") would produce "foo/bar"
<unmatched-paren>i can just do (string-append "foo" "/" "bar") but path-append would be more convenient
<lilyp>I recall writing such a thing some while ago
<unmatched-paren>i can't be bothered to write one just for this purpose, so i'll just use string-append as above if there isn't one
<lilyp>Well, you can generalize that to (lambda args (string-join args file-name-separator-string))
<unmatched-paren>lilyp: good point
<unmatched-paren>i'll do that
<unmatched-paren>is there a procedure to pipe some text to a command and return the resulting stdout text?
<lilyp>info '(guile)Pipes'?
<unmatched-paren>lilyp: thanks
<lampilelo_>remember to match parens
***lampilelo_ is now known as lampilelo
<unmatched-paren>can i use (match) with '(cons . pairs)? something like this (match foo ((x . xs) ...)) but i don't see it mentioned in the match manual section
<unmatched-paren>ohh, i think the "list of n or more" pattern works with pairs
<unmatched-paren>it does
<lilyp>unmatched-paren: you probably found that out yourself already but (head . tail) is another way of writing lists, so if tail is the cdr of a pair it works just as well
<lilyp>but you can't distinguish between (a b) and (a . b) with just that
***bandali_ is now known as bandali