IRC channel logs

2022-03-30.log

back to list of logs

<daviid>tohoyn: i fixed gtk-widget-path, gtk-widget-class-path, on the devel branch
<daviid>tohoyn: you should consider joining #gtk and #libadwaita on irc.gnome.org,it. appart from some deep doan talks in between gtk deves, is full of QA and advices on how one should write an app these days ...
<daviid>*irc.gnome.org, appart from some deep down ... devs :)
<daviid>fwiw, here is a(n updated) g-golf / gtk3 / get-path (ok), path (deprecated), class-path (deprecated) testing snipset - https://paste.debian.net/1236082/
***alMalsamo is now known as lumberjack123
<tohoyn>New G-Golf debian package 0.1.0v9-1 has been released. See https://www.iki.fi/tohoyn/g-golf-debian/.
<amk>how do guile-gi and g-golf differ?
<alextee[m]>I spent a few hours yesterday writing this
<alextee[m]> https://git.sr.ht/~alextee/zrythm/tree/master/item/scripts/gen-appdata-xml.scm#L32
<alextee[m]>I finally kinda understand what , ,@ and ` do
<jadzi>Hi! I feel i don't realize what exactly continuations are, so i don't understand the error message in such code with fibers (run-fibers (lambda _
<sneek>jadzi, you have 1 message!
<sneek>jadzi, unmatched-paren says: "For example, I tried running `cargo install racer`" <- isn't racer obsoleted by rust-analyzer? that is in guix
<jadzi> (call-with-values (lambda _ (http-get "https://www.gnu.org"))
<jadzi> (lambda (response body)
<jadzi> (pk 'response response)))))
<jadzi>the error message is : Attempt to suspend fiber within continuation barrier. I've found out that this code is ok when not using https. Is there possibly a bug with fibers + web client tls-wrap ?
<jadzi>Here is the full error stack https://pastebin.com/5XcbPbJS
<tohoyn>Theme-D-Golf has been renamed to Theme-D-Intr. See https://www.iki.fi/tohoyn/theme-d-intr/.
<d4ryus>jadzi: Iam not certain, but i think your problem is the custom-binary-input/output-port that gnutls creates. Those will create a barrier which prevents the fiber suspension: https://github.com/wingo/fibers/wiki/Manual#32-barriers
<jadzi>d4ryus: thank you for the answer, under the link you've posted there's also info about ports and blocking. It seems that this custom port is yet impossible to use within fibers scheduler
<chrislck>sneek: botsnack
<sneek>:)
<jpe>do people generally use geiser for development these days, or are there any alternatives you guys recommend checking out?
<lilyp>jpe: The use of Emacs for Lisp development is not negotionable.
<lilyp>That being said, if you are a slave to vim, you might as well learn to use the Guile REPL on the side.
<jpe>oh no, i only use Emacs, i was just wondering if people use anything other than geiser with it
<m455>i use https://github.com/jpalardy/vim-slime to get the ctrl-c c experience :D
<jpe>i'm using erc right now :)
<m455>oh woops just saw your message lol
<lilyp>tbf you can get pretty far with just parentheses matching, but having an interactive repl inside emacs is a great help
<jpe>yea for sure
<lilyp>this is not just a scheme thing mind you, running prolog inside emacs has the same benefits
<daviid>tohoyn: tx for the g-golf debian pre-release package and the theme-d-intr(ospection) renaming - now you may even switch to or 'just' also offer theme-d-intr using guile-gi :) [jokes apart, it would be quite a lot more work for you, but fwiw, guile-a-sync[2|3] did that for their glib based event loop, so uers may choose to work with guile-a-sync using guile-gi or g-golf]
<jpe>i wanted to check partially before i see if i can hack in step debugging support to geiser
<jpe>or at least attempt to :)
<mwette>jpe: I've been looking into upping the debug experience also. I ran across gds but found it was for guile 1.X; You may be interested in https://github.com/mwette/guile-jtd
<mwette>^ work-in-progress
<jpe>mwette: ooh very nice! thanks for sharing!