IRC channel logs

2022-03-29.log

back to list of logs

***karlosz_ is now known as karlosz
***karlosz_ is now known as karlosz
<daviid>sneek: later tell tohoyn can you (carefully) (re)read https://www.gnu.org/software/g-golf/manual/html_node/Events.html - the '- In Gdk-3.0' section, because i took quite a bit of my time to document this the best i could, and what youare asking for is (hopefully well) explained there, with even two examples of how you should call the gdk-3.0 union (upstream/built-in) accessors - if you do not wish to use g-golf accessors that is - then
<daviid>let me know if you find your 'mistake', otherwise i'll point it to you, but i'd like to see if the documentation is enough to help you fix your own 'bug'
<sneek>Welcome back daviid, you have 1 message!
<sneek>daviid, tohoyn says: I posted some messages about G-Golf and gtk-widget-class-path
<sneek>Okay.
<daviid>sneek: later tell tohoyn i did not receive any email from you, fwiw, but 'gtk_widget_class_path has been deprecated since version 3.0 and should not be used in newly-written code. Use gtk_widget_get_path() instead' - let me know how it goes using gtk-widget-get-path instead ...
<sneek>Got it.
<daviid>sneek: later tell tohoyn oh, i now see in thischannel logs, you posted here, i must have been disconnected when you posted ... ok, i'll look into it, it might indeed be usefull to debug anyway ... will let you know then
<sneek>Got it.
<tohoyn>sneek: botsnack
<sneek>Welcome back tohoyn, you have 3 messages!
<sneek>tohoyn, daviid says: can you (carefully) (re)read https://www.gnu.org/software/g-golf/manual/html_node/Events.html - the '- In Gdk-3.0' section, because i took quite a bit of my time to document this the best i could, and what youare asking for is (hopefully well) explained there, with even two examples of how you should call the gdk-3.0 union (upstream/built-in) accessors - if you do not wish to use g-golf accessors that is - then
<sneek>tohoyn, daviid says: i did not receive any email from you, fwiw, but 'gtk_widget_class_path has been deprecated since version 3.0 and should not be used in newly-written code. Use gtk_widget_get_path() instead' - let me know how it goes using gtk-widget-get-path instead ...
<sneek>tohoyn, daviid says: oh, i now see in thischannel logs, you posted here, i must have been disconnected when you posted ... ok, i'll look into it, it might indeed be usefull to debug anyway ... will let you know then
<sneek>:)
<tohoyn>daviid: the problem with <gdk-event> is not just about accessors. E.g. function gtk-widget-event-does not work. See https://paste.debian.net/1235943/.
<tohoyn>^gtk-widget-event does ...
<tohoyn>daviid: are values of struct types always converted to lists in g-golf?
<tohoyn>daviid: It seems that values of type GdkRectangle are converted
<tohoyn>daviid: should the <argument> or <gi-struct> classes contain a boolean slot to tell if the struct is converted to a Scheme list?
<tohoyn>daviid: if it is not possible to add slots to <gi-struct> we could have a global list of those struct types that are converted to Scheme lists
<daviid>tohoyn: just to make sure we are on the same planet here :), there is no problem with <gdk-event> and its accessors; when you are using an upstream function that expect a pointer to a GdkEvent, you need to pass a pointer to a GdkEvent ... which means, as stated in the manual, if you have a <gdk-event> instance 'in your hand', call (!event the-event)
<tohoyn>daviid: ok. that works.
<tohoyn>daviid: but do we have a similar problem with other struct types, too?
<tohoyn>daviid: i.e. the struct instances are of type <my-struct> but procedures taking arguments of that type require pointers?
<daviid>tohoyn: pointer to struct (upstream libraries) are never transformed into goops instances in g-golf, there are 'decoded' and encoded' as a list if and only if there are not opaque nor semi-opaque, like clutter colors for example - if you receive a pointer, then the upstream struct 'instance' is opauqe and there is nothing no language on earth can do, nor g-golf either :), you must use the upstream api to access its content and
<daviid>'blindingly pass the pointer to other functions when you need so ...
<daviid>we've talked about this multipe times already ...
<tohoyn>daviid: sorry, I meant union types
<tohoyn>daviid: objects are of type <gdk-event> but functions taking <gdk-event> arguments take pointers
<tohoyn>daviid: is there the same problem with other union types, too?
<daviid>all union types are opaque, none except gdkevent are wrapped in a goops class, whichi did to be compatible with guile-gnome
<daviid>tohoyn: you should also move to gtk4, the all app management, event in particular, changed...
<tohoyn>daviid: so are the values of other union types <pointer>'s?
<daviid>tohoyn: GI typelib yes, but g-golf obviouly encode/decode GIArguments ...
<daviid>tohoyn: gtk4 rendering has radicaly changed as well,don't ivest to much of your time in gtk3/gdk3, my 2c ...
<daviid>tohoyn: and use libadwaita, already v1.1, which depends on gtk4/gdk4/gsk4 'obviously'
<dadinn>hi all
<tohoyn>daviid: the reason that I still use GTK 3 is that all the features needed in the Theme-D-Golf demo can't be done (or I'm unable to do them) with G-Golf and GTK4: for example, radio menu items
***alMalsamo is now known as lumberjack123
<tohoyn>daviid: I think there is something wrong with g-type-name. See https://paste.debian.net/1235974/. The first g-type-name call returns "void" but the second call works ok (returns GtkTargetList).
<dsmith-work>{appropriate time} Greetings, Guilers
<dsmith-work>!uptime
<sneek>I've been running for 22 days
<sneek>This system has been up 3 weeks, 1 day, 2 hours, 8 minutes
<dsmith-work>sneek: botsnack
<sneek>:)
<wingo>i see civodul continues his fibers saga :)
<daviid>tohoyn: there is nothing wrong with g-type-name, but your understanding of upstream type(s), and these calls are in g-golf core stuff, nothing a g-golf user you write an application would ever have to deal with ...
<daviid>it occurss tome you should not call your app theme-d-golf, but theme-d-gtk3
<daviid>theme-d- has nothing to do with g-golf
<daviid>tohoyn: exactly, you will have to adapt to gtk4 ... the sooner the better
<daviid>and call it theme-d-gtk4
<tohoyn>daviid: Theme-D-Golf should be able to handle other introspected libraries, too
<daviid>only if you write the code ... hence what you write is incompatible in between gtk versions ... g-golf can imprt any GIintrspectable lib
<daviid>i wish you name it something else, but not using g-golf in the name
<daviid>gdkatom is an unnamed opaque struct, it is unnamed - g-golf gvies it a name though, just call the !name or !g-name upon the (g-golf) imported <gi-struct> instance
<daviid>tohoyn: here https://paste.debian.net/1236013/
<daviid>tohoyn: none of the g-golf core nor its manual are for g-golf users, these are for g-golf maintainers - you can't take one core proc, use it totally out context and then complain that 'there is a problem with g-golf ...'
<tohoyn>daviid: I'll rename it
<civodul>wingo: yup, it's a lot of fun!
<jpe>newbie here, using guile 3. how can I set a breakpoint so I can drop into the debugger when I call a function? can't seem to find it in the docs
<poselyqualityles>make-breakpoint function?
<poselyqualityles>i think that's in the gdb module
<poselyqualityles>so if you use gdb
<poselyqualityles>also found http://gnu.ist.utl.pt/software/guile/docs/docs-1.8/guile-ref/Intro-to-Breakpoints.html#Intro-to-Breakpoints
<poselyqualityles>not sure how current that is
<poselyqualityles>but i guess you could check if there is a breakpoints module
<poselyqualityles>i just had to switch os so i need to re-setup guile or i would check, sorry
***sneek_ is now known as sneek
<mwette>jpe: from guile prompt, you can; type: ,help debug
<jpe>mwette: thank you! i got it working from the help command. i didn't realize some of those debug commands work at the top level
<jpe>inspecting breakpoints seems to lock up emacs for some reason but it works at command line at least
<jpe>gahh i didn't read the docs carefully enough.. "The next 3 commands work at any REPL."
<mwette> /quit