IRC channel logs

2022-03-23.log

back to list of logs

<dadinn>hi all
<dadinn>I am still facing the (add-to-load-path (dirname (dirname (current-filename)))) call in my guile scripts.
<dadinn>as mentioned before I'm running Guile 3.0.5, on Debian Bullseye, and have tried to remove ~/.cache/guile, and also tried to apt purge/reinstall guile-2.2 guile-3.0 ... all this to no avail
<dadinn>I've seen this email thread: https://lists.gnu.org/r/guile-devel/2012-01/msg00409.html
<dadinn>it kinda implies that there is some issue with guile-3.0, and using some sort of guile-2.0 compatibility stuff would resolve this...
<dadinn>it gives an error though: unfulfilled cond-expand in form (cond-expand ((not guile-2) (load "guile-2.0-compat.scm")))
<mwette>yewscion: If you mean procedure defined in file, i have added meta-command "list-procedure" to https://github.com/mwette/guile-jtd; ,use (jtd) then ,list-procedure <your-procedure>
***alMalsamo is now known as lumberjack123
<sneek>wb chrislck!!
<chrislck>sneek: botsnack
<sneek>:)
<dsmith-work>Wednesday Greetings, Guilers
<rlb>dadinn: not sure you presented the actual error you're seeing?
<dsmith-work>rlb: http://logs.guix.gnu.org/guile/2022-03-21.log#212321
<rlb>Oh right, but is there a backtrace, and what's the exact error message?
<dadinn>rlb: In procedure scm_to_utf8_stringn: Wrong type argument in position 1 (expecting string): #f
<dadinn>obviously (current-filename) returns #f, and then dirname blows up on it.
<mwette>if a procedure must return values is it legal to have last expression be (or (proc1) (proc2) (throw 'error)). <= not working
<mwette>^ where proc1 and proc2 return multiple values (and "return values" means "return multiple values")
<darth-cheney>hey gang, quick question
<darth-cheney>if I want to make an http request to download a file (binary) can I use web-client? And if so, how might one go about doing that?
<darth-cheney>For json and basic text requests I've been using the formation (receive (resp-status resp-body) (http-get "my-url") (do-something-with request-body))