IRC channel logs

2022-02-16.log

back to list of logs

<singpolyma>Hmm. What are the criteria for if (procedure-source) will work?
<lilyp>singpolyma: it works during compilation with the right flags
<lilyp>it might also work in interpreted mode
<lilyp>it won't work when loading byte-compiled code
***karlosz_ is now known as karlosz
<wingo>lilyp: singpolyma: i think actually it was removed from the reader in 3.0.6 :/
<wingo>3.0.5 rather
<wingo>* Incompatible changes
<wingo>** `copy' read-option removed
<wingo>This read option would include a copy of the source expression in the
<wingo>source-properties of each subexpression. This option has always been
<wingo>off by default and lost most of its use value with the switch to a
<wingo>compiler in Guile 2.0.
<stis>Hello guilers!
<singpolyma>wingo: ok, so (procedure-source) is mostly historical now but will almost always return #f ?
<wingo>singpolyma: yeah. if you want procedure source you can do (define-syntax-rule (lambda/source formals . body) (lambda formals #((source . (lambda formals . body)) . body))
<wingo>er
<wingo>scheme@(guile-user)> (define-syntax-rule (lambda/source formals . body) (lambda formals #((source . (lambda formals . body))) . body))
<wingo>scheme@(guile-user)> (lambda/source (a b) (+ a b))
<wingo>$3 = #<procedure 939550 at <unknown port>:8:0 (a b)>
<wingo>scheme@(guile-user)> (procedure-property $3 'source)
<wingo>$4 = (lambda (a b) (+ a b))
<singpolyma>In my case I want the source of an ecmascript procedure. I'm using a string literals right now, but it's kinda gross
<singpolyma>Maybe I can add support for es6 `` strings...
<wingo>if you have the string you can arrange to put it in as the "source" property in the function (part of the tree-il lambda's "meta" alist)
<singpolyma>Right, so the ecmascript reader could probably choose to do that if it wanted
***roptat is now known as Guest2562
<dsmith-work>Wednesday Greetings, Guilers
<leinad>Hi :-)
<civodul>i just noticed that compiler warnings with 3.0.8 are all marked as <unknown-location>
<lloda>istr that has been the case for a while
<lloda>or not (?)
<civodul>i think it used to work well
<lloda>sorry i think you're right
<lloda>i'm seeing that now where i didn't before
<dsmith-work>Looks like there are no tests for compiler warnings/errors.
<avalenn>I am a bit sad to see that base64 is not in Guile proper and reimplemented several times like in guile-email or in guix.
<civodul>and guile-gcrypt!
<civodul>though strictly speaking it's copied rather than reimplemented :-)
<civodul>i'd consider guile-gcrypt's the official copy
<avalenn>Ok. So i will use this one when I need it;.
<singpolyma>Should it not rather go in a base64 package the other there's could all depend on easily?
<dsmith-work>I wonder if it's possible to combine several .so's into a single .so?
<dsmith-work>Combine like segements. Adjust offsets. I wonder.
<daviid>gtk-4.6 landed in debian testing today, prety cool! now we need a debian libadwaita[-1.0] package [in debian] - https://blogs.gnome.org/alexm/2021/12/31/libadwaita-1-0/
<daviid>ah libadwaita-1-0 is in unstable already,so i guessitwill land in testing soon ...ish