IRC channel logs

2022-01-26.log

back to list of logs

<mwette>I'm a little lost on (web http) headers. If I want to splice accept into a list of headers to feed to http-get, do I use `(... ,(parse-header 'accept ..)) or `(... ,@(parse-header 'accept ...)) ?
<mwette>or something else?
<stis>Hej guilers!
<wingo>robin: i have a new idea
<wingo>gc-wise
<wingo>robin: https://www.cs.utexas.edu/users/speedway/DaCapo/papers/immix-pldi-2008.pdf
<wingo>we can start without generational gc. nice thing is that immix gets us compaction and bump-pointer allocation while still allowing conservative roots
<wingo>so, less risk.
<wingo>if we ever go generational we will have to add write barriers which would affect c users, so more complicated to pull off
<wingo>but apparently immix improves over bdw-gc, is a good single-generation heap, and has some good generational configurations as well
<wingo>there are a couple good followups, "rust as a gc implementation language", "fast conservative collection" among them
<robin>wingo, sounds interesting, about to fall asleep but i'll skim it on my kobo as i drift off (maybe literally dream about a better gc ;))
<lampilelo>wingo: you want to replace bdw in guile?
<wingo>lampilelo: would love to, yes. tricky though, as it's a kind of local maximum
<lampilelo>good luck ;)
<civodul>rlb: hi! FWIW, i get "unexpected syntax in form ()" as soon as it gets to compile the first .scm file, with Guile 3.0.7
<civodul>that seems to relate to (eq? #nil x) from the expansion of 'require-nil'
<civodul>does that ring a bell?
<rlb>civodul: yep - you'll need d79a226359d28f4a1dc5df136e5544d699903a96 I added that to debian's guile a while back.
<rlb>(to the 3.0.7 debs)
<civodul>rlb: oh crap
<civodul>did you look for workarounds?
<civodul>ah problem is that uses of define-method for instance are equally doomed
<civodul>so it's not just a couple of macro definitions that we could patch