IRC channel logs

2021-12-10.log

back to list of logs

<fnstudio>ArneBab: thanks and sorry for the slow reply, just seen this now
<fnstudio>ArneBab: what's the usual safeguard that protects from data leaks, should that piece of "random" data contain some sensitive info? is the OS that's expected to take care of that?
<fnstudio>or the process that was previously using that piece of memory?
<fnstudio>(sorry, this is possibly out of scope here, just a curiosity)
<amazigh>fnstudio: on unix, you do not have access to other process' memory except if you want to
<amazigh>so yes, that is the OS that is supposed to handle that.
<amazigh>But at Scheme level, you only have access to what you are given access too, there is no direct access to memory unlike C.
<amazigh>The exception is parameters, that you can "always" import and have access to them.
<amazigh>so with Guile a procedure has only access to the variables part of its lexical scope.
<lilyp>amazigh: there is direct memory access through FFI pointers...
<lilyp>fnstudio: I think in C-based libraries there's a stuff called "secure memory"
<lilyp>in Scheme you might want to clear your password bytevectors/strings before deallocating them
<ArneBab>fnstudio: sometimes data is zeroed, but see the details here: https://stackoverflow.com/a/8029651/7666
<ArneBab>(in short: malloc does not have to zero memory.
<fnstudio>amazigh lilyp ArneBab: thanks, very interesting
***rgherdt_ is now known as rgherdt
<lampilelo>so how's your advent of code going, guys? for now i struggled the most with day 8's 7 segment display puzzle
<taw10>lampilelo: I just finished day 8 part 2 today. Wow, there are a lot of "gotchas". But I'm pretty happy with my final code (I'll post it shortly)
<lampilelo>after i implemented the solution it turned out i had a bug somewhere and had to go through all of it again
<lampilelo>also at first i had an idea how to do this puzzle but scrapped it one hour in
<taw10>Me too! I thought it would have much more to do with part 1 than it actually did
<lampilelo>today's challange was pretty fun though
<dsmith-work>Happy Friday, Guilers!!
<fnstudio>very lazy question, i usually insert a (read) when i want to analyse a loop step by step, but then i need to type a char and press enter
<fnstudio>is there a way to resume the loop by just pressing enter?
<fnstudio>(i know, i feel ashamed by how lazy i am being here :D)
<lloda>fnstudio: (ice-9 rdelim) has read-line
<fnstudio>lloda: awesome, i'll go for that one then, thanks!
<ArneBab>lampilelo: I’m struggling with the segment display, too
***lampilelo_ is now known as lampilelo`
<fnstudio>lampilelo`: aoc is going well, my favourite one was probably the one with the fish
***lampilelo` is now known as lampilelo
<fnstudio>speed-wise, are a cond statement and finding an element in a hash-table equivalent?
<fnstudio>where the cond statement and the hash table are supposed to implement the same case-logic
<fnstudio>that might not be terribly clear
<lilyp>reminder that cond is more powerful than case/hash-tables