IRC channel logs

2021-12-02.log

back to list of logs

<excalamus>lilyp, thank you
<excalamus>in #guile, is there a bot like sneek? I don't see anything in the MOTD
<ArneBab>I’m taking the advent of code in Guile Wisp: https://www.draketo.de/software/advent-of-wisp-code-2021
<ArneBab>let’s see how far I get
<amazigh>hello
<amazigh>the link 'The Internet Scheme Repository' at https://www.gnu.org/software/guile/learn/ is dead
<amazigh>ref: https://cs.indiana.edu/scheme-repository/home.html
<amazigh>I am trying to port a json library to several scheme implementations
<amazigh>I have around 5 implementation passing the tests
<amazigh>At this time, I have a problem between guile, and mit-scheme
<amazigh>guile side I can't make library cond-expand declaration work
<amazigh>with something like:
<amazigh>% guile --r7rs myprogram.scm
<amazigh>here is an extract from the library.sld
<amazigh> (scheme write))
<amazigh> (export hello)
<amazigh> (cond-expand
<amazigh> ((or mit guile chibi gambit gerbil loko)
<amazigh>I found a quickfix with, I copied library.sld into library.scm then removed the cond-expand, and call: guile myprogram.scm
<amazigh>I dropped --r7rs flag from `guile` command line
<amazigh>and mit-scheme now works too with the hello program
<amazigh>fyi here is how the files a layed out on disk:
<amazigh>live/hello/body.scm
<amazigh>live/hello.scm
<amazigh>live/hello.sld
<amazigh>live/hello.rkt
<amazigh>live/hello.chez.sls
<amazigh>hello is what I called library.sld / library.scm above
<amazigh>ref: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=52239
<taw10>ArneBab: following your RSS feed :) I'm also trying AoC this year, in plain Guile
<lampilelo>i started learning scheme by solving aoc using guile, i think, 2 years ago, this year i'm trying rust
<attila_lendvai>is there a way to tell with-output-to-file to append instead of overwrite?
<attila_lendvai>this doesn't work: (with-output-to-file "/tmp/x" (lambda () (let ((port (current-output-port))) (fcntl port F_SETFL (logior O_APPEND (fcntl port F_GETFL))) (write (random 42) port))))
<attila_lendvai>doesn't seem possible, i have to use the lower-level machinery (open-file, call-with-port, with-output-to-port)
***chris is now known as Guest387
<samplet>Should you ever want to use XZ compression in Guile, you might like this library I made :) https://ngyro.com/software/guile-lzma.html
<civodul>samplet: oh nice! that's the only one we didn't have :-)
<civodul>well, that and bzip2
<samplet>It’s for Disarchive. I’m sure I’ll have to do bzip2 eventually.
<civodul>yes, i thought so
<dsmith-work>Morning Greetings, Guilers
<dsmith-work>!uptime
<sneek>I've been running for 28 days
<sneek>This system has been up 19 weeks, 1 day, 3 hours
***robin__ is now known as robin
<ArneBab>taw10: nice!
***sneek_ is now known as sneek