IRC channel logs

2021-11-13.log

back to list of logs

***lampilelo_ is now known as lampilelo
<dadinn>hi all
<Kolev>How do I make builders for Haunt?
<dadinn>I am facing a problem with using modules. I have a root project, which has a utils subproject which has two modules A and B. So in the top project i add (add-to-load-path (dirname (current-filename)), and use-module utils/A, and utils/B. The problem is that utils/B module also uses module utils/A... which could only be possible if it had (add-to-load-path (dirname (dirname (current-filaname))) ... this
<dadinn>works fine when i am running in Geiser, but fails when I run the parent project script! :/
<dadinn>the error is that comming from unknown file: (dirname #f) that it expects a string
<dadinn>I've checked, and for some reason in utils/B the current-filename call returs #f
<dadinn>*returns
<dadinn>btw, if I utils/B doesn't reference utils/A, I can run the parent project script fine, but Geiser complains when I try to load the utils/B module :/
<dadinn>any suggestions how to resolve this?
<nckx>sneek: seen davexunit
<sneek>davexunit was last seen in #guix 5 months ago, saying: irc or bust.
<xd1le>sneek: seen dthompson
<sneek>Sorry, no.
<avp>I released Guile-GitLab 0.1.0: https://lists.gnu.org/archive/html/guile-user/2021-11/msg00008.html
<KE0VVT>How do I get Haunt's blog builder to put posts in /yyyy/mm/dd/post?
<stis>Heya guilers!
<KE0VVT>Getting Haunt to use my URI scheme is hard.
<stis>KE0VVT: sorry I'm not familiar with haunt!
<dadinn>i've tried to look into this problem with current-filename and have no clue why it's returning false. It seems if the module itself is not a #! guile script, only a stand-alone module file, then the current-filename is not defined?
<lilyp>dadinn: compilation could be a reason
<lilyp>also, you shouldn't rely on current-filename anyway, particularly in modules
<lilyp>it's for interactive use mostly
<dadinn>lilyp: I think somewhere I've read that there is some project management tool for guile... not sure if it's called guild? Would that solve this problem? Or should I be using Makefiles?
<dadinn>when I am running the project using the parent shebang script, then it adds its own directory the same way to the load-path, and then everything works. But when I am running utils submodule alone, then Geiser is not able to resolve the use-module utils/A reference without adding the parent dir to the load-path
<dadinn>Also, in the utils/A and utils/B modules, I have (define-module (utils A/B)...
<lilyp>dadinn: I think it was called hall, but imho it's better to just learn autotools :)
<dadinn>lilyp: I think there is a way to make sure the add-to-load-path call is executed during compilation? or maybe to define a variable (define-parent-path (dirname (current-filename)) and make that evaluate during compilation?
<dadinn>I assume that wouldn't work :/
<lilyp>I'd like to have Guile support in meson, but meson is already weird with not liking single-file configurations
<lilyp>Most Guile projects use a file called pre-inst-env (generated from pre-inst-env.in by configure) setting GUILE_LOAD_PATH
<lilyp>See Guix for an example
<lampilelo>it would be handy to have support for guile in meson, we would have to make a module in their source tree since there's no way of loading external modules
<lilyp>fwiw you can just declare guild as a compiler, but the buggy subdirectory support (at least speaking about the versions currently in Guix) make it cumbersome
<KE0VVT>Error: Haunt: Personal Site repo <https://gitlab.com/calher/personal-site/-/tree/haunt>: https://paste.centos.org/view/66de84a5
<dsmith>lilyp: Look at eval-when for evaluating expressions at compile time:
<dsmith> https://www.gnu.org/software/guile/docs/master/guile.html/Eval-When.html
<lilyp>I know about eval-when, but what's that supposed to do?
<dsmith>Make sure you use it correctly, especially if you have a cat.
<lilyp>But what if I am a cat?
<dsmith>Just be extra extra careful then.
<dsmith>(see last paragraph in link above)
<lilyp>Welp, good thing that I'm now safe https://gitlab.com/lilyp/tsukundere/-/commit/e07e592420718d0b07c22b3f6c50c8f190650914
<morganw>lilyp: do you mind if I ask, does tsukundere support state rollback of some kind?
<KE0VVT>Haunt is so hard.
<KE0VVT>jgart: :-(