IRC channel logs

2021-10-31.log

back to list of logs

<Sheilong>Is it possible to break a do loop?
<RhodiumToad>sure, you can break out of anything with an escape continuation
<RhodiumToad>the do-loop syntax itself doesn't contain any exit mechanism other than the loop test condition
***ec_ is now known as ec
<RhodiumToad>given (let/ec break (do (...) (...) stuff...)) then invoking (break ...) anywhere will exit the form returning the value(s) passed to break
<Sheilong>Thanks.
<Sheilong>I tried to translate a python program into a scheme equivalent but I am having a different behavior in the Scheme one.
<RhodiumToad>then the translation was not correct, clearly?
<Sheilong>Probably not. I did some debugging, but haven't found yet where the problem is.
<chrislck>sneek: botsnack
<sneek>:)
<chrislck>sneek: transform
<sneek>Someone once said transform is "autobots go"
<morganw>Possibly I'm missing something fundamental, but why would I not be able to do (apply set! '(y 40)) where I can do (set! y 40) ?
<lampilelo>because set! is not a function