IRC channel logs

2021-10-16.log

back to list of logs

<RhodiumToad>I guess nobody uses (system foreign-object)
<dukester>Tire-kicker here & noob hobbyist. what's the diff between guile and e.g. Chicken scheme?
*RhodiumToad doesn't know Chicken, but I would guess the fact that guile was designed for embedding (i.e. to be an extension language for a C or similar program) gave it different design objectives
<dukester>RhodiumToad, Thx - I've become interested in embedded system lately, so guile might be interesting as well.
<lilyp>RhodiumToad: it's relatively new (so not backwards-compatible) and a bit idiosyncratic. Give it some time and it will find uses.
<RhodiumToad>it has bugs
<RhodiumToad>like getting the parameters to ensure-generic backwards
<lilyp>Ahh, well then that is an issue too and you might want to send patches to bug-guile or smth
<RhodiumToad>and ideally it needs an extra method to make it possible to use foreign-object classes as base classes
<RhodiumToad>right now it doesn't inherit the finalizer, making it pretty useless
<lilyp>Well, to be fair using "has-a" abstractions does work in many cases
<RhodiumToad>yes, I tried that as a workaround, but it's a bit messy
*RhodiumToad swears at (close)
<stis>Hello guilers!
<rlb>I'm a bit surprised srfi-4 doesn't include (u32vector-copy v), etc.
***chris is now known as chrislck
<lloda>array-copy does that
<lloda>it's a defect in the original srfi-4, but we have (srfi srfi-4 gnu) so it would be trivial to put -copy, -copy! and maybe -fill! in there
<rlb>lloda: thanks - I thought I'd seen a way, but didn't remember array-copy.
<stis>o/
<lloda>rlb: it's in (ice-9 arrays)
<lloda>the best (fastest) way is probably to make-u32 and then bytevector-copy!
<lloda>since bytevector-copy doesn't preserve the type
<lloda>and array-copy is slow for that case
<rlb>OK, thanks - in this case, I'm just implementing some of the clojure array operations, which are a little "odd" (i.e. jvm-interop-related). https://clojure.org/reference/java_interop#_arrays And in particular, fwiw, I wanted the copy operation for (aclone array).
<rlb>atm, I was mapping long-array -> s32vector, etc.
<rlb>Of course some of them may not really make sense -- for now just implementing the more common ones.