IRC channel logs

2021-09-19.log

back to list of logs

***smitop7 is now known as smitop
***KE0VVT is now known as Beigeinator
***Beigeinator is now known as KE0VVT
***chris is now known as Guest6757
<stis>Tja guilers!
<manumanumanu>tjenixen stis
<stis>hej manumanumanu:
<stis>What other languages totally miss when they want to be functional is named lets, I could be without map reduce and all that, just let me have a named let construct
<ArneBab>stis: yes! I missed that in the 10x-advantages of Guile — now I need to select one to replace :-)
<stis>ArneBab: I just sent an email to the liist where you can find a nice example of whats doable in scheme and not python using python code and extensions available in python-on-guile
<ArneBab>very cool!
<stis>basically in python-on-guile, yield id a function ahndle that you can bass as a value to other functions
<stis>And that generators and iterators are copyable
<ArneBab>wow — that’s what I’d wish to have as syntactic sugar in regular Scheme :-)
<stis>I have such a syntactic sugar
<stis>for scheme as well
<stis> https://gitlab.com/tampe/scheme-python/-/blob/master/modules/util/scheme-python/yield.scm
<stis>to see example of usage, consider row 284 in https://gitlab.com/python-on-guile/python-on-guile/-/blob/master/modules/language/python/module/os.scm
<stis>to use it in a nice way a for construct is needed e.g. https://gitlab.com/tampe/scheme-python/-/blob/master/modules/util/scheme-python/for.scm
<ArneBab>stis: with using a fluid, can I use a yield in a yield?
<stis>Should work
<stis>I think that some wotks needs to be done to get this to work with fibers
<stis>e.g. whole of python on guile
<ArneBab>that would be pretty cool
<ArneBab>Does it work with POSIX threads?
***sneek_ is now known as sneek
<stis>Shoule work but very little is tested with respect to native threasd. I usually use fluids to store gloabal data
<stis>but one should avoid sending a yield into a nother tread. But it is possible as we can copy generators and iterators
<theruran>I have a question. if I create a bunch of GOOPS objects that inherit in a hierarchy, how's best to address them in a universe of objects? do I literally just create a VHash table of UUID -> Object and call that my Universe?