IRC channel logs

2021-09-12.log

back to list of logs

<vijaymarupudi>daviid: Is there a way to get the pointer-address of a g-object?
<daviid>vijaymarupudi: !g-inst iiuc
<vijaymarupudi>daviid: I think that's it! I couldn't really figure it out using the documentation, thanks!
<vijaymarupudi>daviid: I think I'm running into a g-golf bug? This program will open a window with a text view. Try typing a decent amount of text in it, backspace, remove text, add text. It will eventually segfault, not sure why... https://paste.gnome.org/pddmgitte
<daviid>vijaymarupudi: i will look at it asap, tx
<vijaymarupudi>daviid: Thanks!
<daviid>vijaymarupudi: i will work on a 'proper' soltution to fix this bug, but meanwhile, you can comment the gtk-text-iter-free calls [in any of your app(s)], and it should not segfault anymore
<daviid>i slightly changed/adapted your snispet, so the sw is in the box, which becomes the window child, added box margins and v[h]expand properties to the box and the sw ... if it interest you, here - https://paste.gnome.org/pxbrttxyy
<daviid>thought it seems <gtk-box> instances v[h]expand by default, if i comment lines 38 and 39, it still v[h]expand, but you definitely need to specify those when making the sw ...
***Guest3024 is now known as chrislck
<vijaymarupudi>daviid: Thanks for the fixed snippet, yeah the original one was something I made quick to replicate it, the bug was actually happening in a larger project
<vijaymarupudi>daviid: I'll be making a lot of textiters, hopefully that won't be too much memory haha
<daviid>vijaymarupudi: need to double check, but those semi-opaque struct are mem wise scheme allocated, gobject filled, then gc'ed when unreachable, so you shouldn't have mem leak ... if so, users indeednot free those ...
<stis>Hi guilers!