IRC channel logs

2021-09-09.log

back to list of logs

<muradm>why file-name-separator-string is string, while (string-split ...) second argument is char? :)
<muradm>not very efficient, but useful tool to serve local files https://paste.rs/gRr :) here i stop..
<muradm>in (ice-9 getopt-long) source there is an example https://paste.rs/IRV
<muradm>(predicate ,string->number) does not work me, i see that is is just applies function (pred val) on line 209
<muradm>but i always get wrong type to apply
<muradm>(predicate 'string->number) also fails
<muradm>(predicate (lambda (v) ...)) also fails :)
<muradm>(predicate ,(lambda (v) ...)) (predicate '(lambda (v) ...))
<muradm>damn.. found it
<civodul>muradm: hi! i'd recommend (srfi srfi-37) for option parsing, i find it more pleasant to use and more capable
<muradm>civodul: o.. thanks, will check that now
***chris is now known as Guest248
***Guest248 is now known as chrislck
<dsmith-work>{appropriate time} Greetings, Guilers
<dsmith-work>muradm: https://paste.debian.net/1211106/ getopt-long
<dsmith-work>muradm: So 2 things. Needed to use ` instead of ' . canonicalize-path does not return #f on failure, so wrapped it with false-if-exception.
<stis>Hi guilers!
<muradm>dsmith-work: thank you! yeah i already figured out problem with ` :) thanks for false-if-exception, this is good oneofvalts
<muradm>oneofvalts = one (sorry autocompletion)
<festerdam>Hi, all!
<festerdam>The website says that support for Lua is being added. What is the current situation? It seems like commits in that regard have stopped a year ago.
<dsmith-work> /enable snark mode
<dsmith-work>I think people evenually lose hactivation energy. Why write in lua or whatever when you can use Scheme.
<RhodiumToad>lua is a lot more easily embedded than guile
<festerdam>dsmith-work: Althugh Scheme is great, people who want to extend some software are much more likely to know Lua considering it is a very popular language. So I was thinking whether it is possible for those unenlightened people to extend the software anyway.
<dsmith-work>RhodiumToad: Indeed!
<morganw>I think Fennel is the go-to solution that people use at the moment, to end up with Lua code: https://fennel-lang.org/
<lampilelo>i wonder how feasible it really is to have multiple languages with very different paradigms on the same vm, given that the compatibility problems arise even between different lisp dialects, the recent example being scheme, clojure and elisp in relation to #nil
<festerdam>lampilelo: It seems at least some work was done, in regards to Lua: https://gitlab.com/NalaGinrut/guile-lua-rebirth
<lampilelo>i'm not saying it can't be done, but it certainly involves some compromises between performance and standard conformity, at least that's my presumption
<lampilelo>there are more projects like this, e.g. https://gitlab.com/python-on-guile/python-on-guile
<RhodiumToad>the lua one is odd because lua is itself designed for embedding, and embedding it is tons simpler than embedding guile
<lampilelo>still should be useful, because with guile you get more languages, in principle
<RhodiumToad>yeah, but with a hell of a lot of overhead
<RhodiumToad>lua is really small
<dthompson>guile isn't really meant for embedding
<sneek>dthompson, you have 2 messages!
<sneek>dthompson, ArneBab says: did you see https://paste.debian.net/1202617/ ?
<sneek>dthompson, ArneBab says: this gives in chickadee 299:4 0 (sprite-batch-add* #<<sprite-batch> texture: #<texture…> …); chickadee/graphics/sprite.scm:299:4: In procedure sprite-batch-add*:; In procedure bytevector-ieee-single-native-set!: Wrong type argument in position 1 (expecting bytevector): #f
<RhodiumToad>embedding into other programs, I mean, and that is _exactly_ what it is meant for
<dthompson>I don't understand the distinction?
<dthompson>ArneBab: not sure when you sent this but I responded in #chickadee and sent some code that works for me.
<dthompson>that was sometime yesterday.
<lampilelo>RhodiumToad: are there any benchmarks comparing the two?
<RhodiumToad>probably, somewhere
*civodul is surprised that ",opt (expt 2 3)" does nothing