IRC channel logs

2021-08-14.log

back to list of logs

<dokma>avp: what are those asterisks doing in your path? Is that normal?
<dokma>paths are usually not specified with asterisks
<dokma>particularly in a colon separated syntax I have never seen that
***Noisytoot_ is now known as Noisytoot
<vijaymarupudi>daviid: Do you have pointers on how to subclass <gobject> in g-golf for using https://docs.gtk.org/gio/class.ListStore.html
<vijaymarupudi>Just subclassing gobject and instantiating throws a unbound slot error
<daviid>vijaymarupudi: was afk, back ... could psate (debian or gnome) a snipset, you should be able to 'just subclass' ... but you prob found a bug ...
<vijaymarupudi>Would appreciate the snippet, will post a minimal example of the issue I'm facing
<vijaymarupudi>Here's the example: https://paste.gnome.org/pc3ajgjz0
<daviid>you should subclass the gio listore class, not gobject
<vijaymarupudi>I think I should phrase my question differently, Gio.ListStore only stores GObjects, and I want to add some of my own objects to it
<daviid>vijaymarupudi: imeant to write *could you paste ... but you did :) - now, why would you subclass GObject, what are you trying to acheive exactly?
<daviid>vijaymarupudi: and why would you prefer to use <g-list-store>, instead of plain scheme lists?
<daviid>but i'll look into Unbound slot in object #<<gobject-class> <person> 7f3bb090da50> anyway ...
<daviid>the bug - this is a g-golf bug - is that as things are, <gobject> 'g-type slot isunbound
<vijaymarupudi>I need it to use https://docs.gtk.org/gtk4/class.ListView.html
<vijaymarupudi>To create a ListItemFactory, I need to associate a GtkListModel with it
<vijaymarupudi>Also see this: https://docs.gtk.org/gtk4/method.ListBox.bind_model.html
<daviid>vijaymarupudi: so, iiuc, you need to subclass <gobect> so that its instances may be used with other gtk classes?
<vijaymarupudi>daviid: Yep! Something like this: https://pygobject.readthedocs.io/en/latest/guide/api/gobject.html
<daviid>vijaymarupudi: great, tx forthe link
***vijaymarupudi_ is now known as vijaymarupudi
<daviid>vijaymarupudi: I just pushed a fix to g-golf devel branch, see if it works as expected, letmeknow ...
<daviid>vijaymarupudi: here, your <gobject> derived class example - https://paste.gnome.org/py5nmlouh
***chris2 is now known as Guest7553
<tohoyn>Theme-D version 4.0.2-1 has been released. It contains some bug fixes. See http://www.iki.fi/tohoyn/theme-d/.
<jgart>tohoyn, have you tried using theme-d with guix? that is, for adding types to packages and/or services
<tohoyn>jgart: interesting idea
<jgart>I'd be happy to test it out and dogfood it
<tohoyn>jgart: great! just ask me if you have anything to ask.
<jgart>I'll try to package theme-d for guix soon
<jgart>does the guile implementation depend on racket for anything or you just have two implementations in the same repo?
<tohoyn>there is also a Theme-D forum at https://sourceforge.net/p/theme-d/discussion/general/
<jgart>sorry, I haven't looked at the code closely yet
<tohoyn>jgart: it doesn't depend on racket
<jgart>cool cool
<tohoyn>jgart: I used to have a racket backend but it is no longer supported
<jgart>ohh ok
<tohoyn>jgart: I have to leave now. I'll be online later today.
<jgart>I'm usually hanging around. I'll probably be around tonight (ET)
<jgart>nice chatting! looking forward to checking out theme-d closer
<dokma>leoprikler: still no improvement on the stop-server-and-clients! issue. For now I'm shutting down with (kill (getpid) SIGINT) until I learn enough scheme to understand this module. Same behaviour with guile 2.2 and 3.0.7.
<dokma>Now I've ran into another issue. When I try to (define ks-shutdown (kill (getpid) SIGINT)) from the repl the function gets immediately executed instead of just defined.
<dokma>Anyone got a clue as to why this would happen?
<leoprikler>(define (ks-shutdown) ...)
<dokma>oh... let me try that
<dokma>Tried with (define (ks-shutdown) (kill (getpid) SIGINT)
<dokma>Now when I (ks-shutdown)
<dokma>I get warning: possibly unbound variable `ks-shutdown'
<dokma>Is it allowed to define procedures from the REPL ?
<dokma>There was another brace at the end of that define line.
<dokma>It didn't paste right.
<avp>sneek: Later tell dokma: yes, REPL allows to define new procedures. Did you call 'ks-shutdown' right after the definition, in the same REPL session?
<sneek>Got it.
<avp>It seems that I managed to fix some random segfaults that occored during tests in Guile-SSH.
<avp>At the end of the day, they where not so random.
<avp>One of the insights was that I can bypass libssh internal logging altogether, calling the user-specified logging procedure right away instead.
<avp>Guile-SSH used to pass Guile objects to a libssh logging procedure as a opaque pointers, and some Guile objects didn't make it to the point when an actual Scheme callback procedure called, GC'ted on the way.
<avp>Also, SRFI-64 test framework don't really like tests that spawn new processes that do stuff without calling some kind of 'exec'.
<avp>s/don't/doesn't/