IRC channel logs

2021-08-08.log

back to list of logs

<darth-cheney>hello all, is there some built-in function or set of functions I can use to compute CPU usage as a percentage every N number of seconds or something like that?
<daviid>sneek: later tell dthompson same here, since switched to guile 3, and the latest geiser, not sure which causes the problem- if you find a solution, let meknow ...
<sneek>Got it.
<tohoyn>darth-cheney: what about statprof?
***kir0ul3 is now known as kir0ul
***dongcarl1 is now known as dongcarl
***chris is now known as Guest8165
<stis>Tja guilers!
<manumanumanu>Tja stis
<stis>whats up manumanumanu:
*stis is wotking with binary serializers and deserializers
<stis> https://gitlab.com/tampe/stis-data/
<manumanumanu>I am working on a scribble-like-system for guile. Not skribilo, but one that does the same thing, except it is non-code-first like scribble, not code-first like skribilo.
<manumanumanu>stis: I'll have alook
<stis>The nice thing is that it can ouput and input from stream and all code is flat meaning that no buildup of the stacks e.g. good for fibers
<stis>aha scrible, nice!
<manumanumanu>stis: that is a nice thing! I had some code I wanted to try to fiberize, but the continuations were so large it actually hurt performance before I rewrote it
<avp>stis: Will it be similar to Python "shelve" module?
<stis>the python serializing and deserializing tools is supprted in python-on-guile
<stis>this is a standalone serilizing tool and currentlu only handles the basic datastructures
<stis>no lambdas
<manumanumanu>how would you serialize a lambda?
<stis>avp: for your information you can get generators and iterators to serialize in python-on-guile
<stis>manumanumanu: c.code magic that you can find in guile-persists
<stis>avp: that's not suported in CPython
<stis>avp: it's a tricky thing though beccause you need to serialize continuations, which is not possible in guile generally without turening off inlining of datastructures on the stack
<stis>manumanumanu: https://gitlab.com/tampe/guile-persist
<stis>it's ugly as hell
<manumanumanu>it does tickle the wrong places...
<manumanumanu>but in the right way
<stis>lol
<stis>stis-data has a more thought out code and I like it much more
<stis>I will carry over features from guile-persists as time goes to stis-data
<manumanumanu>I will keep an eye at it! Now sleep!
<manumanumanu>gnight!
<stis>night!
<stis>ping zlib maintainer
<stis>who is it and is he/she here
<stis>guile bindings that is¨
<stis>sneek where is zlib
<stis>sneek: where is zlib
<stis>sneek: help
<ft>guix says guile-zlib is here: https://notabug.org/guile-zlib/guile-zlib — Most commits are by civodul.
<lloda>r7rs doesn't have bytevector-fill!
<lloda>i'm going to extend the core version to support start end
<lloda>the r7rs version is just (bv fill) so no conflict
<lloda>the r6rs version i mean
<lloda>there is only one #f and one #t, right? i mean for every x that is #t/#f (eq? x #t/#f) is true
<vijaymarupudi>manumanumanu: I have a working copy of the exact same thing, was going to write up documentation for it
<vijaymarupudi>I'll put source code up somewhere now
<vijaymarupudi>It was able to parse through war and peace in 0.8 seconds, which I think is acceptable performance for such a thing
<vijaymarupudi>Here's a link to what I have: https://gitlab.com/vijaymarupudi/nectar
<vijaymarupudi>It's pretty much done, the HTML renderer and plaintext renderers work well, I have a plan for enabling whitespace sensitive extensions soon.
<vijaymarupudi>I think the approach I chose has promise, it allows for any amount of post processing by traversing the AST (or SXML) after evaluation, which can be used for table of contents, interpage links for static websites, etc.
<leoprikler>vijaymarupudi: that looks promising but also not how you will have to keep large chunks of xml (parse trees) in memories then
<vijaymarupudi>I've designed it so that you don't have to do that, that just what the default renderers use
<vijaymarupudi>"nectar" is a term that refers to a list of expressions that evaluate to parse trees
<vijaymarupudi>You can just loop over them, eval each top level expression one by one, and then do what you wish with it