IRC channel logs

2021-06-06.log

back to list of logs

<bud>yeah. This is the last thing i really miss from my old windows setup.
<bud>i had this script that let me, do things like: hold right+scroll -> switch tab
<bud>hold left+scroll -> switch program (alt+tab)
<bud>right+middle close tab
<bud>left+middle close program
<bud>it was great.
<dsmith>The only "chording" I've ever seen before is in Plan 9
<bud>YES!
<bud> https://0x0.st/-_p9.txt
<bud>this works, hold right and scroll to send control+page_up/down
<bud>try it in the browser!
<bud>and just pressing right, at least have its own function (notify-send alone)
***conjunctive_ is now known as conjunctive
***unCork is now known as Cork
<dsmith>nc
<tohoyn>retropikzel: terve
<retropikzel>tohoyn, moro
<emestee>I don't presume anyone here is a character terminal magician that could explain me why sending an ANSI escape command to interrogate the terminal causes the terminal to print the response locally?
<dsmith>emestee: What do you mean by "locally"? What are you expecting to happen?
<emestee>dsmith: i send an ANSI device status request to guile standard output and read the terminal's response on standard input. However, something duplicates the terminal's response to its screen. Guile is execute from the shell that lives in tmux. I don't know which component is echoing the terminal's response (e.g. encoded cursor position) back to the terminal
<emestee>executed*
<emestee>it's basically putty -> ssh -> shell -> tmux -> shell -> I assume pty -> guile
<dsmith>And the Guile prog does read the response?
<dsmith>Hmm. Might need to turn echo off or something like that.
<dsmith>I think I ran into something similar one time. Was sending some escapes to determing screen size.
<dsmith>I don't have that code here.
<dsmith>Hah! Found it.
<dsmith>emestee: Yeah, I'm disabling echo.
<emestee>dsmith: how?
<dsmith>emestee: https://paste.debian.net/1200172/
<emestee>ah termios, so it *is* done by linux and not the terminal itself
<emestee>well then, time to abuse the ffi I guess
<emestee>thanks!
<dsmith>It's the pty I think.
<dsmith>A terminal is just a thing on the end of a serial port that you send chars to and read from.
<dsmith>emestee: There was a nice article I read recently that goes into the history of serial ports on unix and why xterm behaves the way it does.
<dsmith>Sadly, I don't have a link to it.
<dsmith>emestee: Might have been this: https://www.linusakesson.net/programming/tty/
<xeno>hi, I don't get the simple call/cc example from The Scheme Programming Language: (let ([x (call/cc (lambda (k) k))]) (x (lambda (ignore) "Hey!")) - why is the last lambda evaluated rather than returned?
<xeno>oh damn, I think I just got it
<emestee>is there a method to perform arbitrary system calls?
***pritambaral is now known as prite