IRC channel logs

2021-05-26.log

back to list of logs

***lfam is now known as zebracloud
<tohoyn>daviid: is it possible to build G-Golf for Guile 2.2 even though Guile 3.0 is installed in the system?
<tohoyn>daviid: Guile 3.0.7 has not yet been published in debian. that's why I don't want to build the debianized G-Golf package for Guile 3.0.7.
<daviid>tohoyn: yes, even with 2.0
<unknown_lamer>dsmith-work: I guess adding dual network support to sneek would have been a waste of time after all ;) (rip freenode)
<tohoyn>daviid: how is it done?
<daviid>tohoyn: look for GUILE#_PROGS in guile-ext.m4
<daviid>* GUILE3_PROGS
<tohoyn>daviid: I tried the following: GUILE=/usr/bin/guile-2.2 ./configure --with-guile-site=yes
<tohoyn>daviid: result: configure: error: found development files for Guile 3.0, but /usr/bin/guile-2.2 has effective version 2.2
<daviid>tohoyn: yes, you need more env var (re)def when you have //install...
<tohoyn>daviid: I set GUILE_EFFECTIVE_VERSION=2.2. ./configure works now.
<tohoyn>daviid: BTW, does G-Golf use gtk-4 by default?
<daviid>tohoyn: no, which version is used is determined by which are available and GI protocol, that is it will import the latest, unless you require/pass a specific #:version optional kw value
<tohoyn>daviid: ok
<flatwhatson>probably need to update the "#guile on Freenode" on https://www.gnu.org/software/guile/
<dsmith>unknown_lamer: Yeah
<taylan>does anyone know who controls the website?
<taylan>there's been a dead link on http://www.gnu.org/software/guile/manual/ for years now :D
<wingo>dsmith-work: like, an option that would make "guild compile" fail if there were a call that is known to have the wrong arity?
<wingo>actually -Werror would be nice...
<wingo>the web site is modifiable by any project contributor, technically
<wingo>is the dead link on /manual/ the postscript file?
<wingo>that page is generated by gendocs.sh; we probably need to update ours
<taylan>yeah it's that one, also subject of this report: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=15536
<taylan>I've been trying to do a bit of housekeeping on debbugs and that one annoyed me for being so minor and yet unresolved for ... *checks* ... about 8 years :D
<RhodiumToad>the link to freenode is probably a more urgently required fix :-)
<RhodiumToad>(for those not aware, #guile on freenode got killed a few hours ago)
<wingo>is there a web irc client that new irc users could use to access this channel?
<emanuele6>kiwiirc.com works
<RhodiumToad>looks like libera doesn't have its own web client (yet?), probably it's not at the top of their priorities list right now
<wingo>i guess i will update the web site without a link to some web client
<wingo>(kiwiirc claims to be sponsored by PIA -- isn't that related to the entity that took over freenode?)
<emanuele6>oh, i did not know that
<wingo>dunno, that was an old sponsorship note
<emanuele6>they have libera.chat on the default server list though
<RhodiumToad>sponsored by, but afaik still independent of - more serious is that the kiwiirc project lead (prawnsalad) is quitting over the whole incident
<RhodiumToad> https://gist.github.com/prawnsalad/4ca20da6c2295ddb06c1646791c61953
<wingo>(i am not against sponsorship fwiw, just that it seems that PIA is... not good)
<wingo>wow this thing is high drama :)
*wingo avoids looking into it any more :P
<wingo>ok web site updated fwiw
<wingo>tx emanuele6 for kiwiirc suggestion
<emanuele6>you are welcome :)
<tohoyn>daviid: is there any way to find out what is the default gtk version that g-golf uses?
<tohoyn>daviid: i.e. what gtk version g-golf uses if #:version is not specified
<opfez>i'm having a problem with alists. if i have a file "f.scm" which contains a definition for an alist (define a '(("foo" . 1))) i cannot change the value if i load it via (load "f.scm)
<opfez>(assq-set! a "foo 2") just adds a new entry: '(("foo" . 2) ("foo" . 1))
<opfez>are alists loaded from another file immutable, and how can i make them mutable?
<tohoyn>daviid: I made a new debianized release of G-Golf. See http://www.iki.fi/tohoyn/g-golf-debian/.
<RhodiumToad>opfez: the use of assq-* functions means you're expecting the keys to be eq? rather than equal?
<RhodiumToad>opfez: and strings are not eq? to other strings with the same content except by chance
<opfez>RhodiumToad: if i later do assq-set! on the new alist, it correctly changes the value
<opfez>it correctly changes the value of the new entry, but i want to change the value of the old entry
<RhodiumToad>opfez: I think what you're finding is that two string literals in the same compiled file refer, by chance, to the same actual object and are thus eq?
<opfez>i'm testing this in the repl
<RhodiumToad>opfez: but this is an implementation artifact and therefore your code is incorrect
<tohoyn>opfez: try (define a (list (cons "foo" 1)))
<opfez>i will
<RhodiumToad>bottom line is that you should be using assoc- and not assq- functions
<RhodiumToad>or use symbols rather than strings as keys
<opfez>RhodiumToad: i did use assoc- before, and it gave me an error: set-cdr! expected a mutable pair
<opfez>tohoyn: hm that doesn't work unfortunately
<RhodiumToad>ah, that's a different issue
<tohoyn>opfez: try to use assoc-xxx instead of assq-xxx together with my previous suggestion
<RhodiumToad>by defining the alist as a literal list, it's being made immutable by the compiler
<opfez>ah now it works
<opfez>thank you RhodiumToad and tohoyn
***ArneBab_ is now known as ArneBab
<ArneBab>The new freenode owners zapped the #guile topic. I’m glad we moved here.
<civodul>ArneBab: are there still people there?
<RhodiumToad>they zapped the whole channel, really
<RhodiumToad>#guile is now invite-only and moderated, when I left it still had people in it but nobody could say or do anything
<civodul>woow
<RhodiumToad>on join, #guile redirects to ##guile now
<RhodiumToad>~8 people in ##guile
<RhodiumToad>(which has no owner or ops)
<emanuele6>if it has no owner why does #guile redirect to ##guile?
<civodul>seen on the fediverse: "andrew lee just seized over 700 channels on freenode because they mentioned libera.chat in their topic."
<RhodiumToad>emanuele6: it's to take it out of the reserved topic namespace
<emanuele6>oh, it says that the founder is freenode-placeholder-account
<ArneBab>civodul: yes, many.
<clacke>whether PIA is sleazy needs to be evaluated on its own merits; LTM, which owns Freenode Ltd, sold PIA two years ago
<lampilelo>afaiu the number 700 is an arbitrary estimate, it's just the number of channels that mentioned libera in their topic, there's no concrete evidence all of them got cancelled
<lampilelo>at least i haven't seen one yet
<lampilelo>test
<lampilelo>i joined the channel as a guest from kiwiirc and the messages from it don't show up and there's no indication in the kiwiirc client that's the case, what if a noobie joins by clicking the link on guile's webpage and tries to ask a question?
<daviid>tohoyn: as sais earlier, there no 'default' version, it will import the latest installed on the system it's being used on, unless passed #:version ...
<daviid>tohoyn: you may list available versions, see (g-irepository-enumerate-versions namespace)
<daviid>here, scheme@(guile-user)> (g-irepository-enumerate-versions "Gtk") -| $2 = ("2.0" "3.0" "4.0")
<daviid>tohoyn: tx for the updated g-golf debian package
<daviid>tohoyn: https://www.gnu.org/software/g-golf/manual/html_node/Repository.html#Repository
<tohoyn>daviid: I built the new g-golf package against gtk-3 because libgtk-4 is currently in the experimental distribution.
<daviid>g-golf doesn't require gtk
<daviid>to build
<tohoyn>daviid: ok
<tohoyn>daviid: what about the test cases in g-golf?
<daviid>as tested here, they pass using any of gtk2, 3 or 4 -
<tohoyn>daviid: anyway, the g-golf debian package has currently a dependency to libgtk3
<daviid>you should remove the dependency - what about someone want to try gtk4 ...
<leoprikler>I think the question is how to handle the case, when no Gtk is available at build time (more exactly during `make check`)
<leoprikler>Does g-golf handle that gracefully?
<tohoyn>leoprikler: test cases work but they required two patches to pass
<tohoyn>leoprikler: the patches were required in order to get test cases pass during the debian package build
<tohoyn>leoprikler: one patch is for using xvfb to run the tests
<daviid>i'll change the test suite - later on, have other priorities now ... - not to depend on gtk, nor clutter ... but you should _not_ make it depend on gtk3,nor clutter to build ... anyway,afk, bbl
<tohoyn>daviid: I'll work on that
<tohoyn>leoprikler: another patch was about removing a test case involving a TTY
<tohoyn>daviid: as long as the test cases depend on GTK it has to be in the dependencies
<tohoyn>daviid: but I'll change the dependencies so that libgtk4 is accepted, too
<tohoyn>daviid: ok?
<tohoyn>daviid: actually it should be sufficient to have the GTK and Clutter dependencies only in the Build-Dependencies
<daviid>not the build dependencies, the test dependencies
<daviid>these are pre-rebuild pkg, not official releases ... and that the test requires a gtk typelib is 'a thing', making it a specific version is 'wrong'
<tohoyn>what do you mean by test dependencies? Is there such a field in the Debian control file format?
<wingo>lampilelo: weird! happy to switch web irc links if we find one that works
<daviid>tohoyn: just not make the build depend on gtk nor clutter
<lampilelo>wingo: can people that are not logged in talk on this channel? i used just the default nick and didn't identiy
<tohoyn>daviid: since this is a pre-build package it should be ok to disable the tests during the Debian package build. Otherwise the package will not build unless gtk and clutter are not in the build dependencies.
<tohoyn>daviid: shall I disable the tests in the package build?
<wingo>lampilelo: no idea -- i am not an irc expert :P
<wingo>i don't think chanserv needs to identify you, if that's the question
<lampilelo>me neither, the last time i owned an irc channel was like 13 years ago
<daviid>tohoyn: yes, the pre-official deb package should not impose any of gtk and clutter ...
<tohoyn>daviid: ok
<lampilelo>hmm... maybe civodul knows more about it?
<tohoyn>daviid: changes done.
<dsmith>wingo: Yeah, -Werror might help that. And -Werror is a good thing to have anyway.
<dsmith>It's there an irc scheme for urls? Like irc://irc.libera.chat ?
<dsmith>ircs://irc.libera.chat/#guile
<taylan>hmm yeah, guile-guest can't speak. I had muted unregistered users on the first day of creating this channel because there was extreme spam due to the Freenode drama, it's probably that
<taylan>"Channel #guile modes: +ntz" I can never remember these mode letters...
<taylan>strange, according to https://libera.chat/guides/channelmodes none of those should mute unregistered users.
<dsmith>taylan: Weren't those spambot promoting freenode?
<taylan>yeah something like that. they were spamming "this channel has moved to freenode" in all-caps on repeat, like that's going to convince people :P
<dsmith>Ya.
<taylan>hmm, guile-guest can message #guix but not here, even though #guix also has +ntz set (and also C and c which seem irrelevant)
<taylan>also can't message #scheme which has the exact same flags as here. maybe the C or c flag on #guix does make a difference somehow.
<roptat>civodul, wingo you probably want to set a few more flags on #guile: it has PUBACL currently, whereas #guix has SECURE KEEPTOPIC TOPICLOCK GUARD PUBACL
<civodul>roptat: i'm a complete noob: what do we have to type? :-)
<roptat>/msg ChanServ set secure on
<roptat>and same for the other flags
<roptat>you can learn more about these flags with /msg ChanServ help set
***ksroot is now known as KC1NCN
***ChanServ sets mode: +o civodul
***services. sets mode: +o ChanServ
***ChanServ sets mode: -o civodul
<civodul>roptat: thanks, i think we're good now!
<taylan>the guest user still can't send messages
<taylan>roptat: ^ any insight on that? it can send to #guix but not here
<dsmith-work>Hey Hi Howdy, Guilers
<dsmith-work> https://libera.chat/guides/channels#why-cant-i-talk-in-a-channel
<dsmith-work>How do you contact a staffer? I'm not seeing that anywhere.
<dsmith-work>In #libera I guess
***KC1NCN is now known as ksroot
<leoprikler>Nice, #guile now has as many users here as in the compromised server
<dsmith-work>leoprikler: #guile or ##guile? I tried to connect earlier today and ##guile had about 8 nicks in it.
<dsmith-work>#guile was up to about 160 or so before the drama started, right?
<leoprikler>#guile
<dsmith-work>s/#guile/freenode #guile/
<dsmith-work>leoprikler: are you in there? Can you invite me?
<leoprikler>just left
<dsmith-work>heh
<tohoyn>what's the problem with #guile?
<leoprikler>We were naughty and redirected people to Libera
<dsmith-work>Oh the drama
<roptat>taylan, I think I don't see all the flags/options, so to me the two channels look the same
<roptat>or I'm not looking at the right thing
<roptat>civodul, taylan I think you'd need to set -m on this channel
<roptat>but it doesn't seem to be set, so I'm confused
***chris is now known as Guest8302
<dsmith-work>sneek: botsnack
<sneek>:)
<lloda>(check)