IRC channel logs

2021-05-24.log

back to list of logs

<leoprikler>It's on 3.0.2
<taylan>dsmith: I'm now at least able to explain the bug in detail: https://bugs.gnu.org/42345
<leoprikler>applying that fix doesn't seem to work for me ._.
<dsmith>taylan: Very nice
***malaclyps is now known as mala
***mala is now known as ma
***ma is now known as mala
***mala is now known as dob
***dob is now known as dannyob
***dannyob is now known as dannyobrien
***dannyobrien is now known as malaway
***malaway is now known as mala_
***mala_ is now known as mala
<daviid>spacebat1: for info https://gitlab.com/a-sassmannshausen/guile-hall (which is not and not related to guildhall) is an option, although most of us use the autotools chain
<daviid>spacebat1: akku is another one https://akkuscm.org/
<daviid>spacebat1: fwiw, hall is mentioned in the guile manual, here 4.8 Distributing Guile Code
<dsmith>taylan: Are you thinking that wrong-num-args bug is becuse how the function name is accessed, or becuse the frame is being constucted incorrectly?
<taylan>dsmith: not entirely sure yet but leaning towards "frame constructed incorrectly" because the docs about the calling convention seem fairly clear that the called procedure should be put in slot 0
<taylan>dsmith: the comment about slot 0 not necessarily containing the procedure might be meant in the sense that the procedure's own instructions might decide to put something else there, when it's not needed anymore
<dsmith>Ahh. Yeah, I was wondering about that comment.
<apteryx>is here a way to programmatically add a breakpoint in the sources? something like '(use-modules (system vm traps)) (breakpoint)' (pseudocode) ?
<tohoyn>sneek: botsnack
<sneek>:)
<apteryx>I got a 'source-properties' object equal to '((filename . "/tmp/test.scm") (line . 6) (column . 33)), but somehow (source-property obj 'filename) returns #f.
<apteryx>seems to me source-property should be equivalent to assoc-ref, but apparently not
<apteryx>here's my current attempt, which fails with "No procedures found at ~a:~a. "/tmp/test.scm" 6": https://paste.debian.net/1198577/
*apteryx zzzz
<apteryx>basically I'm after an equivalent to Python's 'import pdb; pdb.set_trace()' one liner.
<tohoyn>I'm compiling a large guile program with 3.0.7 and I get the following error: mmap(PROT_NONE) failed
<tohoyn>the compilation has worked with older versions of guile
<tohoyn>compilation with command "guild-3.0 compile -o tmp.go target-1.scm"
<tohoyn>I think this is a compiler bug
<tohoyn>Is it possible to attach large files into a bug report?
<wingo>tohoyn: i think that bug is libgc 8.x -- https://github.com/ivmai/bdwgc/issues/353
<sneek>Welcome back wingo, you have 1 message!
<sneek>wingo, dsmith-work says: What's the difference betwen an OPn and a DOPn ?
<wingo>sneek: later tell dsmith-work same encoding, only that by convention the DOP writes to its first operand
<sneek>Got it.
<tohoyn>wingo: does that mean that there was not enough memory to compile the file?
<wingo>sneek: later tell civodul that shepherd bug looks interesting :) surely a problem with 8b994be59fc4d9d23d8fad546deca3dbb2d29df7 somehow
<sneek>Will do.
<tohoyn>wingo: Compilation of the file with guile 3.0.5 worked.
<wingo>tohoyn: that's possible. the question is, are you using libgc 8.x or 7.x
<wingo>there are other differences between 3.0.5 and 3.0.7 that can affect when and how gc runs
<tohoyn>wingo: version of package libgc-dev is 1:8.0.4-3
<wingo>i think then that you are running into the aforementioned bug
<wingo>guile itself does not mmap(PROT_NONE)
<wingo>fyi compiling at -O1 uses less memory. could be a way to get around this issue in the short term, if you need something that will just let you move forward
<tohoyn>wingo: -O1 as an argument for guild?
<wingo>yeah guild compile foo.scm -o foo.go -O1
<tohoyn>wingo: tx
<apteryx>any idea in which situation reading from a port (SSH connection) would return a <eof> object? unexpectedly? Could this signal the connection was lost?
<wingo>certainly. or shutdown on remote side. see shutdown(2)
<apteryx>OK! So I'm trying to add the ability to retry a connection in case it dies and resume normal operation; the code flow is currently something like this: create all connections, check they are alive, do X with connections, batch processing them. The problem is that at the time we batch process them, they might have died. I've modified the code to raise an exception in this case, and I could use a
<apteryx>brute-force retry mechanism that redoes all the things mentioned earlier from zero for a finite number of retries. Going further, is there a pattern/building block I should look into to make this more granular (at the level of an individual connection)? The current code looks like:
<apteryx> https://git.savannah.gnu.org/cgit/guix.git/tree/guix/scripts/offload.scm?id=2b76179ecd951172288f5f6f78402d9304d2da41#n646.
<apteryx>phew, sorry for the wall of text
***taw10_ is now known as taw10
***b4283__ is now known as b4283
<dsmith-work>Morning Greetings, Guilers
<sneek>Welcome back dsmith-work, you have 1 message!
<sneek>dsmith-work, wingo says: same encoding, only that by convention the DOP writes to its first operand
<dsmith-work>D for Destroys Destination with Data from the Doing
<manumanumanu>Ahoy!
<manumanumanu>I had a small discussion with Zelphir about some old threading macros I wrote a long time ago. I told him that I advice against using them now that SRFI-197 exists. Would there be any interesti of having srfi-197 in guile?
<manumanumanu>not for, but in. I can take it upon myself to implement it and rewrite the SRFI document as texinfo.
<rlb>manumanumanu: I suspect I might well like them.
<rlb>fwiw
<manumanumanu>it is one of those often asked-for things, and there are a billion implementations of them. My old ones are fine, full-featured and portable - but ultimately not something I think anybody should use now that there is a standard alternative.
<manumanumanu>srfi-197 is a superset of most implementations, with good handling of multiple values to that
***Server sets mode: +ntz
***KindOne_ is now known as KindOne
<jackhill>Recommendations on a good way to answer this question in guile: "have I seen this object before?" I'm thinking a set library may be useful. Thoughts?
<RhodiumToad>hashtable, possibly weak?
<jackhill>sounds reasonble. Do you know if there is an implentation already available for Guile?
<RhodiumToad>make-hash-table, hashq-ref, etc. are built in
*jackhill check the reference manual again.
<RhodiumToad>make-weak-key-hash-table if you want a weak one
<jackhill>Ah yes, thanks