IRC channel logs

2021-04-12.log

back to list of logs

<dsmith>!uptime
<sneek>up 1 day, 5 hours, 17 minutes
<everstone>How do I evaluate escapes? I have (string-append "\\x" %hex-string)
<rlb>wingo: is it feasible/sensible to replace C functions (say in srfi-13) with scheme functions, and/or how would that work? Some of them in my experiment, like string-tabulate, might be just about as efficient in scheme, but if so, would I put them in srfi-13.scm, or would they have to go in boot-9.scm or...?
<rlb>(Hmm, or maybe that's a bad example, maybe I can make it faster in C (we'll see).)
<wingo>rlb: yes it is certainly feasible and desirable!!
<wingo>decreasing the amount of C is a high priority goal imo, so that rewriting the GC is easier
<lemzwerg>[I'm new to freenode – not sure whether my previous message came through, thus repeating.] On the homepage of guile there is a list of applications that use guile. I suggest to add GNU LilyPond.
<wingo>hi! i think lilypond is there at https://www.gnu.org/software/guile/libraries/#apps, can you check ?
<lemzwerg>It is, thanks.  Then I suggest that you add a small line at the bottom of the 'Applications using Guile' section that  links to this list.
<lemzwerg>Of course, LilyPond is *not* a library, so the title of the link is misleading.
<g0d_shatter>hey all, curious if anyone knows what the status of guile-ncurses is? last release was a couple of years ago, does it work with guile-3 yet? or even worth using?
<lemzwerg>Regarding the https://www.gnu.org/software/guile/libraries/#apps link: The '#apps' tag doesn't exist.
<wingo>lemzwerg: if you send a mail to bug-guile@gnu.org with a description of the bug, that will make a ticket in our tracker
<wingo>which will be dealt with eventually. not always timely on these things but at least it will get done
<lemzwerg>@wingo: Done!
<wingo>tx :-)
<wingo>janneke: hey. can you remind me what the mingw64 status is
<janneke>wingo: i believe spk121 reviewed my wip-mingw branch and found all commits except two OK (please verify!)
<janneke>those two were the 64bit mingw and the fix for the absolute-file-name cross-compilation bug
<janneke>last thing i know was spk121 did an experiment to introduce a hash type and he said something like "i learned a lot" ...
<wingo>hehe
<janneke>so, i forgot whether it's a viable path and needs more, or not...
<wingo>janneke: just reviewed the first 9 patches on gitlab. the ones without comments lgtm
<wingo>(i hope the branch was up to date!)
<janneke>wingo: it is, thanks!
<janneke>so, feel free to push, but possibly align with spk121?
<wingo>feel free to push any of the first 9 patches that have no comments :)
<wingo>comments on the gitlab i mean
<janneke>eh wait, do i have push access?
*wingo checks sv
<wingo>you do now :) plz do ping on irc before pushing patches
<wingo>janneke: also feel free to use wip branches in the main repo
<janneke>wingo: that's great, sure; so OK to push up to the first DRAFT commit, right?
<wingo>janneke: there are comments on a number of those commits, right?
<janneke>ah, right -- now i git what you wrote -- any that have no comment
<wingo>:)
*janneke goes to push 7 commits to master, and create a new wip-mingw
<wingo>janneke: there are only 3 that don't have comments, right?
<janneke>oh my, /me goes to re-check
*janneke push a re-sorted wip-mingw
<janneke>*pushed
<janneke>wingo: hmm...on the new wip-mingw, there are no comments on the commits below
<janneke>f1d2460252 Add `scm_sigaction_for_thread' stub for MinGW. ?
*janneke breaks for lunch and will wait for full alignment here ;)
<wingo>you don't see one on https://gitlab.com/janneke/guile/-/commit/34cbe4eedcbab317b3fbbf127493e1b82a64ee9a ?
<wingo>if your commits get renumbered because of a rebase or whatever, you will lose gitlab comments; if you want persistent comments, make a PR
<janneke>wingo: ah, comments on gitlab! right...i didn't see those, sorry -- never worked with gitlab comments
*janneke was thinking/guessing: a remark in the commit message before the actual change log
<janneke>wingo: check, 3 commits "Document write-line.", "ice-9 ftw: Use 'absolute-file-name?' in 'nftw'.", and "Compile fix for x86_64-MinGW." ready to push
<janneke>i'll look into your remarks (thanks!) to push the other commits forward
<wingo>great! & tx for patches :-)
<wingo>perhaps you can hoodwink lloda into doing a gnulib update at the same revision, but adding the gethostname module :)
<janneke>yw, and thanks for the hand-holding :-)
<janneke>ah great -- i'll be checking if gethostname import fixes it
<apteryx>Any idea of how we can use parameterize as part as a syntax-case? This naive try doesn't have an effect: https://paste.debian.net/1193328/
<apteryx>as part of*
<wingo>you want syntax parameters
<wingo> https://www.gnu.org/software/guile/manual/html_node/Syntax-Parameters.html
<apteryx>hey, thanks! I'll try it.
<dsmith-work>Hey Hi Howdy, Guilers
<apteryx>wingo: I tried, but I'm getting a syntax error (the same I had when trying with plain parameters, so probably unrelated): https://paste.debian.net/1193356/.
<wingo>perplexing
<apteryx>a more minimal example: https://paste.debian.net/1193363/
<apteryx>I don't get what it doesn't like about the body, which *is* an expression, AFAICT.
<wingo>is it an expression? looks like a definition
<wingo>depends on the result of the expansion of define-configuration
<wingo>anyway, i think that is probably a bug in the expander.
<wingo>your code looked good to me fwiw. if you wanted to hack around it you could (syntax-parameterize ((...)) my-thing #t)
<wingo>though i wonder if it would treat those as local definitions... humm
<apteryx>the define-configuration called without the 'without-serialization item should expand to a (begin ...) that does a bunch of definitions
<apteryx>I'll try your suggestion, thank you :-)
<apteryx>it seems to get me passed this block!
<apteryx>although the syntax-parameterized %with-serialization value doesn't seem to stick in the final syntax; https://paste.debian.net/1193369/; It still generates serializer fields set to some (inexistant) procedure names.
<apteryx>anyway, I'll strip that 'without-serialization syntax sugar for now; it can at least work when using teh global plain parameter and a single case in define-configuration. Thanks for your help!
<apteryx>it works as long as its used as a global variable more than a parameter
***DadeBonetti1 is now known as DadeBonetti
***jorts is now known as nckx
***cbaines_ is now known as cbaines
***mood_ is now known as mood