IRC channel logs

2021-03-13.log

back to list of logs

<stis>hello guilers!
<tohoyn>stis: hej
<allan[m]>stis: hello!
<spk121>I wonder if anyone ever uses Guile on Cygwin? I'm expecting Cygwin to die off because of WSL, even though it is still actively maintained for now
<spk121>It is telling that there a like a half-dozen different ways to deal with how non-POSIX windows is, and how each one has its adherents. A maintenance nightmare
<rlb>Is the comment above SCM_MAKE_CHAR in chars.h really just noting the behavior for negative values? i.e. latin-1 is a subset of unicode?
<spk121>rlb: it is trying to handle casting signed char, unsigned char, and uint32_t into codepoint values
<rlb>right - just wanted to make sure that the "latin-1" bit wasn't particularly relevant.
<rlb>i.e. every latin-1 code point value is the same utf-32 code point value
<rlb>so it's mostly just worried about < 0, I think?
<spk121>true
<rlb>And thanks.
<rlb>wingo: yes, wrt utf8 and say pcre, though the main issue there is actually latin-1, not utf-32, fwiw, i.e. pcre doesn't do latin-1, only unicode or raw bytes iirc.
<rlb>i.e. it only does bytes and utf-{8,16,32}
<rlb>so latin-1 is expensive
<rlb>(also have to compile matchers per-encoding, so having a single encoding is more efficient and easier)
<lispmacs>hi, my Guile skills are a bit rusty. When I am in the interpreter, how do I load in a file from the cwd?
<mdevos>lispmacs: (load "stuff.scm")
<mdevos>or (include "stuff.scm") (semantics are somewhat different)
<lispmacs>thx
<Noisytoot>mdevos: What are the differences?