IRC channel logs

2021-03-10.log

back to list of logs

***heroux_ is now known as heroux
<lispmacs>hi, I'm trying to relearn how to use cooperative repl servers (in 3.0.5) after a year or two away. Something I'm trying to figure out: if I don't connect to the coop-repl-server, and just exit my application, the port is left bound for a while at least.
<lispmacs>but it isn't obvious to me from the documentation how to properly close a coop-repl-server without connecting to it and running (exit)
<lispmacs>My system: https://bpa.st/XUPA
<lispmacs>does David Thompson still haunt this channel?
<lispmacs>had a Chickadee question. Probably in bed
<ArneBab>wingo: ah! Nice :-)
<terpri_>sneek, seen davexunit
<sneek>I last saw davexunit in #guix 7 days ago, saying: figured it out but boy is the solution ugly.
<terpri_>lispmacs, ^
***apteryx is now known as Guest97284
***apteryx_ is now known as apteryx
<ArneBab>manumanumanu: would it help you to get write access to https://hg.sr.ht/~arnebab/wispwot/ ?
<dsmith-work>lispmacs: Could be becuse of not using SO_REUSE* socket option
<dsmith-work>?
***janneke_ is now known as janneke
<lispmacs>dsmith-work: okay, I'll look into that, thanks
<roptat>is there a way to prevent regexps from reading the whole string after the first match?
<pkill9>roptat: look up lazy vs greedy regex, might be what you're looking ofr
<pkill9>for*
<roptat>I mean, (string-match "a+" (string-append "aa" (make-string 500000000 #\b))) should return the first "aa", and I don't care if there are matches after that
<roptat>(the regexp is taking a few seconds to match that)
<roptat>(not counting the time it takes to create the string)
<roptat>to explain, I'm trying to write a lexer, and I use regexps as a simple way to express what it should match. But with big source codes, I have to run regexps multiple times on big strings, which makes it very slow
<taw10>roptat: You mean you want the first substring? Wrap your expression in (match:substring ..... 0) and it does what you want
<roptat>(define s (string-append "aa" (make-string 500000000 #\b))) (match:substring (string-match "a+?" s)) is slow, how to make it fast? :D
<taw10>(tip: reduce the number 500000000 for testing :)
<roptat>below that number it's hard to see it's slow
<roptat>my code works well on small files, but it's just taking ages on bigger files
<taw10>Ah, then I misunderstood the question. Afraid I don't have any suggestion of how to make it faster, except perhaps not using a regex matcher
<roptat>so, I think it's trying to get every possible matches in the string, and not only the first one, so it goes through all the bs. for what I want, executing the regex would just go through the as, fail at the first b and return the match
<roptat>no reading an absurd amount of garbage :)
<roptat>so should I just come up with my own implementation of regexps for that?
<dsmith-work>roptat: You probably want to write your own lexer instead.
<wingo>spk121: the posix-w32.h patch described in recent commit wasn't part of the changeset, fyi
*wingo added mkstemp, finally
***edcragg7 is now known as edcragg
***hunzelstrunz_ is now known as hunzelstrunz
<spk121>hmm
<spk121>oh, since I was pulling in from different PC's that commit was already included from fedb65b98. I could 'force' the commit to remove that, if you want, or just let it go
<wingo>nah, all fine
<wingo>just fyi in case you forgot to add something that you wanted to add
*wingo grumbles at gnu copyright assignment procedure
<civodul>wingo: i reported the -Wunbound-variable issue at https://issues.guix.gnu.org/47031 but haven't yet taken the time to investigate
***taw10_ is now known as taw10
<manumanumanu>daviid: I don't have a mouse, and haven't set up my computer for mousle-less navigation, what is the expansion of the macro?
<manumanumanu>of the bug
<manumanumanu>the big unanswered question is "what is the use-list of a module?". Why did module-use! re-export the bindings in 2.2 but not in 3. The expansion is not the problem.
<manumanumanu>now good night again
<ArneBab>First result from the Lilypond folks testing Guile 3.0.6: The error about the missing gperf command comes during make instead of during ./configure. Could someone check whether the check for gperf is missing from configure.ac?
<daviid>manumanumanu: forget bout the macro, the macro is fine :) - it is there only to allow users not to have to quote each module name(s) ... the problem is deep downin the module system (the changes that has(ve) been made in 3.0, and/or the compiler, which breaks module-use!
<daviid>ArneBab: tell them when build from source, they need ti install gperf
<daviid>the gperf and/or gperf-dev module i don't remember
<ArneBab>They already found that and are retrying. The point is just that the error should be thrown during configure, not during make.
<daviid>no, because the cinfigure from the tarball works fine ...
<daviid>works fine without gperf
<ArneBab>can we do that check during autoreconf?
<daviid>manumanumanu: let me paste a smaller example
<daviid>ArneBab: you'd have to talk to our maintainers, who are aware of this, it's been reported here a couple of times already ... but i don't think it is important enough that they will do something about this 'now' - maybe they'd accept an autoreconf (bootstrap/autogen.sh) patch though, i don't know - but i'd rather have them solve the module-use! bug, which imo is a regression, and/or any other bug(s), 'spurious warnings' ... then work on
<daviid>'this' minor problem, not even a bug ...
<daviid>manumanumanu: here https://paste.debian.net/1188771/
<daviid>wingo: here is a much 'better' snipset/report for bug#43025 - https://paste.debian.net/1188771/
<daviid>in the above, the define map-a is totally useless, and does not even use the srfi-1 map 'extension', just there to have a define in (a) - the important thing is module-use! is 'broken' in 3.0