IRC channel logs

2020-12-16.log

back to list of logs

<daviid>fnstudio: fwiw, the best list of guile (none core) libraries and apps is here http://sph.mn/foreign/guile-software.html
<daviid>fnstudio if par-map and friends do not fulfill your needs you may look at 8sync, fibers and guile-a-sync (which is for guile 2.0, bu but the author page, you'll find versions for 2.2 and 3.0 as well, guile-a-sync2 and guile-a-sync3)
<dsmith>sneek: botsnack
<sneek>:)
<dsmith>goodbot
<fnstudio>daviid: thanks, great tip re the sph.mn page
<fnstudio>plenty of interesting links and things to explore
<str1ngs>daviid: forgive the late reply. I probably only use it with things like key-press-event. I think that is an interface?
<daviid>fnstudio: welcome!
<str1ngs>daviid: I would say I use the accessors like (!state event) and (!type event)
<str1ngs>
<daviid>str1ngs: np! ok, the thing is :) I need work on g-golf to make it transparently support gdk3/gtk3 or gdk4/gsk4/gtk4 and things radically changed in the way users manage events - the GdkEvent struct hasn't changed much, but everything above that changed radically
<str1ngs>daviid: understandable. I know things have changed with key events with GTK4 but I have not had time to look at it myself.
<daviid>str1ngs: these accessors, I added to g-golf to offer some 'sort of' compatibility with guile-gnome, and that some requires some C code, and I am gona have to change that (the C part, the accessors, I think I can manage to still offer them, although in gtk4, likely users won't use them anymore ... we'll see)
<str1ngs>daviid: okay, I have not been able to work on nomad at all. I was able to get g-golf updated in guix to 0.1.0-839.ef83010. but my farther is ill and I'm more focues on that right now.
<str1ngs>father*
<daviid>str1ngs: oh, I am sorry to hear that, I understand of course, np
<daviid>str1ngs: just to complete the conversation, there are two accessors that depends on C code, ahich are !changed-mask and !new-window-state - these do not exist in gdk4 anymore and since you are my 'only' user, together with tohpoyn, I want to get rid of the C code
<str1ngs>daviid: if I don't respond via IRC you can use mike.rosset@gmail.com just encase. I will try to work on things early next year probably.
<str1ngs>daviid: as far as I know I dont use those accessors and if I do I can work around it. so it's safe to break API
<str1ngs>well don't worry about braking nomad I mean.
<daviid>str1ngs: ok, i actually don't need you to 'work' - i did assume you were not using those, nor tohoyn - so reallt no big deal - I'll meke these important changes and will inform you, but on your side, it should ask for any change, just test my work by, as usual, run the pull/make/check dans
<str1ngs>daviid: no worries, by work I meant on nomad and indirectly using g-golf.
<fnstudio>i was trying to regex-match "test[012]" expressions, while capturing the number 012 in a regex group
<fnstudio>the matching plus grouping would imply enclosing square and normal parantheses though
<fnstudio>and that seems not to be very easy with POSIX regex, if i understand it correctly?
<fnstudio>normally i'd do something along the lines of `test\[([0-9]+)\]`
<fnstudio>(i guess...)
***sneek_ is now known as sneek
<spk121>.
<srandon111>spk121, ..-..
<tohoyn>sneek: botsnack
<sneek>:)
***apteryx is now known as Guest53337
***apteryx_ is now known as apteryx
<tohoyn>I'm planning to publish some source code in the internet. What platform do you suggest? SourceForge? Gitlab?
<spk121>github is most popular but free software people avoid it. gitlab seems to be the most popular for free software people. sourceforge has a reputation of being obsolete, but, actually it is getting fixed up.
<leoprikler>If you want to go full GNU, you can also use Savannah ;)
<dsmith>Also bitbucket and sr.ht.
<dsmith>sourceforge was *it* back in the day. Feels very spammy now.
<tohoyn>is there some wrong with sourceforge as some people don't like it?
<tohoyn>s/some/something/
<leoprikler>I'd start from the top with the layout.
<leoprikler>Getting to a usable download on Sourceforge always feels like a slog.
<fnstudio>hi! any built-in procedure to convert an integer to a different base? eg base-2 -> base-16
<fnstudio>found it, i think, eg some variation of `(number->string (string->number num 10) 2))` should do it
<chrislck>sneek: botsnack
<sneek>:)
<leoprikler>fnstudio: that's assuming your "number" is a string in its input, but yeah
<fnstudio>leoprikler: cool, thanks!
<dsmith-work>Wednesday Greetings, Guilers
<justin_smith>leoprikler: that's a given, since numbers don't have bases per se, but string representations do
<manumanumanu>tohoyn: Sourceforge has been trying to clear their reputation for some time now. They were doing some hinky stuff about 5-10 years ago
<manumanumanu>I do believe they are OK now. I myself pay for sr.ht and am happy.
<manumanumanu>Ladies and gentlemen, I believe I might be finally entering beta of goof-loop! That concludes my hacking for tonight, if you are interested go check out https://git.sr.ht/~bjoli/goof-loop
<manumanumanu>good night!
<remby>I'm working with guile for aoc, but I noticed that if will "die" if the program runs out of resources https://termbin.com/0ozy
<remby>as it seems I can't have both of those nested loops run togethor
<remby>oh oops I called exit! :P
<dsmith-work>That'll do it