IRC channel logs

2020-12-06.log

back to list of logs

<leoprikler>Is it expected, that s32vector-ref does not work on array slices, but array-cell-ref works on s32vectors?
<leoprikler>[array slices of the kind #1s32]
<RhodiumToad>array functions are supposed to work on anything array-like
<sneek>Welcome back RhodiumToad, you have 2 messages!
<sneek>RhodiumToad, mwette says: That looks nice. Clever job!
<sneek>RhodiumToad, mwette says: I need a fold also: (cartesian-fold proc 1 '(a b c) '(d e f) '(g h i)) -- I will take a shot but you might get it faster.
<RhodiumToad>and an array slice is not an s32vector even if it was sliced from one
<RhodiumToad>so yes, it is expected
<leoprikler>ahh, I need array-contents?
<daviid>sneek: later tell tohoyn I asked on #debian-next and they say you should ask on #debian-mentors
<sneek>Will do.
<daviid>sneek: later tell tohoyn they also suggested the test, in the debian packaging, be patched so it is run under xvfb-run, adding a test to check and depend on xvfb ...
<sneek>Okay.
<ces>How do i seed random? I use random in a loop but it seems to be deterministic...
<RhodiumToad>(random-state-from-platform) to get an arbitrary seed from platform-dependent entropy sources
<RhodiumToad>e.g. (set! *random-state* (random-state-from-platform))
<RhodiumToad>(to set the default seed)
<dsmith>Hey
<dsmith> https://ane.github.io/2020/10/05/between-two-lisps.html
<ces>RhodiumToad: Thanks!
<davexunit>dsmith: just saw this elsewhere. says some pretty nice things about guile.
<dsmith>yep
<RhodiumToad> https://dpaste.org/MqgX <-- cartesian-fold and cartesian-apply
<RhodiumToad>mwette: ^^
<RhodiumToad>sneek, later tell mwette https://dpaste.org/MqgX <-- cartesian-fold and cartesian-apply
<sneek>Okay.
<mwette>RhodiumToad: thanks!
<sneek>Welcome back mwette, you have 1 message!
<sneek>mwette, RhodiumToad says: https://dpaste.org/MqgX <-- cartesian-fold and cartesian-apply
<RhodiumToad>one open question is the order in which you want the fold to work
<RhodiumToad>right now, the first argument list is the one that varies fastest, i.e. '(1 2) '(a b) visits 1a, 2a, 1b, 2b in that order
<RhodiumToad>this is a consequence of a double-reverse in the building of the nested loops and the argument lists
<mwette>For me, there is no requirement on the order.
<RhodiumToad>ok.
<RhodiumToad>I put the accumulator argument to the fold procedure at the end, i.e. it's (proc blah blah ... accum) because that's how (fold) does it, but it might be neater to put it first
<RhodiumToad>otoh consistency is good
<mwette>I do like that order. I use fold a lot and expect to see it.
<tohoyn>sneek, botsnack
<sneek>Welcome back tohoyn, you have 3 messages!
<sneek>tohoyn, daviid says: I am afraid I can't help you, it is a debian 'package building environment' problem, which I know nothing about, but it appears that the building environment does not to have a X11/Wayland server available, hence gtk-init fails ... you should ask for help to 'debian', maybe #debian-next (irc.oftc.net), might help or suggest 'where' to ask ...
<sneek>tohoyn, daviid says: I asked on #debian-next and they say you should ask on #debian-mentors
<sneek>tohoyn, daviid says: they also suggested the test, in the debian packaging, be patched so it is run under xvfb-run, adding a test to check and depend on xvfb ...
<sneek>:)
***apteryx is now known as Guest63572
***apteryx_ is now known as apteryx
<tohoyn>I get lintian error "bad-distribution-in-changes-file unstable". Why is lintian complaining about unstable?
<tohoyn>I have Ubuntu on my computer.
<tohoyn>I build the package with debuild.
<tohoyn>sorry for wrong channel
<ane>the moment you wake up and your blog post about common lisp and guile is all over the internet
<RhodiumToad>heh
<spk121>That feeling when the initially simple task of building Guile on Windows has somehow lead to writing a GCC-like front end to to the CL compiler in c++.
<tohoyn>I get the following error when I try to build g-golf with sbuild: configure: error: found development files for Guile 2.2, but /usr/bin/guile has effective version 3.0
<tohoyn>I've got dependencies guile-2.2 and guile-2.2-dev in debian/control
<tohoyn>There is no direct dependency to guile 3.0
<tohoyn>I suppose that the m4 scripts for guile have a bug
<daviid>tohoyn: I think you have multiple guile installed, byt your distro, and although dependenciesseems satisfied, $(GUILE) point to /usr/bin/guile, and that is the 3.0 version, just a guess - this is a common problem with multiple installations, if the distro does not rename by postfixing guile with the version, and locale both guile and guild and any guile related script in $prefix//bin, the last installed win ... this has nothing to do
<daviid>with the guile.m4 macros
<mwette> The debian issue is that one of the tools -- guild-2.2 or guile-tools-2.2? -- is not included. I think it will be fixed in the future. I ended up generating a configure that works around it.
<tohoyn>why is guile 3.0 installed in the chroot environment at all? I don't have any dependency for it in debian/control.
<daviid>tohoyn: you shouls ask all these questions to #debian-mentors
<tohoyn>daviid: ok
<daviid>even #debian-next mentioned to me that they ask questions on #debian-mentors to ... if they say there is a bug in g-golf, then i'll trust them and fix it ...
<daviid>mwette: where is this configure.ac with the work around? tohoyn grab that, try it, and then tell the #debian-mentors about it, it will 'speeds things up' in fixing the problem i guess ...
<tohoyn>daviid: Is it ok to you if I make an ITP (Intention to Package) for the debianization of G-Golf?
<tohoyn>daviid: see https://wiki.debian.org/ITP
<daviid>tohoyn: yes, it is ok, but very likely will be rejected by debian rules, i see, among reasons to reject a packege, '... The software is very immature (version 0.1-alpha or something like that). ...'
<tohoyn>daviid: ok. I'll think about it.
<daviid>g-golf doesn't even have an alpha release yet :) - another reason is debian wants to get rid of guile-2.2l as I mentioned to you these last few days ...
<daviid>tohoyn: since you seem to be in such a 'hurry', probably because you want a 'presence' no matter what for your theme-D packages, here is what I would do if I were in your shoes: I'd package theme-D and theme-D-Golf for guix, then run guix pack to generate a 'self contained' bundle for each, then upload that on your site and recommand your users to grab those, until g-golf works with guile-3.0 and is(may be) in debian
<jkossen>this probably has to do with the newbie way i use to structure my code, but is there a less ugly way than (+ cnt 0) as a last statement to get the value of cnt as a return value from a function?
<manumanumanu>jkossen: just cnt is fine
<jkossen>manumanumanu: ah thanks! Never even considered using less parentheses :S
<chrislck_>jkossen: you can always fake it: (define return identity), and (return cnt)
***chrislck_ is now known as chrislck