IRC channel logs

2020-09-28.log

back to list of logs

***catonano_ is now known as catonano
***Guest77937 is now known as daviid
<daviid>str1ngs: I fixed the method specializers bug, but as you know, I don't wana push untill I complete the GInterface work ... so 'in the mean time', here is paste with a git format-patch [devel branch] - https://paste.debian.net/1164940/
<str1ngs>daviid: thank you, just to clarify this relates to the append-page method when passing #f?
***rekado_ is now known as rekado
<rekado>will the FFI helper also work for C++ code?
<rekado>I will need Guile bindings for https://github.com/zeroc-ice/ice
<ArneBab_>(define-syntax-rule (log-variable var) (format #t "~a: ~A\n" (quote var) var)) — just a useful shard of ice I just found :-)
<daviid>str1ngs: yes, that's the one
<iv-so>I have a problem with cross-compiling
<iv-so>does it make sense to ask about it here?
<str1ngs>daviid: great glad that's fixed. I can wait for that change with the GInterface work. also I found another issue but I believe GValue is not supported in the context of signal arguments yet?
<civodul>rekado: i guess nyacc has a full-blown C parser, which is already quite an achievement, but not a C++ parser :-)
<daviid>str1ngs: GValue generally need an override - but it dpends ... and so far, I only have overriden functions, afaict, no signals yet but ... I need a snipset/example/bug rep, what ever called ... spcially because i don't use and know webkit ...
<str1ngs>daviid: it's not related to webkit. its GSimpleAction 'activae single the signal signature is user_function (GSimpleAction *simple, GVariant *parameter, gpointer user_data)
<daviid>str1ngs: wrt webkit_web_view_get_tls_info, the last two args are 'out args, so you shouln't even pass them, therefore no initialization is required
<str1ngs>get-tls-info flat out seg faults
<str1ngs>also it takes one argument so I assumed g-golf creates the out arguments internally.
<str1ngs>I shouldn't assume but I tend to treat g-golf as a black box. since emacsy and nomad take up alot of time.
<daviid>str1ngs: yes, ok, i said this because you refered to initalization in the comment you made ... i need a code snipset to invstigate
<daviid>str1ngs: g-golf create the 'space for 'our ags' , so to speak ,...
<daviid>as other lang binding of course ...
<daviid>as for GSimpleAction ... again, a need a code snipset ...
<str1ngs>well I mean in the cause of get-tls-info it takes one argument then which would be a view. so create a view browse to a SSL site and that call the get-tls-info method with the view. that should produce a segfault
<daviid>i need a code snispt, sorry
<daviid>i don't use and don't know webkit
<str1ngs>I don't have a problem making snippets I have a problem when they get bike shed. so I mean that has to stop
<str1ngs>I can't waste time on snippets just to report a bug. and the discuss the merits of each snippet.
<daviid>i need a snipset based on the template i pasted, whe it is possible - no gtk-appk, no g-app-run ...
<str1ngs>well that's bike shedding and I don't have time for that sorry.
<str1ngs>also you have biased opinion of GtkApplication and I don't have time for that either. it's hard to conform got GTK best practices one minute. and then have someone tell you not to the next minute.
<daviid>unless you report a bug relatd to gtk-app/g-app-run, please use the template
<daviid>to much drama for nothing here
<rekado>ArneBab_: ever since I learned about it I always use (pk …)
<civodul>we could have testimonials at gnu.org/s/guile about pk
<rekado>civodul: I only know that writing bindings for C++ libraries is tricky; something about name mangling, perhaps? Will writing an extension still work for C++ things? Or is the answer that it depends…?
<str1ngs>daviid: the drama is produced by you. any valid snippet that produces the bug is valid. what you are asking for is snippets that conform to your debugging practices which have nothing to do with demonstrating the bug. This is unreasonable we spent 3 hours working on something and you had remove the relevant code that produced the bug because you are more concerned with how the snippet is layed out. no offense I don't have time for
<str1ngs>that.
<str1ngs>so my bug report is get-tls-info segfaults period in and snippet you want to use. no need for a snippet or drame.
<daviid>I need a code sniset, please use the template I provided to you (and any other g-golf users), thanks
<str1ngs>what snippet is require it segfaults when use. I don't even have to report this. I already have a fix in C. I'm letting you know for the betterment of g-golf and anyone else that wants to use g-golf.
<daviid>drama, drama .... pleas write and past a code snipset, using the template i rovidd, thanks
<daviid>going away from the kb, bbl
<str1ngs>you are deflecting. the drama is about snippets. and not actually fixing bugs. so no I don't need to create more snippets that you are not satisfied with despite them generating the bug being reported. it's not a good use of my time sorry.
<civodul>rekado: i guess you'd have to write those bindings in C++, using the libguile API
<civodul>or you could try to implement name mangling in Scheme and use the FFI, but that's risky and doesn't address issues like C++ exceptions
<wingo>what c++ project actually uses exceptions? :)
<civodul>heh, dunno, are exceptions no longer in fashion in C++?
<str1ngs>fashion always has exceptions :P
<lloda>my main use of C++ exceptions is to catch them in Guile, curiously
<wingo>dunno, i have been doing c++ since 2008, and no project i have worked on besides gdb uses exceptions
<dsmith>Now Python, on the other hand, is quite exceptional!
<wleslie>"don't use exceptions" sounds like good C++ wisdom, until you realise there's no other way to indicate error within a constructor
<mwette>The ffi helper does not work on C++. Maybe try swig. I'm guessing writing a parser for C++ is not easy.
<mwette>di
<ArneBab_>rekado: (begin (define foo 'fom)(pk foo)) gives ;;; (fom), but I want both foo and fom
<ArneBab_>rekado: the use-case is minimal print debugging: I just wont to see the variables with their values.
<dsmith-work>Monday Greetings, Guilers
<ArneBab_>rekado: (log-variable (list foo bar baz))
<RhodiumToad>should be easy to make it work for (log-variable foo bar baz)
<dsmith-work>So is that supposed to be logging a "variable" or an "expression" ?
*dsmith-work likes the idea of logging an expression better..
<RhodiumToad>I think it actually logs expressions just fine
<dsmith-work>Right. Just looking at the name: "log-variable". It's actually better than that.
<RhodiumToad>(define-syntax-rule (log-exprs exp ...) (begin (format #t "~a: ~A\n" (quote exp) exp) ...))
<ArneBab_>RhodiumToad: that looks nice! Thank you!
<ArneBab_>(define-syntax-rule (log-exprs exp ...) (begin (format #t "~a: ~S\n" (quote exp) exp) ...))
<ArneBab_>RhodiumToad: slight improvement: Use write for printing the argument instead of using display
<ArneBab_>(log-exprs foo bar (list "hello"))
<ArneBab_>foo: bar
<ArneBab_>bar: baz
<ArneBab_>(list hello): ("hello")
<ArneBab_>RhodiumToad: is it ok if I put that on my website? How can I acknowledge you?
<ArneBab_>RhodiumToad: do you have a website to which I can link?
<RhodiumToad>by all means put it on your website, no need to acknowledge me for something that small
<dsmith-work>"format" seems to have inherited ~% from lisp (CL?). I can imagine back in the '60s that starting a new line on an output device could be complicatd and differ greatly between systems. Most stuff today understands "\n" to mean newline.
<dsmith-work>Any real advantage in using "~%" ?
<spk121>dsmith-work: no real advantage on linux machines to using ~%
<RhodiumToad>gmake[3]: *** [Makefile:2279: language/brainfuck/compile-tree-il.go] Segmentation fault (core dumped)
<dsmith-work>Only thing I can think of is you can do ~10% for 10 newlines
<dsmith-work>Just wondering if there was something obvious I was missing.
<dsmith-work>RhodiumToad: Ouch. On a bsd? (the "gmake" indicates it)
<RhodiumToad>yeah, but it's a cross-build so it might be a qemu-user-static bug
<liltechdude>Hello
<liltechdude>What the best method to obtain web page body in guile?
<liltechdude>I`m try (use-modules (web client))(http-get "https://2ch.hk/pr/res/1800721.json")
<liltechdude>but this doesn`t work
<rekado>ArneBab_: I always just do (pk 'whatever-i-want the-variable); that shows me not the “the-variable” and its name, but “whatever-i-want”, which sometimes is more instructive than just the name.
<rekado>I also keep adding intermediate values to the pk expression
<rekado>as long as it ends on the right thing it doesn’t alter the behaviour
<ArneBab_>dsmith: maybe output on a mac or windows?
<ArneBab_>rekado: I sometimes did (pretty-print (cons 'name variable))
<ArneBab_>rekado: but the extra word was overhead for something I don’t usually need (since I often already know where I’m logging from)
<rekado>just tried to use https://gitlab.com/joolean/r6rs-protobuf to generate code from Mumble’s RPC protobuf declarations, but then (while looking through bug reports) found https://gitlab.com/weinholt/mummel
<rekado>no audio support, though
*rekado sees a herd of yaks, eyes scissors
<str1ngs>a *hurd* of yaks... get it! :P
*dsmith-work hands rekado an electric-yak-scissors, bound to C-x Y S