IRC channel logs

2020-09-21.log

back to list of logs

<Aurora_v_kosmose>The newest Hall is interesting.
<daviid>do we have or has anyone written a procedure I could reuse. to compute all combinatorial possibilities, given a list of items, where an item either is an atom or a list?
<daviid>for example
<daviid>(a b b) -> ((a b b))
<daviid>(a b (b c)) -> ((a b b) (a b c))
<daviid>and so on ..
<nalaginrut>,use (ice-9 control)
<nalaginrut>(define (either lst) (shift k (for-each k lst)))
<nalaginrut>(let ((a '(a b)) (b (either '(b c)))) (display `(,@a ,b)))
<nalaginrut>hmm...(define (either lst) (shift k (map k lst))) is better
<nalaginrut>then you don't have to `display'
<daviid>nalaginrut: great, let me try, tx
<daviid>nalaginrut: though you did change the input arg, in a way that i'd need to parse it to fill your 'either', and i'd rahter avoid to use shift ... isn't really any combinaytorial procedure available 'as is'?
<nalaginrut>daviid: I don't know if anyone wrote such thing. Out of topic, if folks all use guile-hall for packaging, it's easy for Guix, so we can collect the contribution easier
***apteryx is now known as Guest3271
***apteryx_ is now known as apteryx
<wingo>moo
<civodul>hey! :-)
<wingo>really nice blog post on compiler design: https://cfallin.org/blog/2020/09/18/cranelift-isel-1/
<civodul>Julian Seward, that name rings a bell :-)
<wingo>haha yeah
<wingo>among many other things, i think he focused on the register allocator there
<matijja>Hello Guilers!