IRC channel logs

2020-08-15.log

back to list of logs

<jgart>How hard will it be to port this library from chez to guile? https://github.com/paullucas/rsc3-chez/blob/master/rsc3.sls
<jgart>How unportable is it? I just wanted to get the opinion of any guiler that might be able to have a general idea from a quick glance at the procedures used in that file
<pkill9>does there exist a small library/tool that uses pandoc
<pkill9>i haven't used pandoc in a long time
<jgart>pkill9, guile bindings to pandoc?
***catonano_ is now known as catonano
<pkill9>jgart: I'm being too specific, basically I want to generate a CV into different formats from information stored as a scheme file
<pkill9>CV being curriculum vitae
<pkill9>i would like to use guile because I like it, lol
<pkill9>and i've been using it a lot recently
<pkill9>hmm, actually i could probably write the whole thing from the ground up, it would be pretty simple
<pkill9>since guile can generate code and text very nicely
<pkill9>probably doesn't need to deal with pandoc at all, just call it on the output probably
<jgart>pkill9, https://github.com/LeifAndersen/leifandersen.github.io/blob/4736f20ec85b67af3690e92ddd4d1271dd67e62b/cv/cv.scrbl
<jgart>pkill9, this is the guile remake: https://www.nongnu.org/skribilo/
<jgart>not sure what the latest status of development on skribilo is
<pkill9>i remember seeing skribilo a while back
<jgart>looks like the last update was this July 6
<jgart>git clone git://git.sv.gnu.org/skribilo.git
<pkill9>can it output to markdown? it doesn't list it on the site
<pkill9>having a CV scripted directly in a single file would be nice
<pkill9>looks like skribilo could be good for htat
<pkill9>it doesn't look like skribilo does a lot
<pkill9>in terms of producing documents
<pkill9>then again it's website is produced with skribilo
<jgart> i think it outputs latex and lout
<jgart>html
<jgart>pkill9, if you look in the engine directory you'll see all the things it outputs to there
<jgart>guile-commonmark can convert to and from sxml/markdown
<jgart> https://github.com/OrangeShark/guile-commonmark
<pkill9>skribilo seems good, i can use alists
<pkill9> mostly what my CV file is made of is lists and strings and booleans
<minerjoe>Hello all. How does one forget a function after it has been defined. I'm trying to change a define into a define-method. In CL I would UNINTERN, but I can't find the same in scheme.
<pkill9>how do you create and access an alist of alists?
<daviid>minerjoe: in these situation, we generally 'promote' the procedure so it becomes the default method of a generic function bearing this name - see ensure-generic in the manual
<minerjoe>daviid: thanks
<daviid>pkill9: you'd have to write your own
<pkill9>got it working
<pkill9>i needed to use dots
<pkill9>i don't understand why when i have '((a "b"))
<pkill9>i thought you only need dots for when "b" is actually a list
<daviid>pkill9: g-golf cache uses an alist of alists - http://git.savannah.gnu.org/cgit/g-golf.git/tree/g-golf/gi/cache.scm?h=devel
<daviid>pkill9: '((a "b")) is not an alist of alist(s) ...
<pkill9>oh that was a bad example
<pkill9>that was a reference to the sub-alist
<pkill9>which was returning ("b") instead of "b"
<pkill9>is it procrastination to convert my CV from yaml to guile? It's not even a technology job, just for minimum wage things
<daviid>minerjoe: welcome
<jgart>pkill9, no it's not procrastination. I'd do it.
<pkill9>cool, thanks for the validation :D
<pkill9>im getting an error with skrilo
<pkill9>skribilo*
<pkill9>create empty files /tmp/a and /tmp/b
<pkill9>then run `skribilo -p /tmp/a -p /tmp/b` and it raises an error
<pkill9>but it doesn't with `skribilo -p /tmp/a`
<pkill9>multiple preloads it seems to fail on
<pkill9>the error is In procedure string-prefix?: Wrong type argument in position 2 (expecting string): #:preloads
<pkill9>i can just use GUILE_LOAD_PATH anyways, no big deal
***wxie1 is now known as wxie
***wxie1 is now known as wxie
***catonano_ is now known as catonano
<str1ngs>hello janneke: in the process of starting working porting emacsy to guile 3 I found a small issue with one of the examples. I pushed a fix here https://git.savannah.nongnu.org/cgit/emacsy.git/commit/?h=wip&id=5bd0719129da21c83533cf5fd3ecfec31d8f3779. regards to guile 3 I'll push to a new branch for review before merging to wip.
<str1ngs>hello with guile 3 . I'm getting this Unbound variable: map it seems if you use a module that uses (srfi srfi-1) it's replacing the core map. I'm I reading this right? how I can are resolve. seems if I use (srfi srfi-1) in my module that will fix it but that seems wrong to me. alternatively I guess I need a delicate handler?
<str1ngs>duplicate*
<mwette>str1ngs: are you use-module'ing (srfi srfi-1) and don't want map?
<str1ngs>some cases I use (srfi srfi-1) but mostly it's in places where a module I'm using is using (srfi srfi-1) which then overrides the core binding for map and for-each.
<str1ngs>seems this helps some #:duplicates (merge-generics replace warn-override-core warn first)
<mwette>you are using goops?
<str1ngs>yes
<mwette>Ah. I don't use goops, don't know this territory.
<str1ngs>I'm porting a few project dependencies for nomad. the first one I'm working on is emacsy
<str1ngs>though in this case I'm not sure if this is goop's related.
<mwette>I'm guessing it could be if goops generics handler is taking over map.
<str1ngs>map seems to be a procedure so I can't see goops taking over that.
<str1ngs>(describe map)
<str1ngs>`map' is a procedure with 2 or more arguments.
<str1ngs>if it was a method it would describe them all
<pkill9>does anyone have an example of using skribilo to produce a markdown file?
<pkill9>actually there's some html -> markdown convertors onliune
<str1ngs>mwette: kinda figured it out. for non modules file I need to (default-duplicate-binding-handler
<str1ngs> '(replace warn-override-core warn first)) so the first binding is used.
<str1ngs>some of these are test files so they are not modules.
<mwette>thanks for the info
<pkill9>actually pandoc has a html->markdown converter
<str1ngs>mwette: though that's the default handler so technically it should work without that :(
<pkill9>is there a simple way to get data from an sxml tree that's structured like this: https://pastebin.com/raw/q21drL6X
<pkill9>i just want to store some metadata in that way
<pkill9>actually i don't think sxml is what i meant, i think i meant sexp
<pkill9>oh, assoc-ref works fine with it
<pkill9>i like guile, but i don't think i fully understand what i am actually doing
<pkill9>what's the best way to read until the end-of-file and return all the s expressions in a list?
<pkill9>oh i have an idea