IRC channel logs

2020-07-27.log

back to list of logs

<str1ngs>pkill9: the nomad package is really dated. I would git clone nomad. then do guix environment -L ./guix nomad. then ./configure and make run.
<str1ngs>pkill9: also you need a pretty recent guix pull.
<str1ngs>pkill9: git clone -b feature-g-golf https://git.savannah.gnu.org/git/nomad.git to be more precise. if you have cloned already switch to the feature-g-golf branch.
***jonsger1 is now known as jonsger
***catonano_ is now known as catonano
<winny>is there a guide to guile error handling? Something that discusses real world application?
<winny>this looks promising https://dustycloud.org/blog/guile-errors/ interested in more stuff =)
<mwette> thanks for that link
<daviid>pkill9: hey, that blog winny just referred to has a nice intro article on hash tables - fwiw, here https://dustycloud.org/blog/hash-tables-are-easy/
<sneek>daviid, you have 1 message!
<sneek>daviid, dsmith says: For concatenating images and other things like that, check out imagemagick
<winny>thanks =)
<daviid>str1ngs: wrt guix, the command civodul proposed // guix install g-golf --with-branch=g-golf=devel // would that grab/update/install the latest, like the eqiv of // git pull; make; make install // can seepel run that 'anytime' for example?
<winny>is there an easy way to determine if a scheme object has been garbage collected?
<RhodiumToad>from within a program? or for debugging?
<RhodiumToad>in programs, you can use the guardians mechanism
<winny>yeah, within a program that embeds guile,
<RhodiumToad>you're interested in when a scheme object that you create in C code gets collected?
<winny>yeah, trying to debug a crash related to http://git.savannah.gnu.org/cgit/xbindkeys.git/tree/keys.c#n458 -- it appears sometimes i get errors saying apply-smob/1 given the wrong type, sometimes it's a vector, sometimes it's a syntax transformer, sometimes it's a different error entirely, but i put in a check to see if the key->function is still passes scm_procedure_p() test, and in most cases it
<winny>fails when the program crashes
<winny>oh jeez
<winny>wish i checked the commit messages
<winny> http://git.savannah.gnu.org/cgit/xbindkeys.git/commit/keys.c?id=13b2af4b613c09983814aff53bfa51ead57fc0cd
<RhodiumToad>yes
<winny>so in future i should use guardians, but the description suggests it affects when objects are collected in addition to notifying the user?
<RhodiumToad>well for a case like this guardians are probably not the thing
<RhodiumToad>you want to reference a scheme object from a C structure, and release the reference to the scheme object when the C structure is explicitly freed?
<RhodiumToad>(if so, protect/unprotect is a reasonable strategy)
<winny>I am thinking from a debugging point of view -- realizing what was happening took awhile because I couldn't make sense of the backtrace, and there are quite a few threads online about seemingly bogus types not being callable or not compatible. Hence my seeking to interrogate the GC from a debugger/with tracing to ensure a pointer is still "live" from a debugging session
<RhodiumToad>from a debugging session, there's probably a good way to check when a given value gets freed, but I don't know offhand what it is
<RhodiumToad>I haven't worked with libgc much
<winny>i'll keep my eyes open, might have to simply do some codebase surfing
<akoppela>Hello folks
<akoppela>What would be the best place to search for Guile jobs?
<kori>akoppela: to be 110% honest i doubt you're going to find any
<kori>I might be wrong, though...
<str1ngs>daviid: yes it's pretty much the same. personally though I would use something more like guix environment --ad-hoc g-golf guile@2.2.7 gtk+ webkitgtk glib-networking . since with g-golf this more useful. though --with-branch tries to build too much when used with environment.
<str1ngs>or maybe I'm not using --with-branch properly.
***malaclyps2 is now known as malaclyps
***apteryx is now known as Guest93646
***apteryx_ is now known as apteryx
***sputny1 is now known as sputny
***ftknox_ is now known as ftknox
<dsmith-work>Morning Greetings, Guilers
<miskatonic>hi dsmith
<pkill9>i like waybar, but it's configuration system is horrible, it woudl be good to be able to configure it with guile
<chrislck>does guile development use continuous integration? what platform?
<chrislck>eg travis?
<dsmith-work>chrislck: The lightening back end does: https://gitlab.com/wingo/lightening/-/blob/master/.gitlab-ci.yml
<chrislck>ah nice
<dsmith-work>What are all those .x-sc_* files for?
<dsmith-work>(in the Guile sources)
<civodul>dsmith-work: it's for some sort of linter that Gnulib has
<civodul>"x" like "exclude": it specifies patterns of files to not be linted
<civodul>i don't even remember how to run that stuff
<dsmith-work>heh