IRC channel logs

2020-07-17.log

back to list of logs

<ArneBab>dsmith: no prob with that — my seeing is different: too many parens start merging everything together, so I have a harder time recognizing the procedure names. Though I do use inner parens to focus on some parts.
<ArneBab>But the key to wisp is that it‘s still scheme. If people use it, you can always add the parens and get the Scheme you know.
<ArneBab>More importantly: anything written in wisp is compatible to Scheme down to the lowest layer. Not just some option to call foreign code, but the same down to the performance model.
***nckx is now known as guix
***guix is now known as nckx
***terpri_ is now known as terpri
***wxie1 is now known as wxie
***wxie1 is now known as wxie
***apteryx is now known as Guest94585
***apteryx_ is now known as apteryx
***terpri__ is now known as terpri
<manumanumanu>How can I tell whether two syntax objects point to the same thing?
<manumanumanu>would that be free-identifier=?
<manumanumanu>ah yes.
<manumanumanu>The manual could really need an example...
***dongcarl7 is now known as dongcarl
<dsmith-work>Happy Friday, Guilers!!
<mwette>morning!
<chrislck>here's my latest gnucash creation, using cutting edge chartjs module \o/ https://github.com/Gnucash/gnucash/pull/759
<mwette>I now have a string-diff : (string-diff "abxef" "cabdef") => ((ins 0 1) (dup 0 2) (del 2 3) (ins 3 4) (dup 3 5))
<chrislck>ooh
<mwette> https://github.com/mwette/guile-contrib/blob/master/seqdiff.scm
<chrislck>mwette: are you working on DNA sequencing?
<manumanumanu>mwette: fun! I have been playing with adding an %app macro to guile, and it works alright :) Just for fun I added the feature of infinite cdadadddddadaaadddaddadar generation at compile time
<mwette>haha - no exactly
<manumanumanu> just itch scratching. Don't know why, but I just need to _make_ something
<manumanumanu>and that idea popped up
<mwette>I've actually run out before (IIRC guile has up to 5 op's)
<dsmith-work>chrislck: Wow. Nice
<manumanumanu>mwette: The only downside is you have to change the current reader, or wrap whatever code you are writing in the (%appify ...) macro. I thought about actually writing an extensible guile reader in guile so that we can have reader macros, but meh.
<manumanumanu>too complex
<manumanumanu>and not fun...
<dsmith-work>manumanumanu: civodul wrote some kind of extensible reader. Though I think it was in C.
<dsmith-work> https://www.nongnu.org/guile-reader/
<manumanumanu>yeah. I know. I am a sucker for pure scheme, though.
<davidl>mwette: can you explain what the string-diff does? I don't understand the result values "ins" "dup" "del" etc.
<justin_smith>davidl: looks like a calculated minimal set of edits https://en.wikipedia.org/wiki/Levenshtein_distance
<mwette>davidl: for (string-diff a b): (del i j) means delete chars i-j from a; (ins i j) means insert from b; (dup i j) means duplicate (or copy) from a
<davidl>ok cool stuff, Ive never heard of that before
<davidl>mwette: I don't follow the (del 2 3) part in the example above.
<mwette>davidl: operations to turn a into b, so (ins 0 1) from a="cabdef" => "c"; (dup 0 2) from a="abxef" => "ab"; (del 2 3) from b="abxef" => [delete "x"]; (ins 3 4) from b="cabdef" "d"; (dup 3 5) from a="abxef" => "ef"
<mwette>s/from a="cabdef"/from b="cabdef"/
<mwette>del and dup are ops on a, ins is op on b
<davidl>mwette: ok thanks! (if I read i to j as index i up to j - but not including j - it looks correct).
<mwette>it's consistent with (substring "cabdef" 0 1) => "c"
<wklew>possibly silly question, but how do i build guile-3.0-dev from guile source checkout?
<wklew>nevermind, I think it installed the dev filed and I was just having linkage issues
<wklew>s/filed/files
<dsmith-work>wklew: Like not running ldconfig?
<wklew>I believe that was it
<wklew>I'm now having issues building guile-reader (for haunt), it seems it can't find the GUILE_PKG macro
<manumanumanu>wklew: I don't think guile-reader is available for guile3
<manumanumanu>or?
<wklew>I thought so too, but I saw that cwebber's recent patch to the guix haunt pkg seems to use 3.0 for everything
<wklew>issue 42326
<dsmith-work>Looks like guile 3 removed things like SCM_COL, SCM_LINUM that guile-reader uses. Not mentioned in NEWS!
<wklew>well I got everything working by building against GUILE_EFFECTIVE_VERSION=2.2
<wklew>a little disappointing
***jonsger1 is now known as jonsger