IRC channel logs

2020-06-09.log

back to list of logs

*mwette found a hidden gem in guile: system/vm/elf&dwarf. I'm working on a guile front end to my microcontroller cpu simulator and want to snag debug info out of my compiled elf files. I'm still trying to get address-lineno sync but making progress.
<anadon>I want to have stronger typing for a program I'm using, so I am using rnrs enums to represent a fair/biased coin, and a head/tails side. I'm using these values as keys in a hash table to look up probabilities of events like P(heads | biased coin). From a `(let coin_type ( make-enumeration `("fair" "biased")))` how do I access the specific symbols in `coin_type` to use as keys?
***oni_on_ion is now known as oni-on-ion
<xelxebar>anadon: I'm not all that proficient in guile, but I think you may be using make-enumeration incorrectly
<xelxebar>(enum-set-member? 'foo (make-enumeration '(foo bar))) should return true.
<xelxebar>The set members are symbols, not strings.
<xelxebar>Is there a particular method that doesn't fit your needs? https://www.gnu.org/software/guile/docs/master/guile.html/rnrs-enums.html
***wxie1 is now known as wxie
<tohoyn>sneek, botsnack
<sneek>tohoyn, you have 4 messages!
<sneek>tohoyn, daviid says: g-golf introspection data is perfectly correct :), as a matter of fact, procedures that override any typelib function _do_ use the imported version and the cache holds on scheme representation of GI 'objects'
<sneek>tohoyn, daviid says: as said earlier, you are not supposed to use/depend on g-golf internals anyway, thay may change anytime, you do this 'at your own risks', which is ok, but g-golf does not bear any obligation wrt. now, if you do, you'll have to adapt ... this said, what we are talkg about now is _not_ a change in g-golf internal representation but the adition of an override mechanism ...
<sneek>tohoyn, daviid says: so, it appears to me that you need to think and implement your own theme-d override mechanism ... fwiw, overriden functions are listed in %gi-override, (g-golf override override) module
<sneek>tohoyn, daviid says: of course that list will evolve in time ...
<sneek>:)
<tohoyn>daviid: could you tell me where are the overridden procedures (xxx-ov) taking one argument invoked?
<wingo>moin
<civodul>hello!
<ArneBab>moin wingo
<RhodiumToad>moo
<dsmith-work>Hey Hi Howdy, Guilers