IRC channel logs

2020-05-24.log

back to list of logs

***sneek_ is now known as sneek
***sneek_ is now known as sneek
<str1ngs>daviid: it's to be working for me. but my znc server connects to gimpnet then I use circe from emacs to connect the znc server. so hard for me to test this for you.
***sneek_ is now known as sneek
***sneek_ is now known as sneek
***sneek_ is now known as sneek
***sneek_ is now known as sneek
***jonsger1 is now known as jonsger
<daviid>str1ngs: I can't connect to irc.gnome.org, but I can to irc.gimp.net, then join 'none #gimp' channels ...
***sneek_ is now known as sneek
<tohoyn>I have found two bug candidates in the reference implementation of SRFI-72. anybody who can discuss this?
<tohoyn>I'm unable to mail to the srfi-72 mailing list.
***wxie1 is now known as wxie
<gagbo>Is there a function that takes a list and a default value, and returns the default value if the list is empty ?
<gagbo>something like (if-let ((value (computation))) value default)
<gagbo>I don't know if if-let is in Guile, can't find it in the manual :(
<gagbo>that if-let is bad since it's missing the empty list check :(
<tohoyn>(define (fn l default) (if (null? l) default l)))
<rgherdt>Hi! I uploaded a while ago a simple patch for the "hash-table-merge!" function (it's currently broken), but only realised the naming convention of using [PATCH] in the title later. I'm not familiar with the way our Bug Report work, could someone please rename my bug report, or classify it as "patch available"? Would that happen automatically if I had used the [PATCH] convention?
<rgherdt> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=41131
<andswitch>(list-set! lst k val) modifies the pair in the list that contains the k-th element, but it doesn't modify the k-th element itself. Correct?
<RhodiumToad>yup
<andswitch>thx
<andswitch>ArneBab: I'm enjoying Wisp! In one or two cases I had to stare a bit to really grok how it reads something, but then it just clicked and now I feel like I'm flying.
***jonsger1 is now known as jonsger
<any1>Is there some way to close only the input end on a pipe from open-input-output-pipe?
<any1>I.e. I want to subprocess to exit so I can gather up everything from its output. Otherwise things just hang.
<RhodiumToad>no. but if you reach into the module and grab some private parts, you can convince it to give you the two pipes separately.
<RhodiumToad>someone asked that recently and gave a solution - let me see if I have it logged
<RhodiumToad>so the method given before was:
<RhodiumToad>(receive (from to pid) ((@@ (ice-9 popen) open-process) OPEN_BOTH "someprogram") ... )
<any1>I'll try that. Thanks!
<RhodiumToad>(substitute let-values or call-with-values to taste)
<mwette>maybe (close-port (fdes->inport (port->fdes port))) ??
<RhodiumToad>I don't think port->fdes would work on a bidirectional port? since that's actually a custom port with the real ports hidden in closures
<any1>I imagine that will close the port but maybe not the file descriptor.