IRC channel logs

2020-03-12.log

back to list of logs

<mwette>for guile-3.0.0, typing 'scheme@(guile-user)> ,L ecmascript', does anyone get 'Unbound variable: langauge-title' ?
<oni-on-ion>mwette, yep, i get that error./
<mwette>maybe system/repl/command.scm : #:autoload (system base language) (...) need language-title and language-name added
<mwette>3.0.1 seems to be working (running on installed system)
***apteryx_ is now known as apteryx
<RhodiumToad>redkahuna: to answer your question from yesterday, probably the two usages came about in different ways but just happened to use the same word
<RhodiumToad>a function with bindings for its free variables was called a "closed expression", shortened to "closure"
<RhodiumToad>whereas the other usage you mentioned comes from abstract algebra and topology
<rbarraud>RhodiumToad: Hiya
<RhodiumToad>hello
<rbarraud>I tried to look at Poudriere to retry pkg installs (once I learn how to actually make the pkgs :-) )
<rbarraud>but FreeBSD 12.1 spits the dummy with a checksum mismatch with poudriere pkg :-/
<rbarraud>Will try to look more in the next few days - long overdue to learn how to make pkg / port.
<rbarraud>Been using FreeBSD for around 4 years at this stage. mostly pretty happy with it.
<rbarraud>Wondering how many ppl have tried 3.0.1 on FreeBSD already?
<rbarraud>I'd be a bit surprised if I'm the first...?
<rbarraud>It's 1am here again so off to Zzzz again
<RhodiumToad>poudriere works fine for me
<rbarraud>Kewl
<rbarraud>at present? as in installing the pkg?
<RhodiumToad>which pkg?
<rbarraud>On 12.1?
<rbarraud>"sudo pkg install poudriere"
<RhodiumToad>what error did you get?
<RhodiumToad>(I actually build poudriere from ports initially)
<rbarraud>"[1/2] Fetching poudriere-3.3.3.txz: 100% 725 KiB 371.1kB/s 00:02
<rbarraud>pkg: cached package poudriere-3.3.3: size mismatch, fetching from remote
<rbarraud>[2/2] Fetching poudriere-3.3.3.txz: 100% 725 KiB 247.4kB/s 00:03
<rbarraud>pkg: cached package poudriere-3.3.3: size mismatch, cannot continue
<rbarraud>"
<rbarraud>Yeah I thought that might be the appropriate workaround
<RhodiumToad>weird, how big is the downloaded file, what arch are you on, and what repo?
<rbarraud>I struck another one with radare2 this evening too.
<RhodiumToad>and does pkg update help?
<rbarraud>FreeBSD latka.<REDACTED/> 12.1-RELEASE FreeBSD 12.1-RELEASE r354233 GENERIC amd64
<rbarraud>Nope
<rbarraud>:-/
<RhodiumToad>ls -l https://itsosticky.com/1434pi0-rwe4da-1slu9y9-2al02l-134gfpf
<RhodiumToad>oops
<RhodiumToad>ignore that
<RhodiumToad>ls -l /var/cache/pkg/poudriere-3.3.3*
<dsmith-work>UGT Greetings, Guilers
<RhodiumToad>good afternoon
<janneke>happy UGT, dsmith-work!
<rbarraud>RhodiumToad: no matches found: /var/cache/pkg/poudriere-3.3.3*
<RhodiumToad>try pkg fetch poudriere ?
<rbarraud>The problem seems to be with the fetched file ... not sure what it's comparing with ... some manifest file entry presumably - local or on the remote repo?
<rbarraud>Same result :-/
<rbarraud>(With the fetch vs install)
<RhodiumToad>try just doing fetch http://pkg.freebsd.org/FreeBSD:12:amd64/latest/All/poudriere-3.3.3.txz
<rbarraud>pkg: No packages matching 'http://pkg.freebsd.org/FreeBSD:12:amd64/latest/All/poudriere-3.3.3.txz' have been found in the repositories
<RhodiumToad>no, fetch, not pkg fetch
<RhodiumToad>literally just fetch http://pkg.freebsd.org/FreeBSD:12:amd64/latest/All/poudriere-3.3.3.txz
<chrislck>sneek: botsnack
<sneek>:)
<chrislck>yay
<rbarraud>RhodiumToad: Succeded, file is in cwd.
*sneek wags
<RhodiumToad>rbarraud: how big is it?
<rbarraud>So should I put it into /var/cache/pkg/ ?
<rbarraud>742300
<RhodiumToad>hm
<RhodiumToad>have you tried doing a pkg update -f ?
<rbarraud>Not with the -f lately, no...
<RhodiumToad>do it
<rbarraud>Yup ... that fixed it!
<rbarraud>Thanks :-)
<rbarraud>So what was scrambled, and how did it get scrambled?
<RhodiumToad>sounds like something up with the local copy of the repo manifest
<rbarraud>Yup
<RhodiumToad>update -f forces it to download the repo metadata again from the remote repo even if it's apparently up to date
<rbarraud>That also fixed the issue with the radare-cutter install.
<rbarraud>I would have thought there would havce been a checksum over the manifest that update or pkg install would have been checking as a matter of course.
<rbarraud>TIL... :-)
<rbarraud>Now I really should be in bed :-)
<rbarraud>Thanks :-)
<rbarraud>zzz
<rbarraud>PS: I guess this is the sort of thing that Guix aims to fix.
<rbarraud>zzzz
<RhodiumToad>I'm pretty sure there are checksums, but the data is stored locally in an sqlite db and it's not entirely unknown for that to be corrupted in various ways
<civodul>mwette: i like that quote of Steele that you posted to guile-user :-)
<gagbo_>quick question : if I'm creating a record-type in a module, I have to #:export all the accessors/constructor/predicate it has individually or is there a helper to just "export this record-type" ?
***gagbo_ is now known as gagbo
<gagbo>(Maybe duplicate because I disconnected apparently) quick question : if I'm creating a record-type in a module, I have to #:export all the accessors/constructor/predicate it has individually or is there a helper to just "export this record-type" ?
<gagbo>Bonus : How can I (map) a function on a vector ? Seems like I have a wrong type argument when I try so
<RhodiumToad>vector-map from srfi-43 ?
<RhodiumToad>also iirc the array functions work on vectors too
<gagbo>RhodiumToad: (vector-map string->symbol #("Hello" "World")) errors out while (map string->symbol '("Hello" "World")) works fine
<gagbo>I'll try the array one
<gagbo>(I was confused because I was searching the "concept index" instead of the "procedure index" ; I think that's why I didn't find out vector-map, but now I'm at the relevant part of the manual)
<RhodiumToad>gagbo: did you load srfi-43 ?
<RhodiumToad>ah, and vector-map passes the index as the first arg to the function
<RhodiumToad>(vector-map (lambda (i s) (string->symbol s)) #("Hello" "World"))
<gagbo>yeah just found that out, thanks for your time RhodiumToad
<gagbo>Oh, and for exporting a record from a module there's no trick right ? Have to #:export every accessor by hand ?
*RhodiumToad not an expert on modules
<gagbo>I'll export everything for now, it's not that important
<gagbo>It looks like there's a mismatch between doc and code : manual tells there's a define-immutable-record-type in srfi-9 https://www.gnu.org/software/guile/manual/html_node/SRFI_002d9-Records.html#index-define_002dimmutable_002drecord_002dtype but it looks like it's not there actually http://git.savannah.gnu.org/cgit/guile.git/tree/module/srfi/srfi-9.scm#n62