IRC channel logs

2020-02-23.log

back to list of logs

***kdr2 is now known as Guest88876
***wxie1 is now known as wxie
<ZombieChicken>Does Guile support UTF-8? Seems like there is some variation between scheme revisions and I'd like to know
<ZombieChicken>and I'm not finding anything specific on it when searching
<spk121>ZombieChicken: guile does support UTF-8. It can read and write files in UTF-8, and its characters are unicode codepoints
<ZombieChicken>thanks. I finally found references to that. Apparently my search-fu isn't strong enough
<spk121>Guile 1.8 and before were only 8-bit characters, and early guile 2.0 still had many unicode bugs
<ZombieChicken>well, I'm on 2.2.6. I'll assume things should Just Work then
<ZombieChicken>spk121: Is guile R5 or 6RS?
<spk121>guile 2.2 has all of R5 and a fair chunk of R6
<ZombieChicken>k, ty
***apteryx is now known as Guest30736
***apteryx_ is now known as apteryx
<gagbo>Hello, what do you use for unit testing usually ? Just a scheme file that errors on assertion failures ? I found ggspec on github, but it's really old and not packaged in guix so I assumed it's not used too much
<nly>hi gagbo, i use this: https://git.savannah.nongnu.org/cgit/emacsy.git/tree/test/check.scm
<nly>in my-project/testsuites/foo.scm:
<nly>(use-modules (check))
<nly>(check (foobar? baz) => #t) ;; check if (foobar? baz) = #t
<dftxbs3e>oh guile can run brainfuck
<erkin>Naturally. ;-P
<dftxbs3e>erkin, I've been looking at the ECMAScript code in GNU Guile, it's so small! Is it that simple to implement an ECMAScript interpreter?
<erkin>I don't see why not.
<erkin>There are quite a few minimal ES interpreters out there.
<dftxbs3e>I am curious to replace the Node.js crap with GNU Guile at some point, Quickjs was another hope
<erkin>They're all purely interpreted, mind you. Web browsers almost always JIT compile JS, which is a much harder task.
<dftxbs3e>GNU Guile also JIT compiles ECMAScript, correct?
<dftxbs3e>(indirectly through IL)
<civodul>dftxbs3e: it does, but the JS frontend in Guile is more of a toy currently
<dftxbs3e>Ah okay.
<dftxbs3e>Node.js's value is also its standard library
<civodul>also its compiler (v8)
<dftxbs3e>civodul, for sure, but at least that can be replaced without interfering with existing JavaScript code
<nly>great blog: https://guix.gnu.org/blog/2020/meet-guix-at-fosdem-2020/
<gagbo>nly: could you just "use-modules check" with the file in the current working directory ?
<nly>not without (add-to-load-path "/the/tests-path")
<gagbo>I see, thanks
<nly>gagbo: try (load "check.scm") in your-project/tests/foo.scm
<gagbo>it takes me a while to get going
<nly>gagbo: sorry to go back and forth:
<nly>(load "check.scm")
<nly>(use-modules (check)) ;; you're set now
<gagbo>nly: yay ! thanks a lot
<nly>:)
<nly>yw