IRC channel logs

2020-02-22.log

back to list of logs

<str1ngs>sneek later tell nly I fixed the window growth bug on completions. the echo area now wraps text. which means it now grows horizontally but that's easier to improve on later.
<sneek>Got it.
<daviid>str1ngs: just pushed a series of patches to fix the problem I had after rewritting gi-gflags->integer and gi-integer->gflags, so whe you have some time, please pull, run the make dance and check that your <gtk-application> based app gets its flags and run the appropriate signal callbacks ...
<str1ngs>daviid: great news will test with our example app right now.
<daviid>str1ngs: just wait one more min, i see one change is missing
<daviid>ok, you may pull now, sorry
<daviid>let's see how it works now
<str1ngs>I'll pull again so far though handles-open and can-override-app-id are working as expected
<str1ngs>you cant test with ./open & sleep 1; ./open foo
<str1ngs>I think though g-golf can't handle 'open arguments right? the signature looks like this. (define (open app g-files n-files hint))
<str1ngs>if can't handle g-files yet that's okay I just wanted to confirm if it should or not.
<daviid>str1ngs: what is the error
<daviid>i mean what is the g-files type
<str1ngs>g-files is a pointer. but is an array of GFile
<str1ngs>for reference https://developer.gnome.org/gio/stable/GApplication.html#GApplication-open
<daviid>ok
<str1ngs>I have a work around for this encase you have other priorities this is just a FY
<str1ngs>err FYI
<str1ngs>the output (dimfi app g-files n-files hint) ;; #<<gtk-application> 7f26b4c15020> #<pointer 0x94a740> 1
<daviid>where is the gfile type defined
<str1ngs>it's part of GIO IIRC
<str1ngs> https://developer.gnome.org/gio/stable/GFile.html
<str1ngs>could it be because it's an array?
<daviid>let me read
<daviid>there are quite a few type still missing in g-golf
<daviid>but gio is introspectable
<str1ngs>no worries.
<daviid>str1ngs: so, indeed is is a pointer, can't you use the gio procedures to use it?
<daviid>what is missing on the g-golf part?
<str1ngs>hmmm I'm not sure how I would iterator over a pointer. I would have though this would be a list of <gio-gfile> ? pseudo name used there
<str1ngs>actually probably it would be <gio-g-file> dunno
<str1ngs>only types I see for gio in the repl is <gio-module> <gio-stream>. but I used tab completion not introspection
<daviid>struct and boxed type would not show using tab copletion
<str1ngs>GFile does not have an iterator unless there is some generic glib iterator for this which is doubtfully. normally I would just for loop this array in C. I guess the scheme way would be for this to be a list of GFiles
<daviid>i can't find the definition f a GFile as g-gold sees it after i import Gio
<daviid>can you?
<str1ngs>find the defintion in g-golf you mean?
<daviid>str1ngs: when we import "Gio", it should import everything th Gio typelyb offers
<daviid>i can't find the definition of GFile after i imported Gio
<str1ngs>(g-file-new-for-path "./foo") works but returns nothing
<str1ngs>is there something like ,m but for namespaces? :)
<daviid>le me see the signature of g-file-new-for-path
<daviid>good idea
<daviid>ok, let me play with this
<daviid>i see type-desc = (interface g-file #f 94356499624864 #f)
<daviid>which is a good startm, but the two #f precisely to indicate the type is 'incomplete'
<daviid>which expected, i only implmented, and only patially, the types that are in glib and gobject
<str1ngs>okay that's good to know, I don't want to impact your current todo list here.
<str1ngs>for now I can just connect this signal in C and use a C callback to open the URI's use SCM functions. so not biggy
<str1ngs>the argv and argc and the handles-open removes a big chunk of C as it is
<daviid>what surprises me is there is no 'boxed 'g-file in the cache
<daviid>i'll talk to the #introspection friends see what they suggest
<str1ngs>sounds good, thanks for looking at the handles-open issue that resolve two things here.
<daviid>if it was a 'normal' struct opaque type, it would work already, g-golf would rturn a lis of pointers ... but for soe reason, it did not happen
<daviid>but i don't much about gio
<str1ngs>here's my callback now http://git.savannah.nongnu.org/cgit/nomad.git/tree/typelib/util.c?h=feature-windows#n67
<str1ngs>it's mainly used for when you click a link etc. it opens the URI in the current nomad
<str1ngs>specifically it creates a new <web-buffer>
<daviid>it's ok, i'll look into this asap
<str1ngs>great work, thanks for the help
<RhodiumToad>interesting, I see that GParamFlags actually exercises several edge cases
<RhodiumToad>it has a multiple-bit flag (readwrite . 3) representing the OR of (readable . 1) and (writable . 2)
<RhodiumToad>and it has non-contiguous bits, with explicit-notify and deprecated
<RhodiumToad>the corrected logic for gi-integer->gflags should comvert 3 to (readable writable readwrite)
<RhodiumToad>it should be safe to uncomment (private . 32) too if you need to
<daviid>hello RhodiumToad indeed, i was defining these 'mnually', now i got the values from their respective gir xml file
<daviid>RhodiumToad: wrt private, i did see it commented in other lang binding, but i never asked on #introspection why .. i'll do that
<RhodiumToad>well if it's usually commented then no reason to uncomment it
<RhodiumToad>you understand how the logic I gave you works in the case of overlapping or duplicate flag values?
<daviid>the thing is i don't know why :), it'd be nice to confir, i suspect just a renaming
<daviid>wrt readwite, not sure
<daviid>either
<daviid>but it would be no harm to return (readable writable readwrite) i guess
<RhodiumToad>ok. the integer->flags logic is: if the flag is defined as (foo . 0) then we include it in the output list only if the integer input is exactly 0,
<RhodiumToad>otherwise we include the flag in the output if all of the bits set in the flag definition are also set in the input
<RhodiumToad>thing is we don't necessarily know what the caller is testing for
<daviid>agreed
<RhodiumToad>so returning all the correct values is better than returning just some of them
<daviid>yep
<daviid>to answer your question '... overlapping or duplicate flag values', no, i just trusted you :)
<daviid>and some checks workd fine so, but it might be good to enhance the test-suite ..
<RhodiumToad>right. testing various combinations of GParamFlags would be a good test for the flags conversion funcs.
<daviid>yes, it would be nice
<daviid>the test-suite is not as structured as i would like it to be, another todo ... but we could easily enhance the flags tests
<daviid>these could be aded to the ./test-suite/tests/gobject.scm i guess
<daviid>what is there uses clutter-actor flags, because when i wrote the tests about this, i was working on GValues, (g-golf gobject params-vals), but didn't even have a (g-golf gobject param-spec) module yet ...
<daviid>RhodiumToad: in (tests support), i updated test-flag as this - http://paste.debian.net/1131513/ wdyt
<RhodiumToad>sneek, later tell daviid test looks ok to me
<sneek>Got it.
<gagbo>Hello, I have a beginner question again : I'm getting close to getting pipes the way I want them to work for async io, but I have a small issue with thunks in (with-output-to-port) : https://paste.centos.org/view/3e5c5e87
<gagbo>How can I get the (with-output-to-port .... ) call evaluate to (list from-xi to-xi) ?
<gagbo>Got it, had to return a (lambda () (list from-xi to-xi)) in the inner let body
<pinoaffe>I have a list with 747111 elements and need to count how often certain alphanumeric hashes occur in said list, the naive alist-based implementation is way too slow, any ideas as to what might work?
<lampilelo>make it a sorted list and use binary search? is the order important in your use-case?
<pinoaffe>order is not important, I just need to know the frequency of each hash
<pinoaffe>so yeah, I guess sorting might help
<pinoaffe>thanks!
<lampilelo>actually binary search won't work on lists
<lampilelo>so it won't help much
<lampilelo>pinoaffe: maybe you could use a hash-table that will have the count for every entry and you could increment it instead of adding new things to the list
<chrislck>pinoaffe: depends how often you want to count these hashes, one off or multiple... I guess you want (list "a" "z" "a" "b" "b") -> '(("a" . 2) ("z" . 1) ("b" . 2)) ?
<pinoaffe>chrislck: that is indeed what I want
<pinoaffe>lampilelo: well once the list is sorted, I can count occurences in linear time
<chrislck>pinoaffe: are you're willing to do a full scan of all 747111 elements once to create the secondary list? the secondary list can be a hash-table
<lampilelo>you can count them in linear time if they're not sorted too
<pinoaffe>lampilelo: only if the hash-table has constant lookup time, right?
<chrislck>that's the idea of hash-table
<chrislck>(define bins (make-hash-table)) (for-each (lambda (elt) (hash-set! bins elt (1+ (hash-ref bins elt 0)))) long-list)
<chrislck>then you can experiment what hashing function is best
<lampilelo>i mean that technically regardless of how you'll structure the data in your list - (list "a" "z" "a" "b" "b") or (("a" . 2) ("z" . 1) ("b" . 2)) - the lookup for the hash in question would have linear complexity
<lampilelo>it doesn't matter, chrislck has a good solution
<lampilelo>pinoaffe: my question is: how do you obtain your list of hashes?
<pinoaffe>chrislck: thanks, I'll try that
<chrislck>depends how often you'll update your long-list.... whether long-list will be altered in the future... how many times you'll need to access the counts etc
<pinoaffe>lampilelo: I read a list from disk as an s-expression, filter said list, then count
<chrislck>pinoaffe: you'll shorten time by accumulating the bins hash-table *as* you read from disk.
<lampilelo>yeah
<nly>just found out about this syntax: (let foo ((a 1) (b 2)) foo)
<sneek>Welcome back nly, you have 1 message.
<sneek>nly, str1ngs says: I fixed the window growth bug on completions. the echo area now wraps text. which means it now grows horizontally but that's easier to improve on later.
<nly>still wondering what's it's use
<nly>thank you str1ngs
<chrislck>nly: named let? it's one of the most versatile looping structures you can have
<nly>oh it's a named let, thanks
<nly>this was in rastache source: (let _token-print ([the-token token] [depth 0])...)
<nly>i probably should use srfi-9 records instead of racket structs
<lampilelo>named let is pretty much a recursive lambda
<str1ngs>nly: pasting now works as well \o/. the echo area has a caveat where you need to use the context menu to paste. still working on that. also when killing a buffer the controls are destroyed and it the new buffer is presented. this is feature-windows branch
<nly>nice !
<str1ngs>dont's spit windows what ever you do haha!
<nly>haha, got it.
<str1ngs>I plan to remove those key binds for now. We'll keep the single window model for now
<str1ngs>thought it's a single window model it's still using emacys windows. so the frame work is there atleast
<str1ngs>ibuffer-mode is surprising useful too
<nly>ibuffer looks a lot useful for viewing guix pkgs too
<nly>or something similar
<str1ngs>I think we can make ibuffer derive from a more generic list-buffer and then use a rich GridView.
<str1ngs>though I think we'll stick to text-buffer for now they are simple and are platform agnostic
<str1ngs>if you want to consider a bookmarks-mode that might give you an idea of what we might need
<str1ngs>nly: one thing with ibuffer-mode is I'm still trying to figure out how to syncronize emacsy buffer marks with textview. basically marking something in the emacsy buffer should mark the textview as well.
<str1ngs>right now you just hit RET on the line to switch to buffer. should be intuitive enough I think
<str1ngs>nly: I think I can merge feature-windows back into feature-g-golf now WDYT?
<nly>yes, sounds good
<str1ngs>I think that covers your bugs for now? unless you can think of anything else?
<nly>the build is still a problem i think, but i don't have a reproducible example
<nly>atm
*nly -> indian dinner, lol
<str1ngs>nly: until I can resolve the guix GI interaction issue. you can install locally with make install. and launch with ./pre-inst-env nomad. the development and installed variant use different application-id's so they wont clash. and if you use my ~/.nomad snippet you can have two repl's
<rlb>Any further thoughts about the best way to write code to work with both 2.2 and 3.0 if it needs to "replace" symbols? If I'm not misunderstanding, right now 3.0 requires #:require-and-replace to work properly, but guile 2.2 rejects that, and it doesn't look like cond-expand will work there.
<rlb>(I mean it may not "work" within the define-module.)
<rlb>s/require-and-replace/re-export-and-replace/
<rlb>wingo: ^ I suppose one option might be to add a (re-export-and-replace ...) to 3.0 and then use cond-expand after the define-module for the relevant symbols (if that would still work right).
***jr0 is now known as jr2
***jr2 is now known as jr0
***jr0 is now known as jr44
***jr44 is now known as jr0
***jr0 is now known as james
***james is now known as jr0
***jr0 is now known as jamestechnotes
***jamestechnotes is now known as jamesrichardson
***jamesrichardson is now known as jr0
***jr0 is now known as jr007`
***jr007` is now known as jr0
***gagbo_ is now known as gagbo
<oni-on-ion>hmm
<killmeplease>Is there an IDE for Guile? #guix has convinced me that it's worth a look, I'm not new to functional programming (although I have never used it for what I'd call a "real" project) I'd love to talk to someone who uses it professionally
<oni-on-ion>emacs ?
<oni-on-ion>with "geiser"
<lampilelo>and with info-lookmore for documentation on the spot
<jcowan>Someone should probably write a really pretty skinnable editor with Emacs at the core, just to get people to shut up about its alleged deficiencies.
<killmeplease>oni-on-ion: lololol good one
<oni-on-ion>jcowan, yeah. something awesome for anything geiser/slime with sexp would be great.
<lampilelo>jcowan: doom emacs?
<oni-on-ion>but emacs+paredit+{slime,geiser,skewer(js)} is quite a lot nicer than other tools already.
*jcowan laughs
<killmeplease>seriously can we stop suggesting emacs, it was funny the first time
<jcowan>It is not a joke. Emacs *is* the IDE Lispers use.
<jcowan>I see there is an Emacs Lisp plugin for Atom, though that doesn't make Atom an Emacs. But Atom would be a good target to aim at / steal from.
<jcowan>in terms of UX
<killmeplease>Fuck
<killmeplease>So don't bother with guile then it seems:(
<jcowan>Have you tried Emacs? You know the saying, I'm sure.
<killmeplease>The problem is you have to learn so much shit to do trivial tasks
<killmeplease>Say what you want about eclipse, there's still a fucktonne of menus and shit it can do that I've /never/ used but it is gradual
<lampilelo>emacs is written in c and elisp, you'll learn some functional programming stuff while learning how to configure emacs
<rlb>killmeplease: it's also the primary IDE for clojure fwiw.
<oni-on-ion>among many other langs/platforms =)
<rlb>Indeed.
<rlb>killmeplease: it may also be at least somewhat language dependent, i.e. I get the impression that it may be a much bigger deal for a language like java (the extent to which some people find the eclipse-style IDEs are even more important to them).
<rlb>(Not saying you wouldn't prefer it for guile too, just suspect the language itself factors in too.)
<killmeplease>lampilelo: maybe I don't want to learn how to configure emacs!
<killmeplease>You must be a gentoo guy. It's not the destination it's the journey right? :P You love a good set up
<killmeplease>rlb: I mainly use C++ and Python BTW. I ahven't used Eclipse for Java since 2012 ish with some Android stuff. I like it because it's generally been good to me, and I wasn't fucked when I tried to use it
<killmeplease>Like I gingerly went from text-editor-with-highlighting to more and more of what it can do
<killmeplease>rlb: in all seriousness I may love Emacs if I got to grips with it. I am not saying all you freaks are crazy or anything - no not at all, nor do I think you're dangerous so I wont just say that
<rlb>killmeplease: while I don't know much about it, if you're fine with vi-style modal bindings, I know a lot of people who use spacemacs and seem to prefer it -- I think it's a more "curated" emacs, with a large pile of packages and configuration already applied (which I think sometimes unsurprisingly makes emacs slower and/or spacemacs upgrades a bit more "exciting").
<killmeplease>But I don't want to deal with emacs + new langauge, where the language is so distant from my meat and balls of wor
<killmeplease>*work
<ft>There is nothing wrong with using guile with any random editor. Emacs just has geiser, which makes for a little tighter integration. But it's hardly required.
<rlb>Also, for whatever it's worth, I've never once regretted the time over the years I've spent learning emacs :) It's one of, if not my most, critical tool.
<killmeplease>ft: there's nothing right about it either
<ft>Says who?
<killmeplease>rlb: the people who did regret learning emacs were probably 'silenced' by those who did not, so not an easy population to sample ;)
<rlb>I'm only speaking for myself of course.
<killmeplease>ft: if you think a text-editor, unaware of context, is on par with emacs, or any IDE you're wrong, simple as that. Yes you /can/ but you could probably also flip bits in RAM using gamma rays instead, or some other retarded method - it's not better, it's retarded.
<killmeplease>Retarded comes from the Latin retardi which is someone who does retarded things
<killmeplease>So yeah nothing wrong, but nothing right either
<killmeplease>Case closed
<lampilelo>lol, emacs community is a lot more friendly than you
<lampilelo>i've never heard of someone from that community trashing any other editor
<lampilelo>if you don't want to - don't use it, we won't make you, just find an editor that suits you
<str1ngs>emacs with geiser is all you need. thinking you need to configure a whole much of emacs is a misconception.
<str1ngs>s/much/bunch
<oni-on-ion>^_^
<str1ngs>and if you use guix you don't even need to configure emacs just install emacs-geiser.
<str1ngs>so your statement is pretty biased IMHO
<str1ngs>though you might want geiser to default to guile, but that might be a small snippet. anyone in #eamcs #guile or #guix would help you with that.
<oni-on-ion>heh @ "regret learning" and 'silenced' ...
<oni-on-ion>yea geiser asks what scheme on M-x geiser, can be told to "not ask" with a default (from a list)
<spk121>for what it is worth, I never use geiser. I do use emacs, because I am used to its indentation. I wouldn't be a big deal for me to use another editor, but, I've never bothered to to figure out a different solution that does scheme indentation
<dddddd>What about drracket, anyone here uses it?
<killmeplease>lampilelo: I'm sorry if I'm not friendly enough for you - I thought were inclusive now and allowed to be our true selves :(
<killmeplease>lampilelo: I just wanted to not indulge the tone, "well actually a text editor is usable" - yeah it is, but this adds nothing.
<dddddd>Setting it to "Pretty Big" seems to do a good job with scheme code.
<oni-on-ion>what are you on about, are you making a point? this does not feel guile-related, killmeplease . just use whtever you want. no one is forcing you to do nothing. it may not make any sense to worry about or get emotionally worked up for things that are not part of your life. no one is trying to sell you anything =)
<nly>hello
<killmeplease>oni-on-ion: I apologise I was trying to explain myself to lampilelo and also remind people that bastards are people too.
<killmeplease>I'm trying to assess who is worth taking notice of and who is worth taking under advisement, 'cept for cat ern (one word, don't want to ping him) I don't recognise anyone here
<oni-on-ion>ah, well.. wait, what ?
<oni-on-ion>is this a hollywood who's-who gala party ?
<killmeplease>I don't understand
<nly>there is atleast one person who uses vim or some variant with guix, i think
<killmeplease>"no"?
<oni-on-ion>"who is worth taking notice of" ... not sure freenode irc is that kind of place. perhaps instagram ??
<holomorph>ez /ignore
<nly>i'm not him, I only know that Emacs works well.
<oni-on-ion>both true things
<killmeplease>oni-on-ion: ah... see freenode has A LOT of students on it, like the guy who went "well actually you can use a text editor" - a little inaccuracy saves a lot of explanation and it missed the point entirely. IDEs (generally) help, that's why we have them
<oni-on-ion>killmeplease, ah ok. that is also true. editing text one character at a time, and using arrow keys, is to me quite an ancient way to produce text and work with characters.
<oni-on-ion> http://danmidwood.com/content/2014/11/21/animated-paredit.html
<killmeplease>I don't do social media but I don't judge people who do either oni-on-ion - so if you take notice of people based on those I don't judge
<killmeplease>oni-on-ion: I'm a ctrl+space whore
<killmeplease>I think I probably type 1/5th to 1/3rd of the code by character count
<oni-on-ion>killmeplease, dont know. i am not commiting to any ideas of beliefs about myself. just observing the language used
<killmeplease>oni-on-ion: okay how about this:
<killmeplease>do you take notice of people proclaiming the world is flat, irrespective of their looks? (except to notice them as idiots)
<oni-on-ion>yes typing is one aspect. but there is refactoring. like moving convenient blocks of code -- paredit is a *great* tool for many uses when working with s-expressions.
<oni-on-ion>(see the animated guide examples)
<killmeplease>Writing people off as authoritative sources is a good optimisation.
<oni-on-ion>yep. dont think anyone here is being too pushy though. but have spoke what they use for IDE with guile. ^_
<killmeplease>I wouldn't call gedit and IDE right ft?
<str1ngs>are you trying to make some poor attempt at describing emacs as a text editor?
<oni-on-ion>integrated development environment, we can call the shell or terminal an IDE as well
<oni-on-ion>unix/bsd as a whole is essentially a C IDE.
<spk121>ed(1) is the one true editor
<killmeplease>str1ngs: if you dont' read what I say, I'm not sure how to answer
<killmeplease>Anyway BRB good luck
<killmeplease>str1ngs: seriously man read up, you were here when it was said
<str1ngs>seriously it's like you just walked into a Toyota dealership with a hate on for Toyota's
<lampilelo>str1ngs: it's not #emacs, so not quite
<str1ngs>okay so we are Toyota racing development :P
<oni-on-ion>okay, so he enters a race track where most drivers are in toyotas.
<oni-on-ion>=p
<gagbo>Back on track, what should I use in Guile to make TUI ? some curses bindings ?
<spk121>gagbo: guile does have some ncurses binding. Ncurses is a bit old school. I don't know if there is a more modern toolkit for TUIs.
<gagbo>hmm ok thanks
<spk121>fwiw, I am the maintainer of guile-ncurses, so feel free to reach out if you have any questions
<oni-on-ion>fwiw, emacs is nice for TUI. surprisingly: has buttons, lists, trees, images, etc.
<gagbo>I'm making a xi front-end in guile to play with the language, it's really about the software I'm making, not the one I'm using to make it :p
<gagbo>spk121: Oh, did you happen to push a guile 3.0 version on guix packages
<gagbo>?
<spk121>gagbo: it does build on 3.0. I don't maintain the guix package.
<killmeplease>str1ngs: I had no idea there was ONLY emacs?
<killmeplease>So I walked into a car dealership thinking there might be more than just ones that use internal combustion engines, but they all do - might be more apt
<killmeplease>Thanks lampilelo
<bandali>it's not ONLY emacs but emacs is very popular in the guile/guix development circles
<spk121>killmeplease: if you want an alternative, there are scheme modes for the microsoft code IDE, but, they don't have any real integration with Guile, last I checked
<killmeplease>spk121: I'm okay if the IDE doesn't interface with the language like emacs (to my knowledge) does! I'll check for Eclipse
<killmeplease>So if you mean that sort of hard core integration, yeah, also wary of using Microsoft stuff in general. Just saying of course you couldn't know this.
<oni-on-ion>well, there are a lot of text editors, if working char-by-char is fine.
<daviid>killmeplease: you should first and above all, try to use emacs+geiser or guile-studio - you have spent, here 'just' today, quite a lot more more time 'discussing things' then it would have taken you to read an introduction and/or watch one of the hunderds of tutorial videos ... I've had intern, 17y old, zero lisp/scheme knowledge, zero computer sc. background, started in 15' ...
<sneek>daviid, you have 1 message.
<sneek>daviid, RhodiumToad says: test looks ok to me
<oni-on-ion>what is this guile-studio ? could not find any info.
<daviid>RhodiumToad: tx, will push
<dsmith>Personally, I won't work on something or somewhere unless I can use emacs. Everything else is just too hard or too clumsy or too slow.
<daviid>everything else id a joke
<oni-on-ion>yea.
<daviid>*is
<nly>I am trying to do:
<nly>(make-record-type "hype" '())
<nly>(make-record-type "hype-train" '(content) write #:parent "hype")
<nly>
<killmeplease>daviid: I've gotta say programmers without formal computer science knowledge are not good things, state machines for example - a working knowledge of this is EXTREMELY important, I will admit parsing is perhaps a bit overrated.
<killmeplease>So I don't take "was taught to children" as an endorsement.
<nly>but looks like make-record-type no longer takes #:parent argument: https://www.gnu.org/software/guile/manual/guile.html#Records
<daviid>that was to answer your 'it is so difficult to learn ...'
<daviid>but i'm off the conversatin, it is a complete total loss of time, afaic, good luck with eclispe ...
*dsmith shudders
<killmeplease>daviid: those of us with productive IDEs can afford the time I have "wasted" here it seems ;)
<oni-on-ion>write a blog post about it
<killmeplease>Hope this channel has a burn ward
<dustyweb>killmeplease: I'd rather have people be nice than have a burn ward though
<killmeplease>oni-on-ion: I don't do that either, blogs are not authoritative sources
<killmeplease>yeah daviid be nice
<eta-expanse>such troll
<oni-on-ion>WRITE the post. YOU are the authority for your own world. ^_^
<killmeplease>oni-on-ion: you mean notes?
<oni-on-ion>whatever you are talking about here
<oni-on-ion>expressing opinions and stuff. we all have 'em
<dustyweb>I think we also shouldn't be dismissive of people who don't have a formal CS background. I wasn't one, and gained a CS background participaing with this community largely
<oni-on-ion>isnt that why people blog ? because then we get the audience that wants to hear about it.
<killmeplease>dustyweb: formal CS background and formal CS study are different things
<oni-on-ion>dustyweb, i relate to this ^_^
<dustyweb>a lot of programmers start out as glue programmers. Some programmers only do glue programming; there's so much to be done that honestly you can do a lot of valuable work that way
<dustyweb>if people were really hard on me for not having a formal CS background when I came in here
<dustyweb>I wouldn't have picked one up by participating
<dustyweb>so I really like to be welcoming to everyone
<dustyweb>get people excited
<killmeplease>But it can't be denied there's a massive deterioration in software quality and terms like hard core real time are being massive diluted - things like control systems are an entire area of formal study, not some if statements
<dustyweb>that's how to improve the world
<oni-on-ion>this convo will be endless. like putting quarters in the plastic horse at the mall . but it does not go anywhere
<killmeplease>oni-on-ion: mathematics has proofs, yet it also does not go anywhere
<oni-on-ion>^ thx for the example.
*nly (define-record-type name *ctor* pred fields) ;; wishes it was ctor -> constructor
<killmeplease>It was a counter example oni-on-ion!
<killmeplease>If it has a proof there is no talk to be had, it is done.
<oni-on-ion>killmeplease, it was an example of putting quarters in the horse. for feeding the aimless convo. i thank for the example which had proved this nicely
<killmeplease>oni-on-ion: "QED motherfucker" what you say when you're arguing with someone in maths, and they just have to take it 'cos it's proved!
<oni-on-ion>its a lot of politics of the state of tech and human-computer interaction and etc, there could be much to talk about. there "is" a lot to talk about =)
<str1ngs>the TLDR version of this conversation. Hi what IDE should I use for guile. Answer is emacs. proceed to now bash emacs
<oni-on-ion>going to have to back out
<oni-on-ion>=p
<killmeplease>str1ngs: where did I once bash emacs?
*eta-expanse inserts quarter
*killmeplease rides eta-expanse
<killmeplease>quarter of what BTW?
<killmeplease>I can't think of anything other than a certain shaft.
<dustyweb>killmeplease: ok, stop
<killmeplease>so seriously now, if we can stop hazing the new guy, it really is /just/ emacs?
<nly>well, Guile has a certain DIY culture. So, just like everybody uses different programming libs, it might be fine to use whatever IDE you like, but as you can see most people are happy with Emacs, doesn't mean you cannot use whatever you like.
<killmeplease>nly: oh not this again
<nly>>just emacs
<nly>yes
<killmeplease>"just emacs" as in "something which could be called emacs" 'cos there's like 13 different emacs before plugins and stuff
<str1ngs>not once did I bash emacs did he say :P
<killmeplease>I didn't!
<nly>this one: killmeplease: gnu.org/s/emacs
<nly> https://www.gnu.org/software/emacs/*
<killmeplease>nly: or any other emacs 'cos there's loads
<nly>killmeplease: sure, i could guide you with the plugins and basic config
<str1ngs>for this you dont' really need much just emacs and *maybe* geiser
<killmeplease>Maybe in the future
<dustyweb>Emacs is the only editor with super nice support. If you prefer vim keybindings, there's the spacemacs emacs configuration suite
<nly>>Maybe in the future
<nly>sure :)
<str1ngs>maybe is progress from never at-least :)
<nly>hi dustyweb: I love the ircbot in 8sync
<dustyweb>hi nly
<dustyweb>thanks
<nly>is there any authentication mechanism
<dustyweb>nly: no... it's pretty demo-quality ;P
<str1ngs>dustyweb: yes I was also looking at your haunt.scm for 8sync will be useful later.
<killmeplease>dustyweb: lets not bring up vim either
<dustyweb>str1ngs: cool, hope it's helpful
<dustyweb>I've learned a lot since starting work on Spritely
<dustyweb>I hope to bring what I've been building in Racket-land back over to Guile soon
<killmeplease>str1ngs: I'm not going to reject the gracious offer of help from nly outright, it's sensible for me to keep it as an option, but right now... I've got enough pain to fight through
<dustyweb>but I want the distributed programming stuff to work first
<lampilelo>killmeplease: what do you use for programming in c++ and python?
<killmeplease>Eclipse
<killmeplease>Again
<str1ngs>nly: I wonder if we could use 8sync in place of emacy's agenda thingy
<nly>dustyweb: thanks
<nly>str1ngs: no idea
<nly>ah, yes, i guess
<killmeplease>lampilelo: eclipse CDT, PyDev
<killmeplease>and sometimes PHP - but only in small bursts otherwise it makes me want to join ISIS
<killmeplease>...
<dustyweb>killmeplease: heya, I've asked it before already; I'm asking again for you to tone it down a little.
<killmeplease>Tone what down?
<killmeplease>I was asked a question
<dustyweb>the bombastic way you're saying everything, particularly references to unrequested sexual actions and violence, and the large amount of dismissiveness
<dustyweb>it's not needed and changes the tone of this place
<killmeplease>sexual what?
<dustyweb>* eta-expanse inserts quarter
<dustyweb>* killmeplease rides eta-expanse
<dustyweb><killmeplease> quarter of what BTW?
<dustyweb><killmeplease> I can't think of anything other than a certain shaft.
<killmeplease>rides as in "on the back of a horse"
<dustyweb>then what's the "certain shaft"
<killmeplease>And I don'tknow WTF the quarter is a reference to even now
<killmeplease>I didn't mean putting a quarter of my dick in eta-expanse seriously I have no idea how you got that from it
<eta-expanse>i regret engaging with this person at all
<killmeplease>Yeah that's why I phrased it that way
<killmeplease>I was trying to be tactful
<killmeplease>If quater horse riding is a beastality thing this is honestly news to me (and I am surprised too - I didn't think it would be a "certain shaft" which is why I asked) - I was not the first to bring that up
<eta-expanse>maybw best to cool off and post somewhere else for a bit killmeplease
<killmeplease>It was you and oni-on-ion though not me
<dustyweb>killmeplease: how about this
<dustyweb>hard reset
<dustyweb>just be nice.
<dustyweb>requesting now
<killmeplease>I'll do my best :)
<dustyweb>okay, thanks.
<dsmith>It's good to remember that not everyone here is a native english speaker.
<malaclyps>I'm trying to install a software package in git that has a guix.scm -- I've tried `guix build --install-from-file ./guix.scm` but there are two packages defined in the guix.scm, so it is returning a list of packages, not a single one to install. How do I specifiy just one of the packages?
<malaclyps>oops! sorry, wrong channel
<dustyweb>malaclyps: :)
<malaclyps>hah! hi, dustyweb!
<dustyweb>heya malaclyps
*dustyweb is writing an email to cap-talk trying to figure out if intuitive ocap-safe macros are possible... thinks they have figured out such a system
<killmeplease>Who's they? The cap-talk people?
<eta-expanse>killmeplease: just stop
<killmeplease>?
<killmeplease>I think I'm misreading it
<malaclyps>dustyweb, I chatted with a few folks internally at EFF about the crypto autonomy license.
<malaclyps>it's a little frustrating to have missed the main discussion, but that's on me: I hadn't realised all the ramifications until you pointed it out
<killmeplease>anywhere I can read up on this?
<killmeplease>I'm just curious so if it'd be difficult to find don't bother
<malaclyps>anyway, it's part of a broader attempt to understand if there are any wider ramifications (negative, positive) to copyright activism wrt people's new experimentation with licenses
<malaclyps>meanwhile, back to guix/guile!
<killmeplease>malaclyps: I know the FSF has been looked at negatively for not "looking after" copyright assigned to it. Any relation?
<dustyweb>killmeplease: different issue, not really about copyright stewardship but stewardship of a list of licenses on the osi license list
<dustyweb>malaclyps: I plan on writing up more on what I think about the scope of FOSS licenses should be
<dustyweb>as well as some framing about free software through the lens of agency
<dustyweb>malaclyps: would you be interested in reviewing before I posting?
<malaclyps>dustyweb, sure!
<killmeplease>Oh that clusterfuck, I don't envy you guys. The worst thing is that these license guides are largely untested
<killmeplease>Fortunately in most cases it is clearly stated what the intention of the license is, so the spirit or motivation is clear
<killmeplease>I do not envy you at all malaclyps - then there's the international issues
<killmeplease>Nor you dustyweb it's a very tough area, good luck
<killmeplease>BTW malaclyps / dustyweb there's a project called wxWidgets (WX4LIFE) it was called wxWindows but Microsoft wanted to be more like oracle and was going through a phase. The license wording is the same and the wxWindows license is OSI approved. It JUST changed its name
<killmeplease>Any hope of that getting done?
<killmeplease>It changed its name years ago too.
<killmeplease>All this was before 2005
<killmeplease>dustyweb: malaclyps the last I'll say of it is this: the wxWidgets project states in a few places "the wxWindows license was OSI approved, it's the same license but the name changed, we have written to the OSI about resubmission" in a few places - as you're here, maybe you can help me get something done. wx is a geat and alive project, also screw qt (I didn't use the "F" word there and it should be F'ed hard)
<eta-expanse>killmeplease you're dominating this channel with comments that make me very uncomfortable
<holomorph>plonk and move on, it's easy
<nly>is there any order-independent match in guile?
<killmeplease>eta-expanse: how?
<killmeplease>eta-expanse: if you tell me how I can stop
<killmeplease>What should I do? Bring it up when he returns?
<malaclyps>killmeplease, I think I can see what you're doing. If you don't mind going quiet on this channel for a bit, I can discuss it with you in private messages?
<chrislck>nly: order-independent (ice-9 match)? how/why would this be useful?
<killmeplease>Sure please do [not sure what I'm doing BTW, but I can find out there]
<nly>chrislck: your point makes sense, it's just some code i found, that looks buggy, but it can't be right?
<chrislck>show
<nly> https://git.piviq.ga/rastache.git/tree/rastache/commons.rkt?h=guile-port2#n130
<nly>procedure: rast-ref*
<chrislck>it's definitely not orderindependent
<nly>i would think if keys 'ks' were (list 'a 'b) then the 2nd match would be ideal, but first would also match.
<nly>oh, ok
<chrislck>racket/match uses (list k) whereas (ice-9 match) uses (k)
<nly>yup, thank you
<nly>:)
<chrislck>yw