IRC channel logs

2020-02-11.log

back to list of logs

<daviid>str1ngs: how about resolving the problems pointed by the message?
<daviid>adding a command-signal signal handler and what is this does not implement g_application_command_line() ... i have no idea
<str1ngs> well like I've been trying to explain the message should not happens since 'open is connected.
<daviid>str1ngs: i would try that first
<daviid>i trust these messages
<str1ngs>try which?
<str1ngs>I don't need command-line since I'm using 'open which satisfies this. the C example does work it's pretty much on par with the scheme example
<daviid>str1ngs: we have to try something right? how about adding a command-lind signal, then we'd figure out if that solves, or not, and why is it that usig g-golf the 'open is not sufficiant ...
<str1ngs>the problem is the 'command-line and 'handle-local-options greatly complicates things. where 'open does not. so I'm not sure how else to address this. For now I have just set the flags from C and that resolves it. then even the 'open signal works from scheme. but with out Gfile *files which is another issue. from everthing I've looked at there is an issue with setting 'flags from scheme but I don't know enough about g-golf to trace the
<str1ngs>probleme.
<rekado_>hey there, is it possible to define a GOOPS object that can be applied as a procedure?
<rekado_>I tried defining “apply” as a method, but that doesn’t work
<rekado_>apply-generic exists but just doing ((make <thing>)) throws an error.
<daviid>str1ngs: i'm going to ask for some ideas/hints on introspection
<RhodiumToad>rekado_: yes it is
<RhodiumToad>(someone else asked that recently and I worked out how)
<daviid>setting flags 'per se' works fine, afaict, but ... this might be a 'corner cae'
<RhodiumToad>rekado_: make it a subclass of <applicable-struct> or <applicable-struct-with-setter>
<rekado_>RhodiumToad: ah, neat! Thank you!
<RhodiumToad>rekado_: I have a working example if you want to see?
<rekado_>yes, that would be great!
<str1ngs>if you see my C example there is no 'commad-line signale only 'open. no need to run it I can confirm it works
<RhodiumToad> https://dpaste.org/p4NC <-- it got a bit tab-damaged, sorry, and it uses srfi-88 because I prefer it
<str1ngs>daviid: ^^
<str1ngs>daviid: I will join #introspection maybe it would help if I understand g-gofl internals beter
<daviid>str1ngs: i was trying to convince you to just try adding a command-line signal
<str1ngs>I have that satisfies the error but does not satify my use-case.
<daviid>it is a debug attempt, not a full solution to the problem ...
<str1ngs>where is 'open should satisfy not having the error at all as well
<rekado_>RhodiumToad: thank you for the example!
<RhodiumToad>yw
***daviid is now known as Guest61326
***daviid` is now known as daviid
<daviid>str1ngs: i was actually working on something else, before we spoke about the WebkitUserMessage argument problem, so I decided to finalize that work, i jst pushed it, which about <gdk-event-crossing>, the widget enter and leave notify events
<daviid>here is an example http://paste.debian.net/1130118/
<daviid>both the window and the button track the signal ... just to show all widget subclass instances can track those signals ...
<daviid>str1ngs: now I want to solve the g-closure-marshal-g-value-ref bug, then I wish to solve the gtk-init, clutter-init and g-application-run argc/argv problem, then i'll try to solve the 'open signal (somewhat hidden) bug
<daviid>str1ngs: here is an attempt to solve the g-closure arg rlated problem: http://paste.debian.net/1130120/
<daviid>could you please try and tell me if it works? here it compiles fine, but as you knw, I can't try it ... let me know ... thanks
<str1ngs>daviid: the new g-closure-marshal-g-value-ref looks good now. **** class-of #<<gobject-class> <webkit-user-message> 7f6dfe848e60>
<daviid>str1ngs: great
<str1ngs>daviid: what was the status of GVariant again?
<daviid>str1ngs: no binding for GVariant
<str1ngs>okay mean time I can use webkit_user_message_get_name () for message passing that helps thanks
<str1ngs>can you ping me when you push that. I was using REPL socket it will be easier integrate this better from an installed package. REPL is nice. but not so much when you have state and moving parts :)
<str1ngs>thanks for looking at this BTW
<daviid>str1ngs: will push asap, prob toorrow, will let you know yes
<str1ngs>daviid: regards to the your TODO list sounds like a good plan. the gtk-init argv issue is a logical step. and we can revisit that flag issue later. it's definitely not acting as expected though but with argv in place. I put a better example together for you.
<str1ngs>thanks for looking at this it's much appreciated.
<daviid>wc!
<rlb>Is anyone using pfds much with 2.2 or 3.0, in particular hamt-fold?
<rlb>(I just hit an assertion failure in both versions for fold when I go from a two element to three element map.)
<rlb>Might just have something wrong, but for example: https://paste.debian.net/hidden/1f1c9d14/
***jonsger1 is now known as jonsger
<roelj>What's the most efficient way to write data coming from an input port to an output port? (basically passing a stream of data from one port to another)
<dsmith-work>Morning Greetings, Guilers
<d4ryus>roelj: guile has pipe, but not sure how efficient it is
<roelj>d4ryus: That looks exactly like what I need. Thanks! :)
<dsmith-work>roelj: If going from a file to a socket, sendfile is probably fastest, but I don't know if guile exposes that.
<roelj>dsmith-work: Ayeah, like Guix does as well. Unfortunately, I am passing data from one network socket to another.
<dsmith-work>s/fastest/most effient/
<civodul>roelj: sendfile works when both the source and destination are "file ports", such as sockets
<civodul>so you should be able to use it
<roelj>civodul: What if I don't know how many bytes are being sent?
<roelj>repeat with N bytes until all is transferred?
<civodul>roelj: or 'stat' the source port?
<civodul>if you know it's a file port
<civodul>and not a socket
<civodul>hmm
<roelj>How does sendfile handle EOF?
<civodul>not sure
<civodul>i think it returns the number of bytes actually sent and everything's fine
<civodul>but you'd need to try or check the code
<roelj>what's a good paste website?
<roelj>I have an example code
<roelj>Ah, it indeed works
<roelj>(while (> (sendfile out in (expt 2 12)) 0))
<roelj>nice!
<dsmith-work>Sweet
<dsmith-work>civodul: Didn't realize it would do socket->socket
<dsmith-work>civodul: Did some high performance embedded a while back and used splice. Implemented it in our kernel driver.
<civodul>dsmith-work: nice, i haven't used splice
<civodul>sendfile is a must for web servers
<dsmith-work>civodul: This new io_uring looks *very* intereting. Wish I had it back then. (I don't work there anymore)
<jcowan>dsmith-work: What we have here is the progressive reinvention of TOPS-10 and earlier operating systems
<jcowan>One of the design principles of Unix is that other than the locations actually read or written by read() and write(), there were no kernel data structures in user space where they could be cabbaged by userland randomness.
<dsmith-work>jcowan: Yeah. The open,close,read,write interface is *so* simple and clean.
<daviid>str1ngs: I pushed the patch to the devel branch
<str1ngs>daviid: great thanks, will pull
<daviid>str1ngs: g-closure-marshal-g-value-ref will need to be further improved, to properly handle all other 'interface' types, keep this in mind, so if you come to a 'similar' error while using signal(s), it probably will be a missing type conversion in g-closure-marshal-g-value-ref
<str1ngs>daviid thanks I keep that in mind. I'll assuming it will be a <boolean> such as this case then?
<daviid>str1ngs: not necessarily, but it definitely will be an inadequate value, you'll spot it ...
<str1ngs>understandable. thank you
<str1ngs>daviid looks good. this greatly simplifies message passing between the webview and web process. I don't need to create my own client/server dbus implementation now :)
<daviid>str1ngs: great
***ng0_ is now known as ng0